xournal / gdk_event_get_coords bug in 7.10 gutsy

Bug #134475 reported by Andrew Frank
4
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Invalid
Undecided
Unassigned
xournal (Ubuntu)
Fix Released
Undecided
Vincenzo Ciancia

Bug Description

Binary package hint: xournal, libgtk

when opening the xournal application it works, till one moves to the next page or moves the page down. then the insertion point is not at the stylus point, but lower (it seems that it writes twices as much lower than the stylus as the move was - i guess it is a sign problem.)
the problem is not present with feisty
but under gutsy - so it could be in one of the libraries.

It appears that the precompiled 64-bit gtk/gdk libraries do not work correctly on all platforms.

Related branches

Revision history for this message
Andrew Frank (frank-geoinfo) wrote :

could somebody please look into this - xournal is crucial for the use of 7.10 on a tablett computer (one of the targets of 7.10?).

any additional information you require to track this?

Revision history for this message
khul (klas-hultqvist) wrote :

I see exactly the same behaviour. The stylus works for selecting windows etc, and the "write" cursor is at the tip of the stylus, but the line you draw appears further down, and the shift is larger the more pages you scroll down (it's OK on the first page). Xournal worked fine with Feisty (on an hp tc4400).

Revision history for this message
khul (klas-hultqvist) wrote :

I dowloaded xournal 0.4 from sourceforge and compiled it (the Gutsy vsn is 0.3.3).

With 0.4 it seems to work OK for the first few pages, but when I try to write something to a page after page 16 the page number at the bottom left changes to 16 (but the displayed page does not change) and the text I write is not visible. It is inserted on page 16 instead.

Revision history for this message
khul (klas-hultqvist) wrote :

Xournal calls

gdk_event_get_coords(event, &x, &y);

to find the position in the file where you write. This function returns a y which rises linearly with the position within the first sixteen pages, but then stays almost constant over many pages. Looks like a GTK bug.

Revision history for this message
khul (klas-hultqvist) wrote :

I downloaded the source for gtk+2.0-2.11.6 and replaced the libgtk-x11-2.0 and libgdk-x11-2.0 libraries with locally compiled ones. This made both xournal 0.4 and 0.3.3 work without losing the insertion point.

I'm using X86_64 on a tc4400 with intel core 2 duo.

khul (klas-hultqvist)
description: updated
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

It seems to me a gtk bug too. I have this bug with version 0.4, too, not only from page 16. To test, open a new document, scroll down the page a bit, and then try to write something (even using the mouse). This is really a showstopper for tablet pcs on ubuntu, I think it should be considered high priority for that reason, since xournal is the only tablet pc app in ubuntu.

Revision history for this message
Andrew Frank (frank-geoinfo) wrote : Re: [Bug 134475] Re: xournal / gdk_event_get_coords bug in 7.10 gutsy

this bug is fixed in the new version 0.4.0.1
needs to be integrated in ubuntu repositories, but works flawlessly
with gutsy tribe 5

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

Hmm, even tough I stated the opposite above (must have mistakenly tried 3.3 thinking it was 0.4) I can confirm that on 0.4.0.1 it works. I already have set up everything to upload 0.4.0.1, that would pass trough my PPA and then be sponsored for universe by someone. However, I would like to fix bug #137944 first, so that we fix all of the three bugs opened for xournal, with a single upload.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

If you have i386 you can check the binary package I provided at

http://www.di.unipi.it/~ciancia/content/deb/xournal_0.4.0.1ubuntu1_i386.deb

It can't be uploaded in this state, since I applied the patch directly, but it should work reasonably, let me know.

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

xournal (0.4.0.1ubuntu1) gutsy; urgency=low

  * New upstream release.
  * debian/docs: Add html-doc.
  * debian/xournal.desktop: add mimetype application/pdf which is handled by xournal.
  * Fixes (LP: #95045)
  * Fixes (LP: #134475)
  * Fixes (LP: #137944)
  * Fixes (LP: #137934)
  * Fixes (LP: #137935)

 -- Vincenzo Ciancia <email address hidden> Fri, 07 Sep 2007 12:26:22 +0200

Changed in xournal:
status: New → Fix Released
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

LP closes bugs that are claimed fixed in PPAs, this is a bug in launchpad. Didn't mean to mark the bug as fixed.

Changed in xournal:
status: Fix Released → Confirmed
Changed in xournal:
assignee: nobody → vincenzo-ml
Changed in gtk+2.0:
status: New → Invalid
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

xournal (0.4.1-0ubuntu1) gutsy; urgency=low

  * New upstream release
    Fixes (LP: #95045)
    Fixes (LP: #134475)
    Fixes (LP: #137934)
    Fixes (LP: #137944)
  * Replace ubuntu shipped .desktop file with the upstream provided one.
  * Install application and mimetype icons in proper directories
  * debian/docs: Add html-doc.

 -- Vincenzo Ciancia <email address hidden> Tue, 18 Sep 2007 14:04:07 +0200

Changed in xournal:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers