xmms-osd-plugin: Crashes xmms after a short time

Bug #7463 reported by Debian Bug Importer on 2004-08-16
16
Affects Status Importance Assigned to Milestone
xosd (Debian)
Fix Released
Unknown
xosd (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #265561 http://bugs.debian.org/265561

Package: xmms-osd-plugin
Version: 2.2.8-5
Followup-For: Bug #265561

  I see a similar problem. I've seen problems that occur randomly, but
I can also reproducibly segfault XMMS just by trying to play certain
files. This started just recently (ie, since the recent OSD upload) and
disabling the OSD plugin cured it.

  Daniel

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.7
Locale: LANG=en_US, LC_CTYPE=en_US (ignored: LC_ALL set to en_US)

Versions of packages xmms-osd-plugin depends on:
ii libc6 2.3.2.ds1-16 GNU C Library: Shared libraries an
ii libgdk-pixbuf2 0.22.0-6 The GdkPixBuf image library, gtk+
ii libglib1.2 1.2.10-9 The GLib library of C routines
ii libgtk1.2 1.2.10-17 The GIMP Toolkit set of widgets fo
ii libice6 4.3.0.dfsg.1-6 Inter-Client Exchange library
ii libsm6 4.3.0.dfsg.1-6 X Window System Session Management
ii libx11-6 4.3.0.dfsg.1-6 X Window System protocol client li
ii libxext6 4.3.0.dfsg.1-6 X Window System miscellaneous exte
ii libxi6 4.3.0.dfsg.1-6 X Window System Input extension li
ii libxosd2 2.2.8-5 X On-Screen Display library - runt
ii libxt6 4.3.0.dfsg.1-6 X Toolkit Intrinsics
ii xlibs 4.3.0.dfsg.1-6 X Window System client libraries m
ii xmms 1.2.10-1 Versatile X audio player that look

-- no debconf information

forwarded 265561 Tim Wright <email address hidden>
tags 265561 + patch
tags 265561 + fixed
thanks

Hi!

On Sat, Aug 14, 2004 at 03:20:54PM -0400, Daniel Burrows wrote:
> I see a similar problem. I've seen problems that occur randomly, but
> I can also reproducibly segfault XMMS just by trying to play certain
> files. This started just recently (ie, since the recent OSD upload) and
> disabling the OSD plugin cured it.

If you'd like to help me a little, grab xosd_2.2.9-pre1 from
http://pint.pmhahn.de/pmhahn/debian/sid/x/xosd/
and give that a try. Works for me.
Upstream has promised me to release a new version this week, so I'm
delaying upload to unstable and will upload it only to experimental to
not further burden Debians build-daemons.

BYtE
Philipp
--
Philipp Matthias Hahn <email address hidden>
 GPG/PGP: 9A540E39 @ keyrings.debian.org

tags 265561 - fixed
thanks

On Mon, Aug 16, 2004 at 05:57:46PM +0200, Philipp Matthias Hahn <email address hidden> was heard to say:
> On Sat, Aug 14, 2004 at 03:20:54PM -0400, Daniel Burrows wrote:
> > I see a similar problem. I've seen problems that occur randomly, but
> > I can also reproducibly segfault XMMS just by trying to play certain
> > files. This started just recently (ie, since the recent OSD upload) and
> > disabling the OSD plugin cured it.
>
> If you'd like to help me a little, grab xosd_2.2.9-pre1 from
> http://pint.pmhahn.de/pmhahn/debian/sid/x/xosd/
> and give that a try. Works for me.

  It seems to work for me. I don't think you want to set the "fixed"
tag, though, as this bug hasn't been fixed. Maybe you meant "pending"?

  Daniel

--
/-------------------- Daniel Burrows <email address hidden> -------------------\
| "If you want a picture of the future, imagine a boot |
| stamping on a human face -- forever." -- 1984 |
\------- (if (not (understand-this)) (go-to http://www.schemers.org)) --------/

tag 265561 + fixed-in-experimental

quit

This message was generated automatically in response to an
upload to the experimental distribution. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 16 Aug 2004 17:57:56 +0200
Source: xosd
Binary: libxosd-dev xmms-osd-plugin xosd-bin libxosd2
Architecture: source i386
Version: 2.2.9-pre1-1
Distribution: experimental
Urgency: low
Maintainer: Philipp Matthias Hahn <email address hidden>
Changed-By: Philipp Matthias Hahn <email address hidden>
Description:
 libxosd-dev - X On-Screen Display library - development
 libxosd2 - X On-Screen Display library - runtime
 xmms-osd-plugin - XMMS plugin using xosd
 xosd-bin - X On-Screen Display library - binary files
Closes: 265561
Changes:
 xosd (2.2.9-pre1-1) experimental; urgency=low
 .
   * New upstream version.
     - Applied my 0..30/26 patches, remove all expect 26_one_line.diff.
   * 31_segv.diff: Crashes xmms after a short time (closes: #265561)
Files:
 327360d3f9505696adf0ee1bf3983382 756 x11 optional xosd_2.2.9-pre1-1.dsc
 ad84f6654f0b8a7161df28ef01013fbb 398273 x11 optional xosd_2.2.9-pre1.orig.tar.gz
 b46c33df4c1e88278d872e08adb8ef9e 29513 x11 optional xosd_2.2.9-pre1-1.diff.gz
 c3722622443c195c5312e0c26bf55616 24902 libs optional libxosd2_2.2.9-pre1-1_i386.deb
 5c0c1b5940937994863cdec8e7424c51 36208 libdevel optional libxosd-dev_2.2.9-pre1-1_i386.deb
 338b58bd7513716757e9d1da24235f0d 18214 x11 optional xosd-bin_2.2.9-pre1-1_i386.deb
 543376b95806520dc690677a710d2007 33106 sound optional xmms-osd-plugin_2.2.9-pre1-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBINpEYPlgoZpUDjkRAmTRAKCg6B/unnccConwv1CDwDYt1AM8hQCfZFcF
rWhZUKUYuRaP3gAHy4CR4FI=
=7XFC
-----END PGP SIGNATURE-----

reassign 252170 xosd
reassign 265561 libxosd2
merge 265561 266076
thanks

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #265561 http://bugs.debian.org/265561

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Fri, 13 Aug 2004 19:36:30 +0100
From: Stuart Rowan <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: xmms-osd-plugin: Crashes xmms after a short time

Package: xmms-osd-plugin
Version: 2.2.8-5
Severity: grave
Justification: renders package unusable

It causes xmms to segfault shortly after startup. Rapid changing of songs
(and hence using OSD to display the new song title) will mean experiencing
the segfault quicker. XMMS has to be forcibly killed from the command line
once it crashes (killall xmms).

Thanks for your packaging efforts. I certainly appreciate the very useful
osd-plugin.

I originally thought this was bug #265230 but I have since worked out that
if I disable the osd-plugin no crashing occurs and as soon as I enable it
again (in the xmms preferences), xmms segfaults. The strace I left at bug
#265230
will, I hope, be useful:

http://bugs.debian.org/cgi-bin/bugreport.cgi/xmms-crash.txt.gz?bug=265230&msg=6&att=1

Please let me know if you need any further assistance tracking this one
down.

Cheers,
Stu.
-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.7
Locale: LANG=en_GB, LC_CTYPE=en_GB (ignored: LC_ALL set to en_GB)

Versions of packages xmms-osd-plugin depends on:
ii libc6 2.3.2.ds1-16 GNU C Library: Shared libraries an
ii libgdk-pixbuf2 0.22.0-5 The GdkPixBuf image library, gtk+
ii libglib1.2 1.2.10-9 The GLib library of C routines
ii libgtk1.2 1.2.10-17 The GIMP Toolkit set of widgets fo
ii libice6 4.3.0.dfsg.1-6 Inter-Client Exchange library
ii libsm6 4.3.0.dfsg.1-6 X Window System Session Management
ii libx11-6 4.3.0.dfsg.1-6 X Window System protocol client li
ii libxext6 4.3.0.dfsg.1-6 X Window System miscellaneous exte
ii libxi6 4.3.0.dfsg.1-6 X Window System Input extension li
ii libxosd2 2.2.8-5 X On-Screen Display library - runt
ii libxt6 4.3.0.dfsg.1-6 X Toolkit Intrinsics
ii xlibs 4.3.0.dfsg.1-6 X Window System client libraries m
ii xmms 1.2.10-1 Versatile X audio player that look

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sat, 14 Aug 2004 15:20:54 -0400
From: Daniel Burrows <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: Me too

Package: xmms-osd-plugin
Version: 2.2.8-5
Followup-For: Bug #265561

  I see a similar problem. I've seen problems that occur randomly, but
I can also reproducibly segfault XMMS just by trying to play certain
files. This started just recently (ie, since the recent OSD upload) and
disabling the OSD plugin cured it.

  Daniel

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.7
Locale: LANG=en_US, LC_CTYPE=en_US (ignored: LC_ALL set to en_US)

Versions of packages xmms-osd-plugin depends on:
ii libc6 2.3.2.ds1-16 GNU C Library: Shared libraries an
ii libgdk-pixbuf2 0.22.0-6 The GdkPixBuf image library, gtk+
ii libglib1.2 1.2.10-9 The GLib library of C routines
ii libgtk1.2 1.2.10-17 The GIMP Toolkit set of widgets fo
ii libice6 4.3.0.dfsg.1-6 Inter-Client Exchange library
ii libsm6 4.3.0.dfsg.1-6 X Window System Session Management
ii libx11-6 4.3.0.dfsg.1-6 X Window System protocol client li
ii libxext6 4.3.0.dfsg.1-6 X Window System miscellaneous exte
ii libxi6 4.3.0.dfsg.1-6 X Window System Input extension li
ii libxosd2 2.2.8-5 X On-Screen Display library - runt
ii libxt6 4.3.0.dfsg.1-6 X Toolkit Intrinsics
ii xlibs 4.3.0.dfsg.1-6 X Window System client libraries m
ii xmms 1.2.10-1 Versatile X audio player that look

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 16 Aug 2004 17:57:46 +0200
From: Philipp Matthias Hahn <email address hidden>
To: Daniel Burrows <email address hidden>, <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#265561: xmms-osd-plugin: Crashes xmms after a short time

forwarded 265561 Tim Wright <email address hidden>
tags 265561 + patch
tags 265561 + fixed
thanks

Hi!

On Sat, Aug 14, 2004 at 03:20:54PM -0400, Daniel Burrows wrote:
> I see a similar problem. I've seen problems that occur randomly, but
> I can also reproducibly segfault XMMS just by trying to play certain
> files. This started just recently (ie, since the recent OSD upload) and
> disabling the OSD plugin cured it.

If you'd like to help me a little, grab xosd_2.2.9-pre1 from
http://pint.pmhahn.de/pmhahn/debian/sid/x/xosd/
and give that a try. Works for me.
Upstream has promised me to release a new version this week, so I'm
delaying upload to unstable and will upload it only to experimental to
not further burden Debians build-daemons.

BYtE
Philipp
--
Philipp Matthias Hahn <email address hidden>
 GPG/PGP: 9A540E39 @ keyrings.debian.org

Debian Bug Importer (debzilla) wrote :

Message-ID: <20040816161845.GA4404@torrent>
Date: Mon, 16 Aug 2004 12:18:45 -0400
From: Daniel Burrows <email address hidden>
To: Philipp Matthias Hahn <email address hidden>
Cc: <email address hidden>, <email address hidden>
Subject: Re: Bug#265561: xmms-osd-plugin: Crashes xmms after a short time

tags 265561 - fixed
thanks

On Mon, Aug 16, 2004 at 05:57:46PM +0200, Philipp Matthias Hahn <email address hidden> was heard to say:
> On Sat, Aug 14, 2004 at 03:20:54PM -0400, Daniel Burrows wrote:
> > I see a similar problem. I've seen problems that occur randomly, but
> > I can also reproducibly segfault XMMS just by trying to play certain
> > files. This started just recently (ie, since the recent OSD upload) and
> > disabling the OSD plugin cured it.
>
> If you'd like to help me a little, grab xosd_2.2.9-pre1 from
> http://pint.pmhahn.de/pmhahn/debian/sid/x/xosd/
> and give that a try. Works for me.

  It seems to work for me. I don't think you want to set the "fixed"
tag, though, as this bug hasn't been fixed. Maybe you meant "pending"?

  Daniel

--
/-------------------- Daniel Burrows <email address hidden> -------------------\
| "If you want a picture of the future, imagine a boot |
| stamping on a human face -- forever." -- 1984 |
\------- (if (not (understand-this)) (go-to http://www.schemers.org)) --------/

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Mon, 16 Aug 2004 12:17:21 -0400
From: Philipp Matthias Hahn <email address hidden>
To: <email address hidden>
Cc: Philipp Matthias Hahn <email address hidden>
Subject: Fixed in upload of xosd 2.2.9-pre1-1 to experimental

tag 265561 + fixed-in-experimental

quit

This message was generated automatically in response to an
upload to the experimental distribution. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 16 Aug 2004 17:57:56 +0200
Source: xosd
Binary: libxosd-dev xmms-osd-plugin xosd-bin libxosd2
Architecture: source i386
Version: 2.2.9-pre1-1
Distribution: experimental
Urgency: low
Maintainer: Philipp Matthias Hahn <email address hidden>
Changed-By: Philipp Matthias Hahn <email address hidden>
Description:
 libxosd-dev - X On-Screen Display library - development
 libxosd2 - X On-Screen Display library - runtime
 xmms-osd-plugin - XMMS plugin using xosd
 xosd-bin - X On-Screen Display library - binary files
Closes: 265561
Changes:
 xosd (2.2.9-pre1-1) experimental; urgency=low
 .
   * New upstream version.
     - Applied my 0..30/26 patches, remove all expect 26_one_line.diff.
   * 31_segv.diff: Crashes xmms after a short time (closes: #265561)
Files:
 327360d3f9505696adf0ee1bf3983382 756 x11 optional xosd_2.2.9-pre1-1.dsc
 ad84f6654f0b8a7161df28ef01013fbb 398273 x11 optional xosd_2.2.9-pre1.orig.tar.gz
 b46c33df4c1e88278d872e08adb8ef9e 29513 x11 optional xosd_2.2.9-pre1-1.diff.gz
 c3722622443c195c5312e0c26bf55616 24902 libs optional libxosd2_2.2.9-pre1-1_i386.deb
 5c0c1b5940937994863cdec8e7424c51 36208 libdevel optional libxosd-dev_2.2.9-pre1-1_i386.deb
 338b58bd7513716757e9d1da24235f0d 18214 x11 optional xosd-bin_2.2.9-pre1-1_i386.deb
 543376b95806520dc690677a710d2007 33106 sound optional xmms-osd-plugin_2.2.9-pre1-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBINpEYPlgoZpUDjkRAmTRAKCg6B/unnccConwv1CDwDYt1AM8hQCfZFcF
rWhZUKUYuRaP3gAHy4CR4FI=
=7XFC
-----END PGP SIGNATURE-----

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Mon, 16 Aug 2004 20:07:14 +0200 (CEST)
From: <email address hidden> (Philipp Hahn)
To: <email address hidden>
Subject:

reassign 252170 xosd
reassign 265561 libxosd2
merge 265561 266076
thanks

Debian Bug Importer (debzilla) wrote :

*** Bug 7461 has been marked as a duplicate of this bug. ***

Debian Bug Importer (debzilla) wrote :

*** Bug 7462 has been marked as a duplicate of this bug. ***

Fixed with xosd_2.2.8-5ubuntu1 upload.

Hello,

I still have this bug with the 2.2.9-pre1-1 version.
xmms segfaults after a few song changes.

--
Julien Danjou
.''`. Debian developer
: :' : http://julien.danjou.info
`. `' http://people.debian.org/~acid
  `- 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 20 Aug 2004 21:13:08 +0200
From: Julien Danjou <email address hidden>
To: <email address hidden>
Subject: Not closed..

Hello,

I still have this bug with the 2.2.9-pre1-1 version.
xmms segfaults after a few song changes.

--
Julien Danjou
.''`. Debian developer
: :' : http://julien.danjou.info
`. `' http://people.debian.org/~acid
  `- 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD

> I still have this bug with the 2.2.9-pre1-1 version.
> xmms segfaults after a few song changes.

How about in 2.2.9-pre3-1?

--
Thomas Hood

Debian Bug Importer (debzilla) wrote :

Message-Id: <1093415603.4797.47.camel@thanatos>
Date: Wed, 25 Aug 2004 08:33:24 +0200
From: Thomas Hood <email address hidden>
To: Julien Danjou <email address hidden>
Cc: <email address hidden>
Subject: How about 2.2.9-pre3-1?

> I still have this bug with the 2.2.9-pre1-1 version.
> xmms segfaults after a few song changes.

How about in 2.2.9-pre3-1?

--
Thomas Hood

On Wed, Aug 25, 2004 at 08:33:24AM +0200, Thomas Hood wrote:
> > I still have this bug with the 2.2.9-pre1-1 version.
> > xmms segfaults after a few song changes.
>
>
> How about in 2.2.9-pre3-1?

Same thing.
I tried to remove ~/.xmms, in case of... but it does not change
anything.

By the way I have another bug: in configuration I choose "top center"
for the position of the OSD.
But it display

            Playing
            1025 - Song title

insted of:

           Playing
      1025 - Song title

as before.

Maybe I should open another bug report ?

--
Julien Danjou
.''`. Debian developer
: :' : http://julien.danjou.info
`. `' http://people.debian.org/~acid
  `- 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD

tags 265561 - fixed-in-experimental
tags 265561 - patch

Debian Bug Importer (debzilla) wrote :

Message-Id: <20040825111107.7968110D74D@localhost>
Date: Wed, 25 Aug 2004 13:11:07 +0200 (CEST)
From: <email address hidden> (Thomas Hood)
To: <email address hidden>
Subject: tagging 265561, tagging 265561

tags 265561 - fixed-in-experimental
tags 265561 - patch

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 25 Aug 2004 13:06:26 +0200
From: Julien Danjou <email address hidden>
To: Thomas Hood <email address hidden>
Cc: <email address hidden>
Subject: Re: How about 2.2.9-pre3-1?

On Wed, Aug 25, 2004 at 08:33:24AM +0200, Thomas Hood wrote:
> > I still have this bug with the 2.2.9-pre1-1 version.
> > xmms segfaults after a few song changes.
>
>
> How about in 2.2.9-pre3-1?

Same thing.
I tried to remove ~/.xmms, in case of... but it does not change
anything.

By the way I have another bug: in configuration I choose "top center"
for the position of the OSD.
But it display

            Playing
            1025 - Song title

insted of:

           Playing
      1025 - Song title

as before.

Maybe I should open another bug report ?

--
Julien Danjou
.''`. Debian developer
: :' : http://julien.danjou.info
`. `' http://people.debian.org/~acid
  `- 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD

Hi!

On Fri, Aug 20, 2004 at 09:13:08PM +0200, Julien Danjou wrote:
> I still have this bug with the 2.2.9-pre1-1 version.
> xmms segfaults after a few song changes.

I can't reproduce any segfaults here. Can you provide more information:
* When does the segfault happen: During song change, changing
  colume/balance or somewhere other?
* Is this 100% reproducable?
* Does it (only) happen with a special song?
  * Does the file contain national characters. (Please provide the "File
    Info" data if possible)
* What locale do you use? (Output of "locale")
  * Does it also segfault with "LC_ALL=C xmms /your/files"?
  * Which fonts do you have available (xlsfonts)

Your reported alignment problem is fixed with 2.2.9.0-1 available from
http://pint.pmhahn.de/pmhahn/debian/sid/x/xosd/

BYtE
Philipp
--
Philipp Matthias Hahn <email address hidden>
 GPG/PGP: 9A540E39 @ keyrings.debian.org

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 26 Aug 2004 14:41:05 +0200
From: Philipp Matthias Hahn <email address hidden>
To: Julien Danjou <email address hidden>, <email address hidden>
Subject: Re: Bug#265561: Not closed..

Hi!

On Fri, Aug 20, 2004 at 09:13:08PM +0200, Julien Danjou wrote:
> I still have this bug with the 2.2.9-pre1-1 version.
> xmms segfaults after a few song changes.

I can't reproduce any segfaults here. Can you provide more information:
* When does the segfault happen: During song change, changing
  colume/balance or somewhere other?
* Is this 100% reproducable?
* Does it (only) happen with a special song?
  * Does the file contain national characters. (Please provide the "File
    Info" data if possible)
* What locale do you use? (Output of "locale")
  * Does it also segfault with "LC_ALL=C xmms /your/files"?
  * Which fonts do you have available (xlsfonts)

Your reported alignment problem is fixed with 2.2.9.0-1 available from
http://pint.pmhahn.de/pmhahn/debian/sid/x/xosd/

BYtE
Philipp
--
Philipp Matthias Hahn <email address hidden>
 GPG/PGP: 9A540E39 @ keyrings.debian.org

On Thu, Aug 26, 2004 at 02:41:05PM +0200, Philipp Matthias Hahn wrote:
> Hi!
>
> On Fri, Aug 20, 2004 at 09:13:08PM +0200, Julien Danjou wrote:
> > I still have this bug with the 2.2.9-pre1-1 version.
> > xmms segfaults after a few song changes.
>
> I can't reproduce any segfaults here. Can you provide more information:

OK, I found the problem...

I did:
apt-get -t experimental install xmms-osd-plugin
to test and install pre3 version that fixed the bug as you said.

However, xmms-osd-plugin does not depend of libxosd2 (= $SourceVersion),
so the lib was not upgraded. I think it should depend on it to avoid
such stupid things to happen.

By the way, downloading your latest version from the URL you gave fixed
all problems.

Patch is attached.

Cheers,
--
Julien Danjou
.''`. Debian developer
: :' : http://julien.danjou.info
`. `' http://people.debian.org/~acid
  `- 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 26 Aug 2004 18:12:59 +0200
From: Julien Danjou <email address hidden>
To: Philipp Matthias Hahn <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#265561: Not closed..

--iFRdW5/EC4oqxDHL
Content-Type: multipart/mixed; boundary="KFztAG8eRSV9hGtP"
Content-Disposition: inline

--KFztAG8eRSV9hGtP
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Thu, Aug 26, 2004 at 02:41:05PM +0200, Philipp Matthias Hahn wrote:
> Hi!
>=20
> On Fri, Aug 20, 2004 at 09:13:08PM +0200, Julien Danjou wrote:
> > I still have this bug with the 2.2.9-pre1-1 version.
> > xmms segfaults after a few song changes.
>=20
> I can't reproduce any segfaults here. Can you provide more information:

OK, I found the problem...

I did:
apt-get -t experimental install xmms-osd-plugin
to test and install pre3 version that fixed the bug as you said.

However, xmms-osd-plugin does not depend of libxosd2 (=3D $SourceVersion),
so the lib was not upgraded. I think it should depend on it to avoid
such stupid things to happen.

By the way, downloading your latest version from the URL you gave fixed
all problems.

Patch is attached.

Cheers,
--=20
Julien Danjou
=2E''`. Debian developer
: :' : http://julien.danjou.info
`. `' http://people.debian.org/~acid
  `- 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD

--KFztAG8eRSV9hGtP
Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename="xosd-2.2.9.0-acid.patch"
Content-Transfer-Encoding: quoted-printable

--- xosd-2.2.9.0/debian/control 2004-08-26 18:10:45.000000000 +0200
+++ xosd-2.2.9.0.acid/debian/control 2004-08-26 17:59:33.000000000 +0200
@@ -31,7 +31,7 @@
=20
 Package: xosd-bin
 Architecture: any
-Depends: ${shlibs:Depends}
+Depends: libxosd2 (=3D ${Source-Version}), ${shlibs:Depends}
 Description: X On-Screen Display library - binary files
  This package contains binary files shipped with the X OSD library:
  osd_cat - a 'cat' like program which will display its output in an
@@ -42,7 +42,7 @@
 Package: xmms-osd-plugin
 Section: sound
 Architecture: any
-Depends: xmms (>=3D 1.2.0), ${shlibs:Depends}
+Depends: xmms (>=3D 1.2.0), libxosd2 (=3D ${Source-Version}), ${shlibs:Dep=
ends}
 Description: XMMS plugin using xosd
  An XMMS plugin which displays volume and track information like
  on-screen displays on TVs and monitors.=20

--KFztAG8eRSV9hGtP--

--iFRdW5/EC4oqxDHL
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBLgwLpGK1HsL+5c0RAtYhAKDQok8QgoJnBj4anLTHm1mbnNGnyQCffVr9
vXjbB2/fbmtf/U7DVOEcbS0=
=U7iG
-----END PGP SIGNATURE-----

--iFRdW5/EC4oqxDHL--

Download full text (4.0 KiB)

Source: xosd
Source-Version: 2.2.10-1

We believe that the bug you reported is fixed in the latest version of
xosd, which is due to be installed in the Debian FTP archive:

libxosd-dev_2.2.10-1_i386.deb
  to pool/main/x/xosd/libxosd-dev_2.2.10-1_i386.deb
libxosd2_2.2.10-1_i386.deb
  to pool/main/x/xosd/libxosd2_2.2.10-1_i386.deb
xmms-osd-plugin_2.2.10-1_i386.deb
  to pool/main/x/xosd/xmms-osd-plugin_2.2.10-1_i386.deb
xosd-bin_2.2.10-1_i386.deb
  to pool/main/x/xosd/xosd-bin_2.2.10-1_i386.deb
xosd_2.2.10-1.diff.gz
  to pool/main/x/xosd/xosd_2.2.10-1.diff.gz
xosd_2.2.10-1.dsc
  to pool/main/x/xosd/xosd_2.2.10-1.dsc
xosd_2.2.10.orig.tar.gz
  to pool/main/x/xosd/xosd_2.2.10.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Philipp Matthias Hahn <email address hidden> (supplier of updated xosd package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 27 Aug 2004 08:11:16 +0200
Source: xosd
Binary: libxosd-dev xmms-osd-plugin xosd-bin libxosd2
Architecture: source i386
Version: 2.2.10-1
Distribution: unstable
Urgency: medium
Maintainer: Philipp Matthias Hahn <email address hidden>
Changed-By: Philipp Matthias Hahn <email address hidden>
Description:
 libxosd-dev - X On-Screen Display library - development
 libxosd2 - X On-Screen Display library - runtime
 xmms-osd-plugin - XMMS plugin using xosd
 xosd-bin - X On-Screen Display library - binary files
Closes: 265561 268182
Changes:
 xosd (2.2.10-1) unstable; urgency=medium
 .
   * New upstream version.
     - Applied my 36_string_with.diff and 37_setlocale.diff
   * Urgency medium because of grave #252170.
 .
 xosd (2.2.9.0-1) unstable; urgency=low
 .
   * New upstream version.
     - 26_one_line.diff/26_one_line_addon.diff: Merged upstream
     - 35_synchronous.diff: Work on tpb related #265757.
   * 36_string_with.diff: Fix alignment problem (#265561)
   * 37_setlocale.diff: Re-add setlocale() in osd_cat (closes: #268182)
   * Tighten dependencies in debian/shlibs. (Thanks to Julien Danjou)
 .
 xosd (2.2.9-pre3-1) experimental; urgency=low
 .
   * New upstream version.
     - 32_osd_cat_age.diff: Work on "osd_cat --age" functionality.
     - 33_automake.diff: Update autoconf files.
     - 34_docs.diff: Update package documentation.
   * Fix spelling in README.Debian (Thanks to Markus Braun)
   * 26_one_line.diff/26_one_line_addon.diff: Fix broken merge.
   * 35_synchronous.diff: Work on tpb related #265757.
 .
 xosd (2.2.9-pre1-1) experimental; urgency=low
 .
   * New upstream version.
     - Applied my 0..30/26 patches, remove all expect 26_one_line.diff.
   * 31_segv.diff: Crashes xmms after a short time (closes: #265561)
 .
 xosd (2.2.8-7) unstable; urgency=low
 .
   * 30_yield_fix.diff: Don't do busy waiting AK...

Read more...

Debian Bug Importer (debzilla) wrote :
Download full text (4.2 KiB)

Message-Id: <email address hidden>
Date: Fri, 27 Aug 2004 02:32:18 -0400
From: Philipp Matthias Hahn <email address hidden>
To: <email address hidden>
Subject: Bug#265561: fixed in xosd 2.2.10-1

Source: xosd
Source-Version: 2.2.10-1

We believe that the bug you reported is fixed in the latest version of
xosd, which is due to be installed in the Debian FTP archive:

libxosd-dev_2.2.10-1_i386.deb
  to pool/main/x/xosd/libxosd-dev_2.2.10-1_i386.deb
libxosd2_2.2.10-1_i386.deb
  to pool/main/x/xosd/libxosd2_2.2.10-1_i386.deb
xmms-osd-plugin_2.2.10-1_i386.deb
  to pool/main/x/xosd/xmms-osd-plugin_2.2.10-1_i386.deb
xosd-bin_2.2.10-1_i386.deb
  to pool/main/x/xosd/xosd-bin_2.2.10-1_i386.deb
xosd_2.2.10-1.diff.gz
  to pool/main/x/xosd/xosd_2.2.10-1.diff.gz
xosd_2.2.10-1.dsc
  to pool/main/x/xosd/xosd_2.2.10-1.dsc
xosd_2.2.10.orig.tar.gz
  to pool/main/x/xosd/xosd_2.2.10.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Philipp Matthias Hahn <email address hidden> (supplier of updated xosd package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 27 Aug 2004 08:11:16 +0200
Source: xosd
Binary: libxosd-dev xmms-osd-plugin xosd-bin libxosd2
Architecture: source i386
Version: 2.2.10-1
Distribution: unstable
Urgency: medium
Maintainer: Philipp Matthias Hahn <email address hidden>
Changed-By: Philipp Matthias Hahn <email address hidden>
Description:
 libxosd-dev - X On-Screen Display library - development
 libxosd2 - X On-Screen Display library - runtime
 xmms-osd-plugin - XMMS plugin using xosd
 xosd-bin - X On-Screen Display library - binary files
Closes: 265561 268182
Changes:
 xosd (2.2.10-1) unstable; urgency=medium
 .
   * New upstream version.
     - Applied my 36_string_with.diff and 37_setlocale.diff
   * Urgency medium because of grave #252170.
 .
 xosd (2.2.9.0-1) unstable; urgency=low
 .
   * New upstream version.
     - 26_one_line.diff/26_one_line_addon.diff: Merged upstream
     - 35_synchronous.diff: Work on tpb related #265757.
   * 36_string_with.diff: Fix alignment problem (#265561)
   * 37_setlocale.diff: Re-add setlocale() in osd_cat (closes: #268182)
   * Tighten dependencies in debian/shlibs. (Thanks to Julien Danjou)
 .
 xosd (2.2.9-pre3-1) experimental; urgency=low
 .
   * New upstream version.
     - 32_osd_cat_age.diff: Work on "osd_cat --age" functionality.
     - 33_automake.diff: Update autoconf files.
     - 34_docs.diff: Update package documentation.
   * Fix spelling in README.Debian (Thanks to Markus Braun)
   * 26_one_line.diff/26_one_line_addon.diff: Fix broken merge.
   * 35_synchronous.diff: Work on tpb related #265757.
 .
 xosd (2.2.9-pre1-1) experimental; urgency=low
 .
   * New upstream version.
     - Applied my ...

Read more...

Changed in xosd:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.