Ubuntu18.04.2 xorgxrdp Install error

Bug #1816253 reported by pingchou on 2019-02-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorgxrdp (Ubuntu)
Undecided
Unassigned

Bug Description

apt install xorgxrdp
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xorgxrdp : Depends: xorg-video-abi-23
            Depends: xserver-xorg-core (>= 2:1.18.99.901)
E: Unable to correct problems, you have held broken packages.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorgxrdp (Ubuntu):
status: New → Confirmed

For me this occured after hwe-18.04 upgrade:
sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

Sig Bee (sloppysphincter) wrote :

I also got that problem after upgrading the hwe-18.04
It's the xserver-xorg-hwe-18.04 part to be exact. If you only do the linux-generic-hwe-18.04 it will still work.

Not that it's a proper fix but I got it working by modifying the deb-dependencies of xorgxrdp:

First I tried modifying the bionic version
https://packages.ubuntu.com/bionic/net/xorgxrdp
Changed in the control file of the debian package:
Depends: libc6 (>= 2.15), xorg-input-abi-24, xorg-video-abi-23, xserver-xorg-core (>= 2:1.18.99.901)
to
Depends: libc6 (>= 2.15), xorg-input-abi-24, xorg-video-abi-24, xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901)
and re-assembled the package.
Didn't work, still couldn't connect to it.

Then I downloaded the Cosmic-versions of xrdp & xorgxrdp packages
https://packages.ubuntu.com/cosmic/amd64/xrdp/download
https://packages.ubuntu.com/cosmic/net/xorgxrdp

xrdp installed w/o problems. (Not sure if the latest xrdp was necessary for it to work but I'm not going back to try...)

For xorgxrdp I changed in the control file of the debian package:
Depends: libc6 (>= 2.15), xorg-input-abi-24, xorg-video-abi-24, xserver-xorg-core (>= 2:1.18.99.901)
to
Depends: libc6 (>= 2.15), xorg-input-abi-24, xorg-video-abi-24, xserver-xorg-core-hwe-18.04 (>= 2:1.18.99.901)
and re-assembled the debian-package.

After that it installed w/o errors and I'm able to connect to it again with xfreerdp.
I attached the modified file, use it at your own risk.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers