Ubuntu

Screen blanking and dpms can't be turned off

Reported by doctordruidphd on 2012-03-11
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

This is Kubuntu-11.10, all current updates applied, 64-bit.

the problem is the screen keeps blanking -- going to black every few seconds, regularly, and moving the mouse does restore the normal screen. I do not have any screensavers activated, and everything on Power save is turned off. I tried turning off dpms with:

xset dpms 0 0 0
xset dpms off
xset -dpms

And then maybe 30 seconds later, the screen goes black, and checking with xset -q, dpms has been turned back on.

I cannot figure out how to completely disable dpms. this is extremely irritating, as I cannot work with the screen going black every few seconds. Something is turning it back on, and I haven't been able to figure out what. I set up xorg.conf to disable dpms with:

Section "ServerFlags"
        Option "blank time" "0"
        Option "standby time" "0"
        Option "suspend time" "0"
        Option "off time" "0"
        Option "dpms" "false"
EndSection

After logging in, xset shows dpms is disabled, but after a few seconds, it comes back on. Is there a way to shut this off, once and for all?

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/952521/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xscreensaver.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → xscreensaver (Ubuntu)
Tormod Volden (tormodvolden) wrote :

This has nothing to do with xscreensaver.

doctordruidphd (doctordruidphd) wrote :

I agree, this has nothing to do with xscreensaver, nor with kscreensaver, as neither have been activated.
"ps aux | grep xscreensaver" does not return any result.

Tormod Volden (tormodvolden) wrote :

I will reassign this to the generic xorg package. Please run "apport-collect 952521" to attach relevant system information. We'll eventually need to reassign this to the Xorg driver in question, or the kernel.

affects: xscreensaver (Ubuntu) → xorg (Ubuntu)
doctordruidphd (doctordruidphd) wrote :

FYI, I am no longer using 11.10, now on 12.04. It does not have the problem. I did make the changes in the /etc/X11/xorg.conf file, and 12.04 does not seem to be restoring dpms to "enabled". I have no idea whether the problem persists in 11.10, as I am no longer using it.

bugbot (bugbot) on 2012-05-03
tags: added: kubuntu
Tormod Volden (tormodvolden) wrote :

Thanks, closing as fixed in 12.04.

Changed in xorg (Ubuntu):
status: New → Fix Released
GreyGeek (greygeek77) wrote :

I had an update today on my Kubuntu 12.04 and this bug has returned.
The relevant application is
xsettings-kde (0.12.3-0ubuntu2, 0.12.3-0ubuntu2.1) Upgraded at 08:51 AM

doctordruidphd (doctordruidphd) wrote :

I can confirm that the bug has returned. Kubuntu-12.04/64-bit.
So far I have not been able to find the config file the xsettings-kde daemon is using to do this.

Tormod Volden (tormodvolden) wrote :

I am not able to change status on this bug any longer. It should be set to "Confirmed" as by above comments.

affects: xorg (Ubuntu) → xsettings-kde (Ubuntu)

I changed it.
Same old problem. Even when I issue xset -dpms, a few minutes later it is back to "dpms enabled".

Changed in xsettings-kde (Ubuntu):
status: Fix Released → Confirmed
Jonathan Thomas (echidnaman) wrote :

I do not believe the xsettings-kde update is related to this. Are you sure it isn't something else in -proposed?

affects: xsettings-kde (Ubuntu) → xorg (Ubuntu)

On my system, proposed is not enabled.
Backports is, if that matters.

Jonathan Thomas (echidnaman) wrote :

That pretty much confirms that xsettings-kde is unrelated to this issue.

GreyGeek (greygeek77) wrote :

Jonathan, my blanking problem started immediately after xsettings-kde (0.12.3-0ubuntu2) was upgraded (0.12.3-0ubuntu2.1) last Friday. My 64bit precise installation display screen has been working perfectly since I installed Precise after the Alpha release. Xsettings-kde was the only upgrade on last Friday which was related to the xserver. All the others were related to the cups package.

Another thing I have tried is to set the powersave parameter of the i915 kernel module:

options i915 powersave=0

and that appeared to work for a while. I set it at around 2pm Saturday and after a reboot the screen did not blank for the rest of the day, till shutdown around 11pm. However, I booted up about 8pm tonight (Sunday) and about 10pm the blanking resumed. To keep the blanking off I have to open a Konsole and issue "xset dpms 0 0 0" followed by "xset -dpms" and keep the Konsole open but minimized to keep out of my way.

I should add that I am running KDE 4.8.3 from the Ubuntu launchpad ppa, which I installed

GreyGeek (greygeek77) wrote :

Wednesday at 1:30pm.

Jeremy LaCroix (j-jlacroix) wrote :

I am having the exact same problem on one of my two laptops.

First, please note I am not using Ubuntu or Kubuntu. I am running Arch Linux. I know this isn't an Arch Linux bug reporter, but wanted to note that this might be an upstream issue due to my having the problem on a different distribution.

Another thing worth noting is that my laptop with Intel graphics doesn't seem to be bothered by this bug (though I only use that laptop around once a week or less). My Nvidia laptop has this issue.

So I'm thinking:
Either this is a KDE bug, or an Nvidia bug.

Are you guys running Nvidia?

Although we use different distributions, our interests are the same, so I hope we can pinpoint the issue.

Jeremy LaCroix (j-jlacroix) wrote :

There's a bug filed upstream:
https://bugs.kde.org/show_bug.cgi?id=295164

Paul Nasca (nascapaul) wrote :
Download full text (4.0 KiB)

TLDR: most likely the issue is fso-deviced

I have a Fujitsu laptop Lifebook and I am using Ubuntu 12.10. Since I upgraded to this version of Ubuntu I experienced random screen blanking each few minutes, like a "blank" screensaver. I solved this issue for myself, but I want to describe it here for others.

The unsuccesful way I tried to solve this issues:

I disabled dpms and screensaver but something re-enabled it and blanked the screen.
The methods how I tried to disable the dpms and screensaver are:
1) Launched this script:
 xset dpms force on
 xset s noblank
 xset s off
 xset -dpms
2) I put in /etc/rc.local these commands:
setterm -blank 0 -powerdown 0
echo -ne "\033[9;0]" >> /etc/issue
3) Added a new file in /usr/share/X11/xorg.conf.d/99-paul-dpms.conf

Section "Monitor"
 Identifier "monitor"
 Option "DPMS" "false"
EndSection

Section "ServerLayout"
 Identifier "monitor"
 Option "BlankTime" "0"
 Option "StandbyTime" "0"
 Option "SuspendTime" "0"
 Option "OffTime" "0"
EndSection

4) All of the above with minor changes

The problem still persisted.

The successfull workaround:

Today (after many days of random screen blanking) I noticed that it is somehow related with the WiFi Internet connection. Indeed, after I turned off and on the router, the screen blanked imediately after wifi reconnection (usually after few seconds).
So, decided to monitor the dbus system messages with the command: dbus-monitor --system

I noticed that always just before screen blanking there is a "lock" message where Interface=org.freesmartphone.Device.IdleNotifier:

--------dbus system monitor log----------------------
signal sender=:1.20 -> dest=(null destination) serial=3397 path=/org/freesmartphone/Device/IdleNotifier/0; interface=org.freesmartphone.Device.IdleNotifier; member=State
   string "idle_dim"
signal sender=:1.4 -> dest=(null destination) serial=2978 path=/org/freedesktop/NetworkManager/Devices/0; interface=org.freedesktop.NetworkManager.Device.Wireless; member=PropertiesChanged
   array [
      dict entry(
         string "Bitrate"
         variant uint32 1000
      )
   ]
signal sender=:1.20 -> dest=(null destination) serial=3399 path=/org/freesmartphone/Device/IdleNotifier/0; interface=org.freesmartphone.Device.IdleNotifier; member=State
   string "idle_prelock"
signal sender=:1.20 -> dest=(null destination) serial=3401 path=/org/freesmartphone/Device/IdleNotifier/0; interface=org.freesmartphone.Device.IdleNotifier; member=State
   string "lock"
signal sender=:1.4 -> dest=(null destination) serial=2979 path=/org/freedesktop/NetworkManager/AccessPoint/0; interface=org.freedesktop.NetworkManager.AccessPoint; member=PropertiesChanged
[screen shuts down here]

[I move the mouse and after less than one minute...]
signal sender=:1.4 -> dest=(null destination) serial=3000 path=/org/freedesktop/NetworkManager/Devices/0; interface=org.freedesktop.NetworkManager.Device.Wireless; member=AccessPointRemoved
   object path "/org/freedesktop/NetworkManager/AccessPoint/15"
signal sender=:1.4 -> dest=(null destination) serial=3001 path=/org/freedesktop/NetworkManager/AccessPoint/0; interface=org.freedesktop.NetworkManager.AccessPoint; member=Properti...

Read more...

That is truly bizarre.

On my system, fso-deviced is not installed.

What I found that finally worked is changing xorg.conf, adding the line

Option "dpms" "false"

in the "Server Flags" section, and removing the

Option "DPMS"

line from the "Monitor" section.

Paul Nasca (nascapaul) wrote :

Have you noticed something suspicious by logging with the shell command: dbus-monitor --system ?

cfaber (cfaber) wrote :

Ok, so there is a work around, it appears the problem exists in power management within KDE.

Enter system settings, power management, then enable all power management on all tabs (applying it as you go through them), then disable it again.

This _should_ correctly disable DPMS and power management won't try to re-enable it again.

If this doesn't work, clear your powermanger rc's in KDE config and try the above steps again.

Good luck!

-cf

Same issue for me, fixed with comment #22 (thanks!)

I moved power* out of ~/.kde/share/config/

I note that once i recreated my power settings, i have only powerdevilrc and powermanagementprofilesrc in the config directory (in terms of power*). The file list that I moved out (power*) included:

powerdevil2profilesrc.old
powerdevil.notifyrc
powerdevilprofilesrc.old
powerdevilrc
powermanagementprofilesrc

I also noted the following in /var/log/syslog, don't know if it's related:

Nov 24 18:02:48 caseylinux dbus[1102]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Nov 24 18:02:48 caseylinux org.kde.powerdevil.backlighthelper: QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
Nov 24 18:02:48 caseylinux dbus[1102]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Nov 24 18:03:18 caseylinux dbus[1102]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Nov 24 18:03:18 caseylinux org.kde.powerdevil.backlighthelper: QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
Nov 24 18:03:18 caseylinux dbus[1102]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Nov 24 18:05:49 caseylinux dbus[1102]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Nov 24 18:05:49 caseylinux org.kde.powerdevil.backlighthelper: QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
Nov 24 18:05:49 caseylinux dbus[1102]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Nov 24 18:06:07 caseylinux dbus[1102]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Nov 24 18:06:07 caseylinux org.kde.powerdevil.backlighthelper: QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
Nov 24 18:06:07 caseylinux dbus[1102]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'

After moving the files and disabling/enabling the power settings, more of these errors appeared.

This started for me at random... i recently updated to 12.10, but it's been running fine for a few days. This just happened when I started up this last time (didn't reboot to see if it continued).

I also have a dead battery (flashing orange battery light on Dell Inspiron 6000), which failed maybe 4 or so boots ago.

-c

dcotordruidphd, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/952521/comments/20 regarding this being fixed with a configuration change. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xorg (Ubuntu):
status: Confirmed → Invalid
KeithG (grider-4) wrote :

well, this is really fixed as I cannot turn off the screen at this time! ALl I want is to set DPMS to turn the screen off after 5 minutes with the login screen and with a user... Nothing tough, but there is not a setting for this in the new, minimal gnome settings...

KeithG, thank you for your comment. Given this is resolved for the original reporter, and considered closed, this bug report is not focused on your hardware or problem. If you have a bug in Ubuntu, the Ubuntu X.Org team, Ubuntu Bug Control, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug xorg

For more on this, please see the Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.