Num Lock stucks on makes keyboard unusable

Bug #933059 reported by zzecool
This bug report is a duplicate of:  Bug #933405: Numlock cant be set "off". Edit Remove
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
xserver-xorg-input-evdev
New
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

After the latest precise updates if i press num lock there is no way to switch it off again , every time i press it it switches on in 0 time by it self again , its like it is always on but it isn't .

My laptop keyboard doesn't have a numpad so instead of numpad it shares half of the keyboard letters with the numpad keys . As you can understand i cant use my laptop keyboard any longer ( im typing using an external usb keyboard ) .

I tried to disable "remember numlock" using gconf with no luck num lock still always on.

When i boot the numlock is off and it stays off even in the lightdm greeter , then if i log into unity or gnome shell it switches on by it self ....

If i press CTRL + ALT + F1 while in unity or gnome shell to access a terminal session , there i can switch off the numlock but as soon as i go back to the X session ( CTRL + ALT + F7 ) num lock goes on again .

I also noticed that when i join a guest session the num lock was off and i was able to use the keyboard as usual , then i tried to switch it on and off but failed and numlock stayed on.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 290.10 Wed Nov 16 17:39:29 PST 2011
 GCC version: gcc version 4.6.2 (Ubuntu/Linaro 4.6.2-14ubuntu1)
.tmp.unity.scope.cities: Error: [Errno 21] Is a directory: '/tmp/unity-scope-cities'
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Wed Feb 15 22:20:33 2012
DistUpgraded: Log time: 2011-09-27 15:36:23.910451
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 NVIDIA Corporation G86 [GeForce 8600M GS] [10de:0425] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Sony Corporation Device [104d:9005]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
JockeyStatus: xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Sony Corporation VGN-FZ31Z
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-16-generic root=UUID=12e02107-7815-4276-b7ac-7bceee898897 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to precise on 2012-02-02 (12 days ago)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 12/21/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: R2110J7
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR2110J7:bd12/21/2007:svnSonyCorporation:pnVGN-FZ31Z:pvrC6006UGW:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VGN-FZ31Z
dmi.product.version: C6006UGW
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu33
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Revision history for this message
zzecool (zzecool) wrote :
Revision history for this message
zzecool (zzecool) wrote :

I forgot to say that if i spam a letter that is shared with a number while also spamming the numlock key i manage to type both .

Example "L" letter is sharing the same Key with the number "3" so the result was something like :

llllll333llll3lll3llll3lllllll

So the numlock isnt actual stuck in on but everytime you try to switch it off it come on by it self almost instantly

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
zzecool (zzecool)
description: updated
description: updated
zzecool (zzecool)
description: updated
description: updated
description: updated
Revision history for this message
Barry Drake (b-drake) wrote :

Exactly the behaviour I get.

Revision history for this message
emelce (mtlang) wrote :

it's possible to unlock it: settings - keyboard - layoutsettings - layout - options - use keyboard LED to show alternative layout: set to NumLock

To post a comment you must log in.