Multiple focus problems on first connexion

Bug #916568 reported by Julien on 2012-01-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Hello,

[EDIT] Unlike what I thought, the problem is probably not related to compiz: I get the same type of problem under Unity2D[/EDIT] [EDIT] and gnome-shell[/EDIT] [EDIT2] and openbox too... [/EDIT2]

The bug appears in my 11.10 system with the last update of compiz (i.e. 01-05-2012).
At the first connection after the boot, I face many problems with the focus on the interface: I can generally use the Unity-dash to launch an application (sometimes two) but then the dash no longer appears correctly, the indicators either, I can not focus from one window to another ... However, I noticed that the keyboard shortcuts usually work.
So I find myself stuck. The only workaround I've found is to launch a system-Alt-k and then reconnect. Here the problem doesn't reproduce until next boot.

I made a video showing the expected behavior (after reconnection) and the behavior that I get on startup: http://ubuntuone.com/5tD98knn0gNXPofcknz285
The audio comment is in French, but I was unable to do this in English ...

I hope this report will be useful ... If information is needed about my configuration, I can complete it later.
---
ApportVersion: 2.0.1-0ubuntu3
Architecture: i386
CheckboxSubmission: 2d986db26f7171f6367f224e0b90fd14
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
CurrentDmesg:
 [ 24.995968] eth0: no IPv6 routers present
 [ 36.613994] 2:3:1: cannot get freq at ep 0x84
 [ 36.720234] 2:3:1: cannot get freq at ep 0x84
 [ 43.986139] 2:3:1: cannot get freq at ep 0x84
 [ 44.016218] 2:3:1: cannot get freq at ep 0x84
DistUpgraded: 2012-02-04 13:44:55,671 DEBUG enabling apt cron job
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Gigabyte Technology Co., Ltd. P55-UD6
NonfreeKernelModules: nvidia
Package: xorg 1:7.6+12ubuntu1
PackageArchitecture: i386
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=85701377-76ea-46c3-876b-a6d1567b4f36 ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Tags: precise ubuntu
Uname: Linux 3.2.0-23-generic-pae i686
UpgradeStatus: Upgraded to precise on 2012-02-04 (71 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 06/30/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F10
dmi.board.name: P55-UD6
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF10:bd06/30/2010:svnGigabyteTechnologyCo.,Ltd.:pnP55-UD6:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP55-UD6:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P55-UD6
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Julien (julienmbpe) on 2012-01-14
description: updated
summary: - Compiz/Unity : Multiple focus problem on first connexion
+ Compiz/Unity : Multiple focus problems on first connexion

See description edit

description: updated
affects: compiz (Ubuntu) → unity (Ubuntu)
Julien (julienmbpe) on 2012-01-16
description: updated
Julien (julienmbpe) on 2012-01-16
summary: - Compiz/Unity : Multiple focus problems on first connexion
+ Unity : Multiple focus problems on first connexion

Which graphic card/driver are you using? Seems like an Xorg issue here.

Changed in unity-2d:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Julien (julienmbpe) wrote :

Thanks for your interest for this bug, I've a NVidia 9800GT Silent graphic card and I've tried the 3 available drivers :
- free pilot (everything is disabled in jockey)
- current [recommended]
- current-update

And I found focus issues with the 3 ones...

Is an other information needed ?

Changed in unity-2d:
status: Incomplete → New
Changed in unity (Ubuntu):
status: Incomplete → New
Julien (julienmbpe) wrote :

Some news about my bug : I tried to log with gnome-shell today but the bug was steel present. So I think the bug is not in unity (2D or 3D) and not in Compiz but I don't no which package to choose in "affects"...
Any idea ?

affects: unity (Ubuntu) → gnome-shell (Ubuntu)
Julien (julienmbpe) on 2012-01-24
description: updated
Julien (julienmbpe) wrote :

I had a test partition under natty 32bits (PAE kernel) and today i've updated it to Oneiric. My focus problem is present in this partition too.

So I can confirm that it is not a problem with my config files but realy a bug.

affects: unity-2d → unity
Julien (julienmbpe) wrote :

I just found a discussion that I had opened on the French forum several months ago and then forgot: http://forum.ubuntu-fr.org/viewtopic.php?id=645381
I already had this problem under Natty and this issue was still present on Oneiric.
it was then resolved himself, perhaps after an update around the October 26, 2011

I'll try to update my test partition this WE to precise to see if this bug is solved (again) ...

Julien (julienmbpe) wrote :

Still prevent on precise, but I've a new element : the bug affect my computer even when I'm not under gnome (shell or unity). I tried openbox under precise and the issue is present too.

Which package can be involved ?

no longer affects: unity
affects: gnome-shell (Ubuntu) → ubuntu
summary: - Unity : Multiple focus problems on first connexion
+ Multiple focus problems on first connexion
description: updated
Julien (julienmbpe) wrote :

You should read "Still present" not "Still prevent" in comment #7

Julien (julienmbpe) on 2012-02-24
affects: ubuntu → xorg (Ubuntu)
description: updated
Julien (julienmbpe) wrote :

This bug seems to have disappeared from Oneiric and Precise during the WE. Last week updates could be involved in the solution but i can't be affirmative...
So... Thanks to "I don't know who"

Julien (julienmbpe) wrote :

This bug seems to be fixed...

Changed in xorg (Ubuntu):
status: New → Invalid
Julien (julienmbpe) wrote :

The bug re-appeared yesterday on Precise Pangolin...
Don't know what to do with it.

Changed in xorg (Ubuntu):
status: Invalid → New

apport information

tags: added: apport-collected precise ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Bryce Harrington (bryce) wrote :

The video demonstrates the bug in unity, which is that the dock panel doesn't return from auto-hide when the mouse is moved to the left side of the screen. You mention that it affects other window managers too, however they do not use unity's dock, so can you describe what you see in each of those cases, that convinces you it is the same bug?

Changed in xorg (Ubuntu):
status: New → Incomplete
Julien (julienmbpe) wrote :

Indeed, the video was made ​​in Oneiric for which the launcher is not in auto-hide mode but intelli-hide mode. However, the problem remains the same with precise ...
The bug isn't just affecting the launcher but also the windows that do not take focus. Sometimes I can not even access the indicators (so I have to close the session with Alt-sys-k).
The "windows focus problme" also affects other WM I tried.

Julien (julienmbpe) wrote :

I made an other video on gnome-shell (under precise pangolin) but record my desktop don't show the panel... You can see the bug concerning windows :
http://ubuntuone.com/7OlTRNvVXVZniC54eVYIOj

I''ve writent some comments directly in the video terminal to explain what i was doing.

Changed in xorg (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Ok thanks, that second video shows the problem quite clearly.

It really does feel more like a window manager bug than X, however the fact that you find similar focus problems in both gnome shell and unity tends to suggest otherwise.

I haven't seen other reports of this behavior (or, at least, not any that I can recall). Is there any chance it is something particular to your system configuration? Can you create a USB live image and boot that, and see if it reproduces? If it does not, then boot your regular system but log in as a guest account.

Changed in xorg (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Julien (julienmbpe) wrote :

I don't see anything "exotic" in my configuration (either software or hardware) but here are some elements :
- Motherboard : Gigabyte P55-UD6
- CPU Core i5
- 4GoRAM
- GPU : NVidia 9800GT Silent
- the issues occures on both 32bits-PAE Precise and 64bits Oneiric installation (Dual-boot)
- I don't have other OS installed on this PC

I can't test on live USB now (no key and no CD available) but I'll try the Week-end.
However, I tried to boot in guest account and the bug was present (and this time, there was no reaction to right or left clic...)

Also affected
nVidia GTX460, driver nouveau
ASUS P8P67LE
i5 2500k (quadcore 3.3Gz) 8Go RAM
Unity 2D + Compiz

In fact I don't have exactly the same bug I think.
I open my session, Compiz loads, Unity-2d-panel loads, and then everything freezes on the display except the mouse.
Unity-2D-launcher doesn't load at all.
Then I kill X (Ctrl+Alt+Sys+K) and I reopen the session. Then, everything works normally, except sometimes unity-2d-launcher which needs to be killed to restart, because it exists but not visible.

Julien (julienmbpe) wrote :

Qs reauesteed by Bryce Harrington (bryce)m I boot from a live-USB (with a f!@#$ qwerty layout for my azerty keyboard) and the bug seems not to be present in the session.

I noticed that in the screen "Try Ubuntu or install it" right clics did't work correctly but once on the desktop, everything is ok...

Did it give you some idea ?

Changed in xorg (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Julien (julienmbpe) wrote :

Surprisingly, the bug can be solved by electrically powering off the PC : I don't encounter this bug since I've done this manipulation 2 weeks ago.
So, I suspect an issue with the motherboard staying under tension when the PC is "off".

My motherboard spec's :
dmi.bios.date: 06/30/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F10
dmi.board.name: P55-UD6
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF10:bd06/30/2010:svnGigabyteTechnologyCo.,Ltd.:pnP55-UD6:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP55-UD6:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P55-UD6
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Timo Aaltonen (tjaalton) wrote :

ok, the video card was in a bad state it seems, and powering it off cleared it

Changed in xorg (Ubuntu):
status: Confirmed → Invalid
Julien (julienmbpe) wrote :

I'm OK with that, but I'd like to know how did it happened and how to make it not happen again...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers