Can't make video work right on a HP dv2125nr laptop with NVidia GO 6150 chipset

Bug #84830 reported by Christopher L. Everett on 2007-02-13
2
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Using Dapper (don't ask--getting wireless to work on this bastard laptop was a 10 day saga) and the 2.6.15-686 kernel.

This is like 3 bugs in one:

The open source (nv) drivers don't work.

The proprietary drivers won't work either. I installed the nvidia-glx package and linux-restricted-modules-686. Using nvidia-glx-enable does not change anything in the xorg.conf. If I change xorg.conf manually or using either nvidia-xconfig or dpkg-reconfigure xserver-xorg, the NVidia module fails to load.

So I'm stuck with vesa. But vesa won't support 1280x800 widescreen.

And the ubuntu forums are worse than useless--I wasted 2 weeks trying to get help there, and I can't even upload my Xorg.0.log file because it complains that I'm tring to upload more than 8 images (what images?!?).

So, anyway, an acceptable outcome for me would be to get *any* video driver working at 1280x800 resolution on this laptop so I don't have to look at blurry, squashed images at 1024x768 resolution. But the Nvidia proprietary drivers would be the Holy Grail (which is about how likely I think it is that they will ever work on this POS laptop).

Thank you.

Dangital. This isn't supposed to be under Usplash. Sorry.

Marco Maini (maini10) wrote :

Move to xserver driver bugs.

Sitsofe Wheeler (sitsofe) wrote :

Thank you for your bug report.

Christopher:
Are things any better if you temporarily boot off the Feisty live CD (no need to install anything to test this)?

Setting to needsinfo pending reply from Christopher.

Changed in xorg:
status: Unconfirmed → Needs Info

Sitsofe,

Don't have the laptop with me, it's been sent in to HP to repair a hardware problem with the video. I will be installing Feisty on it when it comes back.

I did get nvidia drivers working on it by downloading the drivers from the nvidia site and letting it compile a kernel module (I had to delete the kernel module that comes with ubuntu).

Christopher

----- Original Message ----
From: Sitsofe Wheeler <email address hidden>
To: <email address hidden>
Sent: Saturday, April 28, 2007 2:02:35 AM
Subject: [Bug 84830] Re: Can't make video work right on a HP dv2125nr laptop with NVidia GO 6150 chipset

Thank you for your bug report.

Christopher:
Are things any better if you temporarily boot off the Feisty live CD (no need to install anything to test this)?

Setting to needsinfo pending reply from Christopher.

** Changed in: xorg (Ubuntu)
       Status: Unconfirmed => Needs Info

--
Can't make video work right on a HP dv2125nr laptop with NVidia GO 6150 chipset
https://bugs.launchpad.net/bugs/84830
You received this bug notification because you are a direct subscriber
of the bug.

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Bryce Harrington (bryce) on 2007-06-02
Changed in xorg:
status: Needs Info → Unconfirmed
Sitsofe Wheeler (sitsofe) wrote :

Christopher:
Understood. Since you have found a solution to the problem shall we close this bug report? I will just note that after installing drivers not provided by Ubuntu repositories your support options change and any problems that arise should no longer be reported to the launchpad bug area. If the drivers were downloaded from the NVIDIA web site then the NVIDIA linux web forum ( http://www.nvnews.net/vbulletin/forumdisplay.php?f=14 ) is an appropriate place to report issues. If a 3rd party installer was used please contact the 3rd party for support. Other places for manual driver support can be found on the Community Support page (http://www.ubuntu.com/support/communitysupport ).

Sitsofe Wheeler (sitsofe) wrote :

Setting to needsinfo pending reply from Christopher.

Changed in xorg:
status: Unconfirmed → Needs Info
Bryce Harrington (bryce) wrote :

Does this still occur on newer versions of Ubuntu?

Changed in xorg:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions