AutoRepeat doesn't work on Thinkpad Back/Forward keys.

Bug #82925 reported by Octavio Alvarez on 2007-02-02
4
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Version: Ubuntu Edgy, completely updated.
Computer: IBM Thinkpad T42.

Steps to reproduce:
1. Open a terminal.
2. Issue "xset r off"
3. Start xev.
4. Hold down the Back key. It happens also with the Forward key.

Expected result:
You should get one KeyPress event on press and one KeyRelease event on release.

Actual result:
You get a series of KeyPress/KeyRelease events on hold.

Other, maybe related info:
When "xset r on", holding down other keys throw this:
 1. KeyPress.
 2. The typematic delay.
 3. Series of KeyRelease+KeyPress.
 4. Finally a KeyRelease.

However, holding down the Back or Forward keys, xev throws this:
 1. KeyPress+KeyRelease.
 2. The typematic delay
 3. Series of KeyPress+KeyRelease, until released.

Other linux distributions don't show this wrong behavior.

Oleksij Rempel (olerem) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? If so, please reopen the bug. Thanks in advance.

Octavio Alvarez (alvarezp) wrote :

Indeed. The bug is still present.

Oleksij Rempel (olerem) wrote :

I can't reproduce it on my Ubuntu Gutsy. Any way assign it to xorg

Timo Aaltonen (tjaalton) wrote :

Same with hardy, marking as fixed.

Changed in xorg:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers