Tries and fails to remove /etc/gdm

Bug #820370 reported by Scott Kitterman on 2011-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Timo Aaltonen

Bug Description

This is from my apt-term log after upgrading from natty to oneiric:

Preparing to replace x11-common 1:7.6+4ubuntu3.1 (using .../x11-common_1%3a7.6+7ubuntu6_all.deb) ...^M
Unpacking replacement x11-common ...^M
dpkg: warning: unable to delete old directory '/etc/gdm': Directory not empty^M

It's not clear to me why x11-common thinks it should remove /etc/gdm (also not clear why I have /etc/gdm since this is a Kubuntu system that's never had Ubuntu installed) or what was in there that prevented it's removal. After the upgrade, the directory is, in fact, empty, so this looks like some kind ofsequencing issue. Full term-log attached.

Scott Kitterman (kitterman) wrote :
tags: added: iso-testing
bugbot (bugbot) on 2011-08-07
tags: added: kubuntu
Timo Aaltonen (tjaalton) wrote :

Because x11-common used to install stuff there for failsafe-x, and it's now removing the remaining conffiles on upgrade, if found. Dunno why it's trying to remove the directory though, maybe it should remove the files on preinst?

Since this was an upgrade of a Kubuntu installation, it may be that it owned
/etc/gdm since gdm has never been installed on the system.

Timo Aaltonen (tjaalton) on 2011-08-08
Changed in xorg (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → Low
status: New → Confirmed
Bryce Harrington (bryce) on 2011-08-08
Changed in xorg (Ubuntu):
status: Confirmed → In Progress
importance: Low → Medium
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Timo Aaltonen (tjaalton) wrote :

Scott, I've just uploaded a new version of xorg (which builds x11-common), could you verify if you have /etc/gdm left after the update? I hope it'll get removed on upgrade now that there are no conffiles left in the directory.

Otherwise the x11-common.preinst script would need changing, and it's a bit scary to remove the dir and make sure it's not used etc..

Changed in xorg (Ubuntu):
status: In Progress → Incomplete
Timo Aaltonen (tjaalton) wrote :

note that the new package has no changes related to this bug, just that the unpack phase should (?) remove /etc/gdm now that it's empty.. here's hoping.

Scott Kitterman (kitterman) wrote :

Since this was an upgrade bug, it'll probably be close to release when I upgrade non-test systems before I can check this.

Timo Aaltonen (tjaalton) wrote :

It's enough if you update the box where you noticed this.

Timo Aaltonen (tjaalton) wrote :

I believe this bug is fixed as well as it's practically feasible; the version from oneiric removes the conffiles before upgrade, so it should remove /etc/gdm too.

Changed in xorg (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments