Xubuntu i386 and amd64 xserver abort

Bug #799238 reported by Fabio Marconi on 2011-06-18
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: casper

Hello
Live session.
Testing today-s build I can observe that the xserver don-t start.

Workaround>
Boot without quiet and splash and when the screen is black without cursor press Enter, the console appear and type startx

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: casper 1.269
ProcVersionSignature: Ubuntu 3.0-1.2-generic 3.0.0-rc3
Uname: Linux 3.0-1-generic x86_64
Architecture: amd64
Date: Sat Jun 18 20:23:08 2011
LiveMediaBuild: Xubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110618)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :

casper.log

description: updated
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :

From Xorg.0.log.old

[ 21.507] (II) No input driver/identifier specified (ignoring)
[ 89.460]
Backtrace:
[ 89.460] 0: /usr/bin/X (xorg_backtrace+0x26) [0x4a2bd6]
[ 89.460] 1: /usr/bin/X (0x400000+0x638ba) [0x4638ba]
[ 89.460] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f44a8b9d000+0xfc60) [0x7f44a8bacc60]
[ 89.460] 3: /lib/x86_64-linux-gnu/libc.so.6 (__select+0x13) [0x7f44a7b8b293]
[ 89.460] 4: /usr/bin/X (WaitForSomething+0x19b) [0x45ceab]
[ 89.460] 5: /usr/bin/X (0x400000+0x2f6e2) [0x42f6e2]
[ 89.460] 6: /usr/bin/X (0x400000+0x2325e) [0x42325e]
[ 89.460] 7: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xff) [0x7f44a7acbe1f]
[ 89.460] 8: /usr/bin/X (0x400000+0x2354d) [0x42354d]
[ 89.460]
Caught signal 3 (Quit). Server aborting
[ 89.460]

tags: added: xubuntu
summary: - Xubuntu amd64 20110618 xserver not started
+ Xubuntu amd64 20110618 xserver abort

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

This issue also affects the Xubuntu daily-live i386 images dated 20110618. Xubuntu can be installed using the " install Xubuntu" from the cd menu.

 Thanks for taking the time to make Ubuntu better!

Changed in casper (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: iso-testing
Morris Cavestro (fly82) wrote :

this bug affect with i386

I can confirm this bug on Xubuntu i386

summary: - Xubuntu amd64 20110618 xserver abort
+ Xubuntu i386 and amd64 20110618 xserver abort
Paolo Rotolo (paolorotolo) wrote :

I can confirm this bug on Mythubuntu i386 20110506.

Brian Murray (brian-murray) wrote :

There is an xorg backtrace in the comments and attachments of this bug report so it is surely not a casper bug - reassigning it to xorg.

tags: added: workaround
affects: casper (Ubuntu) → xorg (Ubuntu)
summary: - Xubuntu i386 and amd64 20110618 xserver abort
+ Xubuntu i386 and amd64 xserver abort
Charlie Kravetz (charlie-tca) wrote :

This appears to have been fixed in Xubuntu as of 2011-07-29. Using images from this or later dates, can anyone still reproduce this issue? I believe something in the latest Xorg updates fixed this issue.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in xorg (Ubuntu):
status: Triaged → Incomplete
Charlie Kravetz (charlie-tca) wrote :

This has been fixed with the latest release of xorg. Thanks for the fix.

Changed in xorg (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers