Ubuntu suddenly logs-out

Bug #760695 reported by Alessandro Losavio on 2011-04-14
178
This bug affects 38 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gnome-session

-Ubuntu 11.04 amd64 Beta2

Step to reproduce it:

1) log-in on Ubuntu
2) a few minutes to work with Ubuntu (eg. write a text with LibreOffice)

Ubuntu has Suddenly Automatically log-out

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-session-bin 2.32.1-0ubuntu19
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Thu Apr 14 15:43:20 2011
ExecutablePath: /usr/bin/gnome-session
ProcEnviron:
 LANGUAGE=it:es:pt_BR:pt_PT:xh
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Alessandro Losavio (alo21) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you add your Xorg.0.log and Xorg.0.log.old to the bug? Did you get any apport crash notification?

Changed in gnome-session (Ubuntu):
status: New → Incomplete
Alessandro Losavio (alo21) wrote :
Alessandro Losavio (alo21) wrote :

Il 14/04/2011 16:14, Sebastien Bacher ha scritto:
> thank you for your bug report, could you add your Xorg.0.log and
> Xorg.0.log.old to the bug?
scure

> Did you get any apport crash notification?
unfortunately no

summary: - Ubuntu has suddenly automatically log-out
+ Ubuntu suddenly logs-out
Sebastien Bacher (seb128) wrote :

there is no crash mentioned in those, what about syslog?

Changed in gnome-session (Ubuntu):
status: Incomplete → New
importance: Undecided → Low
status: New → Incomplete
Alessandro Losavio (alo21) wrote :
Gabriel Velo (gabriel-velo) wrote :

Same behavior in my laptop after update to 11.04. Apparently a segmentation fault in X server.

[ 16727.462] 15: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0x12ce37]
[ 16727.463] 16: /usr/bin/X (0x8048000+0x1a411) [0x8062411]
[ 16727.463] Segmentation fault at address 0xa3d8440
[ 16727.488]
Caught signal 11 (Segmentation fault). Server aborting
[ 16727.496]
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
[ 16727.496] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 16727.496]

Elies (belkhamza) wrote :

Hi There,

I have faced The same problem few minutes ago. When I was working on netbeans 7. and I tried to put the cursor on a wmv file to listen to.

It happened twice today.

Thank you.

Elies (belkhamza) wrote :

I forgot to mention that I am working on IBM Thinkpad T60.

Hannes Beyer (hannesbeyer) wrote :

Same here with natty 64bit clean install on my Thinkpad t410s. It does not happen every session, but on average maybe once a day.

Sagar Chalise (chalisesagar) wrote :

Same here with Dell Vostro 3400 i3. Basically I asked the question on askubuntu as well for this. It regularly happened during beta test. I re-installed the same beta ISO and updated right away when natty released. It persists but not as regularly as it used to though. Here is the question on askubuntu: http://askubuntu.com/questions/36399/ubuntu-11-04-randomly-logs-out-in-middle-of-use

Rehan S. Alvi (rehansalvi) wrote :

Keep having the same problem every day, usually 2-3x a day. Has crashed while doing nothing but copying files in terminal and another time while writing a letter in LibreOffice Writer.

Attached my Xorg.0.log

Sebastien Bacher (seb128) wrote :

those are xorg segfaults, could you open a bug using ubuntu-bug xserver-xorg?

affects: gnome-session (Ubuntu) → xorg (Ubuntu)
Mustafa Kaya (mustail) wrote :

This happened to me for the first time a few minutes ago. I was on Firefox, I just opened a new tab. Suddenly the screen went black, I saw a couple of words/letters, and then I was back on the login screen.

I am running a clean install of Ubuntu 11.04 x86 on a ThinkPad T400. I had not witnessed this problem when in 10.10.

Nekhelesh Ramananthan (nik90) wrote :

Yeah I have the same problem here. It just happens randomly. I am running a clean install of Ubuntu 11.04 x86 on a Dell Inspiron 1525. I too did not witness this problem in 10.10.

Fernando (ferempi) wrote :

I have the same problem. X Server fails continuously. Every time I try to see a movie, rmvb, flv, mkv, whatever, even on Totem when I'm playing music and I try to change the sound volume.
I can't see videos, every time I try to put a video on full screen, x server fails and I'm back on log in screen. So I can reproduce the bug all the time, also with vlc, if I try to maximize the window while playing a video X Server fails again.

Ubuntu 11.04 stable.
I log in with "Ubuntu Classic".
I have no graphics hardware acceleration.
I installed Ubuntu on a clean partition. (over lvm partitions)

Bryce Harrington (bryce) wrote :

Please collect a full backtrace on this crash - see http://wiki.ubuntu.com/X/Backtracing for guidance.

Changed in xorg (Ubuntu):
importance: Low → High
Fernando (ferempi) wrote :

Ok, I can't make the backtrace right now (gdm, don't have a remote machine. Apport does not report a thing)

It seems the X server terminates normally on an error, so I did a little of "Debugging Error Exits" as I read from the wiki that Bryce pointed.

One log was created closing x server with vlc. The other with totem. Both with different files.

The same x-server messages.

My Ubuntu is the one that I described before (I must ad that it is a 32bit-Desktop)

I'm attaching the logs and I don't know if this serves for something but here is the output of lspci:

00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] (rev 01)

I wish I can do more

CuteChaps (sh-senthilkumar) wrote :

I have the same problem. Installed natty final release couple of days back on thinkpad t410.

CuteChaps (sh-senthilkumar) wrote :
CuteChaps (sh-senthilkumar) wrote :
martincasc (martincasco) wrote :

Same problem on a clean Ubuntu 64 bit’s installation. My Laptops it's a MSI cr-620 with Core i3, onboard video.

pjordan (jordanpatrick) wrote :

Same problem with an upgrade from Maverick to Natty (64 bits). Thinkpad W510 with Nvidia Quadro FX 880M...

pjordan (jordanpatrick) wrote :

(For me it seems to happen on a key stroke... Not always the same)

Bryce Harrington (bryce) wrote :

Guys, Xorg.0.log traces don't really help with diagnosing problems, gotta have full backtraces taken.

Also, one bug report per crash per person please. "sudden log out" is just a generic symptom that always happens with any crash. You each could be seeing some unrelated bug.

Changed in xorg (Ubuntu):
status: Incomplete → Invalid
lewvip (lewvip-163) wrote :

Same issue on my T400, fresh installation.

Anurag Gautam (anuraggau) wrote :

If it is a generic situation why it is happening with all of the people suddenly, I believe there is some problem in this release then ubuntu 11.04 ?

Kindly look into the same as i am also effected from this symptom. Earlier every thing was fine what happened just after upgrading from 10.10.

Changed in xorg (Ubuntu):
status: Invalid → Incomplete
Kaesersoze (kaesersoze1982) wrote :

Hi,
it happens to me very often since an hour or two. Trying to add books into Calibre, the repeted action of logging/opening Calibre/click on "add a book" seems enough to log out suddenly.

(sorry, I'm new to ubuntu, don't know how to edit a log of my systems. Tell me more about if needed.)

Kaesersoze (kaesersoze1982) wrote :

Having the same problem on my Toshiba NB505 netbook. Sometimes the logouts appear to be random, but it _always_ happens when I use ebook management program Calibre (specifically if I try to right-click and 'share' a book).

Juan Iguana (cisneros-jc) wrote :

It affects me too. I use a Semp Toshiba infinity. the bug happens a a few times a day usually a few minutes or seconds after starting the computer, when I try to open GmailWatcher, Banshee, or even the weather indicator, but can hapen with other programs too.

Mustafa Kaya (mustail) wrote :

Apport could not collect information about the crash, in my case.

Today I had two consequtive crashes. Right after the first crash I logged back in and started apport (sudo service apport start force_start=1). Less then a minute later system crashed again and logged back out. When I logged in again, there was no apport message of any kind.

I am assuming that apport did not collect crash information. If it did collect information but did not report it the way it used to do in other cases, then I do not know where on my drive it created (if it did) a report file .

Chrome, TeXworks and Banshee was open at the time of both of the crashes.

srmatanza (erikrogel) wrote :

Same issue here
I guess it is related to pulseaudio or some audio stuff

prabagaran (prabagaranvt) wrote :

I got the same auto logout issue with my Intel 32 bit machine.
When i open 1 or 2 applications and work for long time the problem do not occur.
But when i start more applications the problem occurs.
Provide a patch as soon as possible.

Regards,
Prabagaran.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers