Ubuntu

Xsession: unable to launch "" X session --- "" not found; falling back to default session.

Reported by Malte S. Stretz on 2011-01-30
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xorg (Debian)
New
Unknown
xorg (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

I recently both got an upgrade for Xorg and went to KDE 4.6 (via the PPA), so I don't know who caused this message to appear. But now everytime I logon I get an xmessage telling me "Xsession: unable to launch "" X session --- "" not found; falling back to default session."

This is from /etc/X11/Xsession.d/20x11-common_process-args but I don't know where the session name comes from. Anyway, I think an empty session name should be special cased with something like the following (untested) patch:

--- 20x11-common_process-args.orig 2010-03-02 17:33:01.000000000 +0100
+++ 20x11-common_process-args 2011-01-30 13:57:18.073443001 +0100
@@ -40,7 +40,7 @@
           fi
         fi
         ;;
- default)
+ default|"")
         # Default behavior was requested.
         ;;
       *)

Apart from that it would be nice if that message gave me a hint on how to fix this.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: x11-common 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic x86_64
Architecture: amd64
DRM.card0.HDMI_Type_A.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1680x1050 1280x1024 1280x1024 1440x900 1440x900 1280x960 1152x864 1280x720 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 720x576 720x480 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAmzQxWuAkAACYUAQOANB14KmBBplZKnCUSUFS/7wBxT4FAgYCVAJUPswABAQEBAjqAGHE4LUBYLEUACSUhAAAeAAAA/QA4TB5TEQAKICAgICAgAAAA/ABQTDI0MDlIRAogICAgAAAA/wAxMTAwNU0wOTAyNDg4AaQCAx/xTAECAwQFEBESExQeHyMJBwGDAQAAZQMMABAAjArQiiDgLRAQPpYACSUhAAAYAR0AclHQHiBuKFUACSUhAAAejArQkCBAMSAMQFUACSUhAAAYAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAATw==
Date: Sun Jan 30 13:50:23 2011
DkmsStatus:

MachineType: Acer AL 5100 / VL410
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-25-generic root=/dev/mapper/lvm-sys ro rootfstype=ext4 iommu=noaperture quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 04/14/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: R02-A1
dmi.board.name: FRS690L
dmi.board.vendor: Acer
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrR02-A1:bd04/14/2008:svnAcer:pnAL5100/VL410:pvrR02-A1:rvnAcer:rnFRS690L:rvr:cvnAcer:ct3:cvr:
dmi.product.name: AL 5100 / VL410
dmi.product.version: R02-A1
dmi.sys.vendor: Acer
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-25-generic

Malte S. Stretz (mss) wrote :
bugbot (bugbot) on 2011-02-01
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Malte S. Stretz (mss) on 2011-02-02
affects: xserver-xorg-video-ati (Ubuntu) → xorg (Ubuntu)
bugbot (bugbot) on 2011-02-02
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Malte S. Stretz (mss) wrote :

WTF? Why keeps the bugbot assigning this bug to the wrong package? The file /etc/X11/Xsession.d/20x11-common_process-args is from x11-common which is built from xorg.

bugbot (bugbot) on 2011-02-06
tags: added: kubuntu
Malte S. Stretz (mss) on 2011-02-09
affects: xserver-xorg-video-ati (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Debian):
status: Unknown → New
bugbot (bugbot) on 2011-02-10
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Jeppe Bundsgaard (jeppe) wrote :

I get the same error after upgrading to KDE 4.6.

Paul Abrahams (abrahams) wrote :

And so did I. (also an akonadi error, FWIW).

bugbot (bugbot) wrote :

Hey Malte,

Hi, have you had a chance to test if this bug is still present in natty?

If it does (and if you're the original reporter), please boot into natty
and run the command:

  apport-collect <bug-number>

which will update the bug with fresh logs and tag the bug as affecting
natty. (It is best to run this right after reproducing the problem.)

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Malte S. Stretz (mss) wrote :

A quick glance at the source of the script should show if the bug is still there.

I reassigned this bug to xorg-server since the bugbot always reassigns to xserver-xorg-video-ati if the bug is assigned to xorg where this bug really stems from.

affects: xserver-xorg-video-ati (Ubuntu) → xorg-server (Ubuntu)
Bryce Harrington (bryce) on 2011-04-28
Changed in xorg-server (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
affects: xorg-server (Ubuntu) → xorg (Ubuntu)
tags: added: omit
Ivan Firago (cybertmdev) wrote :

for me helps: sudo chmod -x /usr/bin/which; thanks, Malte S. Stretz

Jeppe Bundsgaard (jeppe) wrote :

After upgrading to Kubuntu 11.04 the problem disappeared.

Surak (smkozasa) wrote :

This bug appeared to me after I upgraded to Natty 11.04, from 64 bit version of 10.10. I tried Ivan Firago's suggestion (chmod -x /usr/bin/which) and it DID work, but since some programs need it, like firefox's lauching script, that will not solve the problem for me. Though it may be a good hint to solve the bug.

Surak (smkozasa) wrote :

OK, I did as in the bug description's "untested patch" and changed the line

default)

to

default("")

in the file /etc/X11/Xsession.d/20x11-common_process-args and the problem disappeared.

Please note that there is a mistype in the bug descripton's "untested patch": default|"") instead of default("").

Hope this helps.

Malte S. Stretz (mss) wrote :

That's not a typo. You can read it as "default"|"").

I can confirm this bug on Kubuntu 11.04 64-bit, upgraded from Kubuntu 10.10.

The proposed untested patch has solved the problem with the warning dialog:
...
- default)
+ default|"")
...

I don't know where the empty string session comes from, though, which seems to be the actual problem.

My x11-common version is 1:7.6+4ubuntu3.

Surak (smkozasa) wrote :

Sorry for assuming it was a typo. I don't have great shellscript knowledge, but if I had payed attention to the code, I shoud have guessed it was not a function, but a case statement. Interestingly enough, it did solve the warning dialog problem. Anyway, I changed the line to

default|"")

and things still work fine. No more annoying warning dialogs when logging in.

Ivan Sorokin (sorokin) wrote :

This helps for me: http://forum.kde.org/viewtopic.php?f=66&t=91936

1) Set in /etc/kde4/kdm/kdmrc AutoLoginEnable = false
2) reboot
3) select default session as kde

At login you'll get the following message:
"Your saved Gnome session isn't valid anymore.
Please, choose a new one or the default one will be used"

Carsten Hoeger (choeger) wrote :

same problem here after upgraded to from 10.10 to 11.04. 64bit Kubuntu

Surak (smkozasa) wrote :

Interesting, I start to understand this bug. When I updated from Kubuntu 10.10 to 11.04, there was, indeed, a message, just before logging in, about my 'kde' session not being valid anymore and that I should choose a valid one, or else the 'default' session would be used. I chose the new name 'kde-plasma', but anyway the warning dialog appeared.

If I understand it right, using (or not using) the 'default' session is the cause of the problem? But the bug itself seems to be the

default)

insted of

default|"")

?

Malte S. Stretz (mss) wrote :

Almost. The process which logs you in to your X session (I guess it is kdm, but I'm not entirely sure) calls the Xsession script which creates your actual session. That script expects either one or zero parameters: The name of the session to use. If no parameter is given, it assumes you want to use the special session with the name "default" which falls back to whatever the default session is on your system.

Now the bug is that, due to some misconfiguration, your session name is invalid. Afterwards, instead of calling Xsession without any parameter, it is still called with a single parameter: The empty string "". Xsession tries to map this string to a session name, gets confused, throws up a nasty xdialog and falls back to default.

So we've got two bugs here:
* Xsession doesn't handle an empty session string (which can mean only "default" IMHO) gracefully.
* Whoever calls Xsession should not use an empty string but leave the first parameter if the user wants the default session. I think the bug is in kdm, but I'm not sure so I don't know where to report it upstream.

The (now tested) patch I posted before fixes Xsession to handle kdm's (?) odd view of a default session.

tags: added: patch
David (david96) wrote :

The message #12 (AleksanderAdamowski ) has corrected this bug, thank you :)

My config : Debian wheezy, the signalment > http://debian-facile.org/viewtopic.php?pid=61236 (french)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.