Dependencies allow driver packages to be removed too easily

Bug #68430 reported by Martijn de Nerd on 2006-10-26
20
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Michael Vogt

Bug Description

I upgraded from dapper to edgy (kubuntu) today, and after rebooting the x was broken. X was complaining about a version difference between driver and xserver. The video drivers (formerly known as xserver-xorg-driver-* packages) were not upgraded! Installing xserver-xorg-video-all solved the problem.
Shouldn't this package be a dependency of something?

tristan_lefebure (tristanl) wrote :

I had a similar problem: upgrade my kubuntu dapper to edgy, and then Xorg complained about unavailable drivers.

I fixed it by running:
sudo dpkg-reconfigure xserver-xorg
and selected 'nvidia' intead of 'nv' in the driver section.

Matt Zimmerman (mdz) wrote :

Many users seem to have removed the standard metapackages from their systems, causing problems like this when the upgrade tool is not used.

I think we ought to tighten the dependencies on xserver-xorg so that all video drivers must be installed. Users who truly intend to strip down their systems like this should use xserver-xorg-core + the driver they need.

Changed in xorg:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
assignee: nobody → fabbione
Matt Zimmerman (mdz) wrote :
Changed in xorg:
assignee: fabbione → mvo
Michael Vogt (mvo) wrote :

I'm currently looking into this issue. Only apt-get is affected, update-manager gets it with because it does post-processing after the runing cache.upgrade() (making sure that *buntu-desktop is still installed for example). And the aptitude resolver is different (and better) so this one gets it right too.

Unfortunately apt-get dist-upgrade does not get it right. The problem resolver says:

Investigating xserver-xorg-video-dummy
Package xserver-xorg-video-dummy has broken dep on xserver-xorg-driver-dummy
  Considering xserver-xorg-driver-dummy 1 as a solution to xserver-xorg-video-dummy 1
  Holding Back xserver-xorg-video-dummy rather than change xserver-xorg-driver-dummy

(this is the same for all the xserver-xorg-driver-$foo).

So it fails to replace the x-x-driver-$foo with the new x-x-video-$foo and this causes the problems. Unfortunately the fix does not help with this issue. Apt will remove xserver-xorg during the dist-upgrade (because it is first kept to the installed version and then later gets removed because x11-common in the new version conflicts with the old version).

So xserver-xorg-driver-$foo gets the same score from apt as x-x-video-$foo and in a situation apts problem resolver keeps the package. The score is generated by looking at the rdepends of the package, priority and installed package gets a point extra.

Michael Vogt (mvo) wrote :

After something pondering I think the simplest solution is a transitional package for xserver-xorg-driver-all.

I have attached a updated debdiff. This fixes the issue in a pbuilder upgrade with only xserver-xorg instlled and in a vmware test environemtn with a full ubuntu-desktop.

The additioanl transitional package ensures that even if xserver-xorg-driver-all is not installed on the dapper system the score of the xserver-xorg-video-$foo is higher than the xserver-xorg-driver-$foo.

I would appreciate a second pair of eyes looking at this because its rather late here already :)

This fix works for me too in my chroot with apt-get dist-upgrade.

Fabio

On Wed, Nov 01, 2006 at 12:37:47AM -0000, Michael Vogt wrote:
> After something pondering I think the simplest solution is a
> transitional package for xserver-xorg-driver-all.
>
> I have attached a updated debdiff. This fixes the issue in a pbuilder
> upgrade with only xserver-xorg instlled and in a vmware test environemtn
> with a full ubuntu-desktop.
>
> The additioanl transitional package ensures that even if xserver-xorg-
> driver-all is not installed on the dapper system the score of the
> xserver-xorg-video-$foo is higher than the xserver-xorg-driver-$foo.
>
> I would appreciate a second pair of eyes looking at this because its
> rather late here already :)
>
>
> ** Attachment added: "Updated proposed fix"
> http://librarian.launchpad.net/4942734/xorg_7.1.1ubuntu6.1.debdiff

Looks good, OK for edgy-proposed.

--
 - mdz

Uploaded to edgy-proposed with a slightly modified changelog.

debdiff in attachment.

Simon, new package has been uploaded to edgy-proposed and it's waiting ftp-master approval. Once it hits archive is your turn according to SRU.

Fabio

Changed in xorg:
status: Confirmed → In Progress
Simon Law (sfllaw) wrote :

This patch creates the desired behaviour on upgrades. Video drivers are now properly installed and transition well. This works properly both with and without the xserver-xorg-driver-all package installed in Dapper.

Matt Zimmerman (mdz) wrote :

Once it has been in -proposed for the requisite 7 days without issue, please reupload to -updates.

Simon Law (sfllaw) wrote :

Please upload to -updates on the 29th. Thanks.

Changed in xorg:
status: In Progress → Fix Committed
Michael Vogt (mvo) wrote :

Uploaded, waiting in new

Matt Zimmerman (mdz) wrote :

Archive team: please accept soonest

Adam Conrad (adconrad) wrote :

Upload verified and accepted for -updates.

Changed in xorg:
status: Fix Committed → Fix Released

hey guys,

it's there, I adept updated this update today. So great work! But... I have
some thoughts about the whole procedure.
I reported this bug on the 26th of October, in the roaring days just after
the Edgy release. On the 1st of November the package with the fix was ready.
This is a very fast response I think, you can be proud of it, and that makes
the rest of the story such a shame .
Because today, it's December the 7th, So it took more than a month before
the fix was actually released! In my opinion this is way too long. This fix
fixes a serious upgrade bug (no X!), and should have been available as soon
as possible. Of course some time for testing the package is necessary, but I
suspect that in the last 5 weeks a lot of people unnecessarily suffered from
this bug.

just my 2cts,

Martijn

On 12/7/06, Adam Conrad <adconrad@0c3.net> wrote:
>
> Upload verified and accepted for -updates.
>
>
> ** Changed in: xorg (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> Dependencies allow driver packages to be removed too easily
> https://launchpad.net/bugs/68430
>

Daniel Stone (daniels) wrote :

> I think we ought to tighten the dependencies on xserver-xorg
> so that all video drivers must be installed. Users who truly
> intend to strip down their systems like this should use
> xserver-xorg-core + the driver they need.

yes, except the configuration infrastructure is still in xserver-xorg, so this is not a sane option to be recommending.

Matt Zimmerman (mdz) wrote :

On Mon, Jan 08, 2007 at 04:16:57AM -0000, Daniel Stone wrote:
> > I think we ought to tighten the dependencies on xserver-xorg
> > so that all video drivers must be installed. Users who truly
> > intend to strip down their systems like this should use
> > xserver-xorg-core + the driver they need.
>
> yes, except the configuration infrastructure is still in xserver-xorg,
> so this is not a sane option to be recommending.

At this time, it's much more important to ensure proper desktop upgrades
than to support stripped-down configurations, so this still seems like the
best option for the present. It's also my understanding that the server
should be able to run without a configuration file in many more
circumstances soon; isn't that so?

--
 - mdz

Daniel Stone (daniels) wrote :

On Mon, Jan 08, 2007 at 04:21:13PM -0000, Matt Zimmerman wrote:
> It's also my understanding that the server
> should be able to run without a configuration file in many more
> circumstances soon; isn't that so?

As of 7.2 (xorg-server 1.2.0), this will indeed be the case.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers