Right button and middle click on mouse are swapped

Bug #68319 reported by JollyRoger on 2006-10-26
6
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading from Dapper to Edgy I found that the click function of the scroll wheel and the right mouse buttons had switched the way that they work. Clicking down on the scroll wheel brings up the menu that is normally brought up by right clicking. Right clicking produces the auto scroll functionality in applications that support it.

Jeremy Teale (jteale) wrote :

Hello and thank you for reporting.
It would very helpful to have a more detailed description of the problem you are having. Please describe the nature of your mouse (make, model, etc.) and if you have performed any previous customizations to your Xorg configuration.

Jeremy Teale (jteale) wrote :

I forgot to also request that you post the contents of /etc/X11/xorg.conf as an attachment.
Thanks.

Jakob Jensen (basementjack) wrote :

I have the same problem. I have an Logitech MX500 mouse.
It switched the middle and right button with the standart xorg.conf (did a fresh dpgk-reconfigure xserver-xorg) and it is still switched after I followed this guide http://ubuntuforums.org/showthread.php?t=219894. I have also configured my graphic card.

Jakob Jensen (basementjack) wrote :

I have been trying out stuff to make my mouse work. It seems that why I change anything in my xorg.conf the mouse does not react on it. Then I check xorg's log and came across this :
$ cat /var/log/Xorg.0.log | grep -i preinit
(II) fglrx(0): === [R200PreInit] === begin, [s]
(II) resource ranges after preInit:
(EE) PreInit returned NULL for "Configured Mouse"

Is it possible that xorg simply ignores the Configured Mouse section?
 - I do not know how to test for this.

JollyRoger (vancexsucks) wrote :

I have since fixed the problem with some help from members of the ubuntuforums.org community. The way I fixed it was by typing these lines into my Xorg.conf file in the mouse section:

Option "Buttons" "7"
Option "ButtonMapping" "1 3 2 8 9"

Having the 3 and the 2 switched brought my mouse buttons into the correct order so that all functions worked as they should. Also oddly enough installing Beryl and XGL fixed the problem also. Under XGL my buttons are fine, in regular Gnome my buttons were mixed up.

For reference my mouse is a Logitech mx518 wired mouse. I followed a guide to setup the side buttons a long time ago that I found on ubuntuforums.org so that could possibly be part of the problem. I undid everything I modified from that guide though and still had the problem.

My xorg.conf file is attached. Currently it has code in it for the evdev driver so that I can use my side buttons on my mx518. The original section for the mouse is still in there though, it's just commented out. In the regular mouse section you will also see the fix I mentioned earlier. Thanks.

Jeremy Teale (jteale) wrote :

Fixed by user and the bug is old. Closing as Invalid as it seems to be a configuration issue and there hasn't been any activity in a while. Please reopen if you feel this should still be addressed. Thanks.

Changed in xorg:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers