X segfaults with Xinerama and multiple cards/drivers

Bug #659919 reported by Rolf on 2010-10-13
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

As it says. This is occuring on two machines, one with radeon + interl and another with 2 nvidia cards. Same segfault:

[ 108.957] 0: /usr/bin/X (xorg_backtrace+0x28) [0x4a0fa8]
[ 108.957] 1: /usr/bin/X (0x400000+0x60fcd) [0x460fcd]
[ 108.957] 2: /lib/libpthread.so.0 (0x7fbbf560b000+0xfb40) [0x7fbbf561ab40]
[ 108.957] 3: /usr/bin/X (0x400000+0xbb22f) [0x4bb22f]
[ 108.957] 4: /usr/bin/X (0x400000+0x2c2d9) [0x42c2d9]
[ 108.957] 5: /usr/bin/X (0x400000+0x2184b) [0x42184b]
[ 108.957] 6: /lib/libc.so.6 (__libc_start_main+0xfe) [0x7fbbf4576d8e]
[ 108.957] 7: /usr/bin/X (0x400000+0x213d9) [0x4213d9]
[ 108.957] Segmentation fault at address 0x4
[ 108.957]
Caught signal 11 (Segmentation fault). Server aborting
[ 108.957]

Rolf (rolf-winmutt) wrote :

With all three screens enabled machine crashes. Also just ATI-1 and Intel crashes.

Rolf (rolf-winmutt) wrote :

Log of crash

Rolf (rolf-winmutt) wrote :

Log of crash

Brian J. Cohen (brianjcohen) wrote :

Same problem. Log of crash attached.

Brian J. Cohen (brianjcohen) wrote :

This is definitely related to Xinerama; when I disable Xinerama the problem goes away.

So far, I've been able to trigger the crash simply by launching any of the following apps:
- vlc
- skype
- nevernote (http://nevernote.sf.net)
- amdcccle

I've also tried to 'dpkg-reconfigure fglrx' and 'aticonfig --initial' to "start over" with a fresh X config but the problem persists. The only thing that alleviates it is turning off Xinerama.

Brian J. Cohen (brianjcohen) wrote :

I've been doing more research, and it appears that any dynamically-linked QT app will trigger the segfault. Konqueror, K3B, etc.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers