[edgy] Freeze when switching to VT in AIGLX

Bug #63584 reported by Misha Koshelev on 2006-10-02
2
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-core

I am running Edgy Beta on a Dell Inspiron 600m (Mobility Radeon 9000) with the open source radeon driver and AIGLX and beryl 0.1. When I switch to a text VT by pressing CTRL-ALT-F1 then switch back to my running X server by pressing CTRL-ALT-F7 the screen goes blank and I cannot access my computer anymore except through ssh.

This also happened when I did a killall -u myusername from a running X session (nasty habit to do this to log out :) ) also screen went blank and couldn't access laptop.

In Dapper I used to run fglrx + Xgl and it worked very well, but under Edgy I was having a lot of problems with random Xgl crashes every few minutes to every few hours so I am trying AIGLX. I have attached my /var/log/Xorg.0.log and xorg.conf files.

Thank you
Misha Koshelev

Misha Koshelev (misha680) wrote :
Misha Koshelev (misha680) wrote :
Misha Koshelev (misha680) wrote :

I noticed I don't have an xserver-xorg-air-core package installed in edgy (duh) because AIGLX is intergrated into xserver-xorg.

description: updated

Same if not worst problem on ppc. Default install will crash X in 99.9% of the cases. I can rarely get to login. Disable dri doesn't help.

Fabio

Changed in xorg:
importance: Undecided → High
status: Unconfirmed → Confirmed

This should be fixed with the new ati driver (ubuntu3) that will appear on the mirrors within a few hours.

Fabio

Changed in xorg:
status: Confirmed → Fix Released
Dustan Ashley (dashley) wrote :

This does not seem to be a problem with only ATI. I am using the i810 driver in edgy and the problem remains.

Joakim Andersson (jocke) wrote :

I had a similar problem with my nvidia GeForceFX 5200 (using inofficial 9xxx series drivers and built in AIGLX). If i switched to VT and then back to X, all I got was a movable pointer over a black screen, and no access except through SSH. After looking trough a few guides I tried unloading the 'eeprom' module (and removing it from /etc/modules), and everything was happy again. :) That module apparently often causes problems with AIGLX and the result is mostly a black screen.

Jocke

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers