X sluggish after 'xset s activate' (dpms on)

Bug #569891 reported by ignasi on 2010-04-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Hi there. I'm using Lucid 64-bits on a Lenovo SL500 with an intel vga.

ignasi@Caladan:~$ lspci | grep Graphics
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

For the past days I have noticed that X becomes really unresponsive after dpms is activated, either by not using the computer or by invoking 'sleep 1; xset s activate'. To have the system run smoothly again I just have to press Ctrl-Alt-F1 to go to a text session, and Ctrl-F7 to go back to X, and everything is normal again (until dpms is activated again)

I'm currently using the x-swat ppa for testing the infamous memory leak.

David Tombs (dgtombs) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in xorg.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → xorg (Ubuntu)
David Tombs (dgtombs) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 569891

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thanks in advance!

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in xorg (Ubuntu):
status: New → Incomplete
ignasi (igp-oenus) wrote :

David, I'm sorry but I can't do that anymore... It was a karmic installation upgraded to lucid, and that was not the only problem I was experimenting. So I had no other choice but to do a clean installation. I have not been able to reproduce this problem anymore.

Thanks

Ignacio

David Tombs (dgtombs) wrote :

OK, well thanks for the reply and sorry for the inconvenience. I'll close this report.

Changed in xorg (Ubuntu):
status: Incomplete → Invalid
David Tombs (dgtombs) wrote :

On second thought, I'll just let this expire in case anyone else has the issue. Sorry for the spam!

Changed in xorg (Ubuntu):
status: Invalid → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers