X11 does not start (except in safe graphics) with update to kernel 2.6.32-21 Generic

Bug #567621 reported by Jim Brumbaugh on 2010-04-21
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Been running Lucid in a separate partition from my 9.10 since Beta release. The X team has been trying to fix a screen blanking bug (reported) which results in a blank (though lit) screen lockup if I close the lid and reopen it. which was introduced in 9.04 just two weeks prior to the release of 9.10..

The developers finally, a week ago (~April 13) started to address this problem. The screen would blank but restore itself imperfectly (all icons and menu item are blank, but I can see the menu outlines as well as text in my Chrome browser, but I need to log out and back in to regain screen normalcy.

At the same time, I noticed that 3d graphics was almost immediately failing and screen was reverting to 2d. Attempting to turn on Compiz resulted in the message "driver not found". The update on Saturday the 17 with some more Xorg driver patches and a new kernal 2.6.32-21 resulted in a blank screen after the new Ubutnu orange logo comes up with the 5 (?) red progress dots filled below it. The screen then blanks and then all disk activity ceases.

This is where the login menu is supposed to show up.

I can boot perfectly in failsafe graphics mode.

lsb_release -rd info:
  Description: Ubuntu lucid (development branch)
  Release: 10.04

Computer: Dell Latitude X300

Twiddling with the safe graphics mode and trying to start X manually results in a blank screen the same as a normal boot.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: x11-common 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
BootDmesg:

Date: Tue Apr 20 17:32:10 2010
DkmsStatus: Error: [Errno 2] No such file or directory
GdmLog1:

InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100317.1)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 046d:c01b Logitech, Inc. MX310 Optical Mouse
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Computer Corporation Latitude X300
PackageArchitecture: all
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=111c8897-cbe2-4fee-a23f-52ddad2ef675 ro single
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xorg
XorgLog:

XorgLogOld:

dmi.bios.date: 11/20/2003
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: A04
dmi.board.name: 0X0213
dmi.board.vendor: Dell Computer Corporation
dmi.board.version: X06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Computer Corporation
dmi.chassis.version: 00h
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrA04:bd11/20/2003:svnDellComputerCorporation:pnLatitudeX300:pvrA04:rvnDellComputerCorporation:rn0X0213:rvrX06:cvnDellComputerCorporation:ct8:cvr00h:
dmi.product.name: Latitude X300
dmi.product.version: A04
dmi.sys.vendor: Dell Computer Corporation
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-21-generic

Jim Brumbaugh (bleumyst) wrote :
Calvin.Ngei (calvin-ngei) wrote :

I googled "Dell Latitude X300" and found that the graphic card of it is intel integrated graphics card (Intel Extreme Graphics 855 GM), the same graphic card as my BenQ Joybook 5000U (Intel Corporation 82852/855GM series). And your description matches bug #568779 well. It should be a duplicate of bug #568779.

Changed in xorg (Ubuntu):
status: New → Confirmed

On Sat, Apr 24, 2010 at 1:55 AM, Calvin.Ngei <email address hidden> wrote:
> *** This bug is a duplicate of bug 568779 ***
>    https://bugs.launchpad.net/bugs/568779
>
> I googled "Dell Latitude X300" and found that the graphic card of it is
> intel integrated graphics card (Intel Extreme Graphics 855 GM), the same
> graphic card as my BenQ Joybook 5000U (Intel Corporation 82852/855GM
> series). And your description matches bug #568779 well. It should be a
> duplicate of bug #568779.
>
> ** Changed in: xorg (Ubuntu)
>       Status: New => Confirmed
>
> ** This bug has been marked a duplicate of bug 568779
>   10.04 rc livecd boots into black/blank screen (intel 82852/855GM graphic card)

Greetings Calvin:

Just wanted to verify, yes- the two bugs are the same. Yesterday I
downloaded the April 19th release candidate live CD image from
http://cdimages.ubuntu.com/ (now apparently moved to
http://releases.ubuntu.com/lucid/) the file is dated April 19th and
has the following MD5.

9b88dce8d215a3c2839105ab8e3139be *lucid-desktop-i386.iso

The burned CD fails at exactly the same place as my Lucid test
partition boot. So yes, the two bugs
  https://bugs.launchpad.net/bugs/567621
  https://bugs.launchpad.net/bugs/568779

are from the same cause.

Ahimsa

"As long as there are slaughterhouses, there will be battlefields." -Leo Tolstoy

-Jess E.

"I want a processor so powerful I can read the
manual by the light of the heat sink."- R.I.P. MRX

jtl999 (jtl999) on 2010-05-05
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers