Ubuntu

Ice listener

Reported by Jon Charge on 2010-02-02
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Could not create ICE listening socket

Could not create ICE listening socket: Cannot establish any listening sockets.

Sometimes it's followed by this message:

IceListenForConnections did not return a local listener!

This has been happening for a few days now, and I've not changed anything. I'm not even sure what package this is.

Carsten Agger (agger) on 2010-02-03
affects: ubuntu → xorg (Ubuntu)
alex-mobigo (alex-mobigo) wrote :

I am getting this message just before login in.
Fresh new ubuntu 9.10 install.

seems to happen on:
/**
* gsm_xsmp_init:
*
* Initializes XSMP. Notably, it creates the XSMP listening socket and
* sets the SESSION_MANAGER environment variable to point to it.
**/
void
gsm_xsmp_init (void)

alex@srv:~$ echo $SESSION_MANAGER
local/srv:@/tmp/.ICE-unix/1713,unix/srv:/tmp/.ICE-unix/1713

studiof451 (studiof451) wrote :

Since some days I get also this message on Ubuntu-9.10 AMD64 without any changes.

> Could not create ICE listening socket
> Could not create ICE listening socket: Cannot establish any listening sockets.

> Sometimes it's followed by this message:
> IceListenForConnections did not return a local listener!

After restart the system it seems all is okay.

Bryce Harrington (bryce) wrote :

Hi seropith,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg (Ubuntu):
status: New → Incomplete
Thomas Danhorn (tdanhorn) wrote :

I just had the same thing pop up before login on Xubuntu 9.10 (never happened before - update related?) and am attaching dmesg and lspci in the hope that it helps. I did not see any reference to ICE in dmesg, though.

Thomas Danhorn (tdanhorn) wrote :

Here is the lspci -vvnn output ...

Thomas Danhorn (tdanhorn) wrote :

... and the Xorg.0.log ...

Bryce Harrington (bryce) wrote :

@tdanhorn - thanks for providing that info, but we would like to see it from the original reporter. We may want to send this bug report upstream, but upstream has a hard and fast rule that logs from someone other than the original reporter are not acceptable. The reason for that is that quite often with X.org bug reports, two people may *think* they have the same issue based on commonality of symptoms and/or hardware, but in truth they have separate issues and mixing the report and the files can cause the developers some confusion.

If this bug report seems not to be getting attention, I would encourage you to file a new bug report with this data, and simply reference this bug report in your bug description.

Changed in xorg (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg (Ubuntu):
status: Incomplete → Invalid
Africanus (africanus) wrote :

Same problem in lucid lynx Beta

Africanus (africanus) wrote :

and other ouput:

Africanus (africanus) wrote :
Changed in xorg (Ubuntu):
status: Invalid → Confirmed
Marcelo Rocha (mcrocha) wrote :

When it's happen for me, locking session doesn't work more.

Greengo (remili) wrote :

This bug also affects me. I tpye in user name and password, screen goes black and the foowing messages appear:

Could not create ICE listening socket: Cannot establish any listening sockets
IceListenForConnections did not return a local listener!
Upon closing the message it returns me back to the login screen.

System: IBM T41 OS Ubuntu-9.10.

micki matt (mrmujoo) wrote :

I have the same issue > for note I am a relative NOOBy

Bug Description

Could not create ICE listening socket
Could not create ICE listening socket: Cannot establish any listening sockets.
Sometimes it's followed by this message:
IceListenForConnections did not return a local listener!

Its sporadic, it does not happen every boot and I only get the a message after signing in, on login.

I'm going to submit a Bug report as I have had no joy finding a solution or explanation.

micki matt (mrmujoo) wrote :

I submitted a Bug report, no joy there, as it is not considered to be a bug!
Anyone there? :O/ I would like toknow whats going on!

Bryce Harrington (bryce) wrote :

I really doubt this is an X bug.

But without exact steps to reproduce the issue, we won't even analyze it. Even with that, I'm not sure it's something we'd fix particularly in Ubuntu - maybe it should go upstream directly.

Changed in xorg (Ubuntu):
status: Confirmed → Won't Fix
j. pach (schaffner-gmx) wrote :

Got the same error messages on Ubuntu 10.4 (amd64)
Messages apperared suddenly before login screen popped up, before 10.4 was running cleanly for several months.
After clicking "ok" buttons I can log in my Gnome session.
Only effects so far (maybe not related: Window Menus (Open, Close) disappeared, also window frames, windows are not resizable anymore.

Attachments:
xorg.conf
screenshot
output of lspci -vvnn
output of dmesg

alex-mobigo (alex-mobigo) wrote :

Just for the record, it is happening on my ubuntu 10.04 now. it has a gtk look box.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers