Beginning of lines truncated in virtual terminal

Bug #51026 reported by Dominique Meeùs
6
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Fix Released
Undecided
gmlion

Bug Description

Binary package hint: xserver-xorg

Under Ubuntu 6.06, going from Gnome (1280x1024) to a vitual terminal with ctrl-alt-F1, I see only the end of the longest lines, the beginning of the lines is truncated on the left like if the virtual terminal had moved left out of the physical window. It is still functioning: I can do a (blind) login and sudo shutdown.
MSI K7NG2G motherboard with integrated Nvidia nForce2 video. AG Neovo E-17 17" LCD monitor 1280x1024, 135 MHz max, horizontal: 30-80kHz, vertical: 49-75Hz. No such problem with this hardware under Ubuntu 5.10.
I know little about packages but I am accusing X because I have no such problem if I boot in single user recovery mode. The problem is only when going from a graphical to a text mode virtual terminal.

Revision history for this message
William Grant (wgrant) wrote :

What type of video card and monitor are you running? And are you absolutely sure that the monitor is adjusted properly?

Changed in xorg:
status: Unconfirmed → Needs Info
Revision history for this message
Dominique Meeùs (dominiquem) wrote : Re: [Bug 51026] Re: Beginning of lines truncated in virtual terminal

William Grant a écrit ce qui suit, le 28/06/06 14:20 :
> What type of video card and monitor are you running?
Monitor completely described in my original bug report. A review of the
motherboard indicates that the Nvidia nForce2 IGP chipset incorporates a
GPU of type GeForce4 MX 420. Ubuntu agrees with that, to judge from
xorg.conf (see hereunder).
> And are you
> absolutely sure that the monitor is adjusted properly?
>

Adjusted like it is, this monitor did support Ubuntu 4.10, 5.04 and
5.10. It still works perfectly with 6.06 in text mode (starting in
recovery mode) and in graphic mode (Gnome). The problem is only when I
go back from Gnome to text mode. My hardware did not change, nor its
adjustment, only Ubuntu changed (fresh install of 6.06, not an upgrade
from 5.10).

Extract of my xorg.conf:
Section "Device"
    Identifier "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Driver "nv"
    BusID "PCI:2:0:0"
EndSection

Section "Monitor"
    Identifier "E-171"
    Option "DPMS"
    HorizSync 30-80
    VertRefresh 49-75
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Monitor "E-171"
    DefaultDepth 24
    SubSection "Display"
        Depth 1
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 4
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 8
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 15
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 16
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 24
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

William Grant (wgrant)
Changed in xorg:
status: Needs Info → Unconfirmed
Revision history for this message
gmlion (gm-l) wrote :

Is this bug still present? have you tried using different resolutions in Xorg/GNOME?

Changed in xorg:
assignee: nobody → gm-l
status: Unconfirmed → Needs Info
Revision history for this message
Dominique Meeùs (dominiquem) wrote :

gmlion a écrit ce qui suit, le 05/04/07 13:09 :
> Is this bug still present?

No it isn't. No such problem any more.

> have you tried using different resolutions in
> Xorg/GNOME?
>

I feel really sorry: I am not sure whether I changed anything. As far as
I remember I did not do any change in Xorg. I surely did NOT change the
resolution because I definitely do not want to use a resolution lower
than the native resolution (1280x1024) of my LCD monitor.

My guess is that the problem disappeared with Ubuntu 6.10 (bug was with
6.06).

I am aware that such a vague answer is not very useful to improve
software. I'll try to note what I do in the future and better follow my
own bugs reports! (I know how easy to forget and I usually DO note much
more than the average plain desktop user, as can be seen on
http://meeus-d.be/linux/, but not in this case.)

> ** Changed in: xorg (Ubuntu)
> Assignee: (unassigned) => gmlion
> Status: Unconfirmed => Needs Info
>
--

Amitiés, Dominique,
<email address hidden>, +32 (473) 61 31 75, http://www.meeus-d.be/

gmlion (gm-l)
Changed in xorg:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers