Strange artifacts in text fields within gtk applications in X when using nv driver

Bug #50768 reported by Eduard Grebe on 2006-06-23
18
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Undecided
Unassigned
X.Org X server
Fix Released
Medium
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-driver-nv

When editing a text field in a web application, e.g. this window on launchpad or a message in gmail and one moves the cursor with the keyboard, a cursor is drawn between every character and only disappears after several seconds. This does not happen in firefox on windows or on my Powerbook running Dapper PPC.

I'm not sure whether this is a firefox problem or Xorg's graphics rendering. This machine has an on-board nvidia video adapter and uses the open source driver. Device Manager says:
Vendor: nVidia Corporation
Product: Unknown (0x0163)

In text widgets such as this editing box (or the URL box) in firefox, the
erasure of the bar cursor is not done correctly when moving the cursor, leaving
annoying phantom cursors around. Even the normal bar cursor is actually not
drawn correctly (rather than blinking ON/OFF it blinks "half-up/half-down").

This problem disappears if I specify the XaaNoSolidFillRect option in my
xorg.conf file. I'm seeing this on a GeForce 6200 (TurboCache) chipset, with
version 1.0.1.5 of the nv driver (from Debian testing). I've also tried the
version 1.1.1 of the driver (from Debian experimental) and the problem seems to
still bepresent in that version as well.

I can confirm this same problem on Edgy. Information about my VGA card (also taken from Device Manager):

Vendor: nVidia Corporation
Product: GeForce 6200 TurboCache(TM)

Anderson Lizardo (lizardo) wrote :

Update: using nVidia's proprietary driver (nvidia-glx package) "fixes" the problem. Strangely enough, the only affected application is firefox...

I've also tested Mozilla's "official" firefox2 release and it also has the same problem.

Lito (lito-eordes) wrote :

I have the same problem with the nvidia-glx driver.

Occours in Mozilla-firefox and Mozilla-thunderbird apps.

I'm using a nVidia GeForce 7300 GS, but I had installed before an ATI vga card.

Changed in firefox:
status: Unknown → Confirmed
David Farning (dfarning) on 2007-01-28
Changed in firefox:
assignee: nobody → mozillateam
importance: Undecided → Medium
Changed in firefox:
status: Unconfirmed → Confirmed
David Farning (dfarning) on 2007-02-24
Changed in firefox:
assignee: mozillateam → mozilla-bugs

Sorry about the phenomenal bug spam, guys. Adding xorg-team@ to the QA contact so bugs don't get lost in future.

I'm using Firefox 2.0.0.1 in Kubuntu 6.10 on amd64. I have nVidia GeForce 6200 videocard and use it with nv driver. I also have this bug: when I'm typing in some text field in Firefox and move cursor in text by arrow keys, it leaves trace.

This should be fixed with xf86-video-nv-2.0.0. Can you please give that version a try?

Got the same problem - Seems to be specially prominent when typing in here. My Cursor just disappeared for the last sentance - then in came back split into two parts alternating. It's also left bits behind, using arrow keys to move cursor. Guarantees leaving bits of cursor around. Tends to disappear if text box is scrolled off screen then scrolled back, but not always - sometimes leaves new variations.

My graphics card is a nvidia geforce 7300LE and the nv driver is specified in xorg.conf (by default)

I can not reproduce this on my Feisty beta system (update as of March 25) with Fx 2.0.0.3

Reproducible on a Feisty beta system. Installed and updated as of March 25 using 2.0.0.2+1-0ubuntu1.

It's an nvidia 6200, but with the open source "nv" driver, desktop effects turned off, i386 system.

Screenshot was taken on slashdot, but I've seen it pretty much everywhere else.

what happens if you add
Option "XaaNoSolidFillRect"
?
could be duplicate of this bug
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-driver-nv/+bug/57466

Matt Russell (mattrusselluk) wrote :

Adding Option "XaaNoSolidFillRect" fixed this problem for me.

Eduard Grebe (eduardgrebe) wrote :

I have marked bug #57466 as a duplicate of this one, and I'm editing the description. I don't think this bug affects firefox, so removing that - but it has been marked as confirmed for firefox - so if someone disagrees, pls let us know.

description: updated
Eduard Grebe (eduardgrebe) wrote :

This bug does not seem to be a firefox problem, but rather to affect all GTK applications, and only when the open nvidia driver (xserver-xorg-driver-nv) is used.

Changed in firefox:
assignee: mozilla-bugs → nobody

seems to be gone in ubuntu feisty fawn, Option "XaaNoSolidFillRect" is not needed

Bryce Harrington (bryce) wrote :

Upstream they say this is fixed as of xserver-xorg-video-nv 2.0.0, which is available for feisty stable.

Changed in xorg:
status: Confirmed → Fix Released
Changed in xorg-server:
status: Unknown → Fix Released
description: updated
Changed in firefox:
status: Confirmed → Unknown
Changed in firefox:
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.