Screen locks up black on laptop lid close.

Bug #49521 reported by ddumanis on 2006-06-12
This bug affects 24 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)

Bug Description

Binary package hint: acpi

On my Dell 640C laptop, my screen locks up black whenever I close the lid.

Doesn't matter if I have it set to sleep/suspend, blank screen, or just no event. Whenever I close the lid, it locks up black and nothing short of restarting Gnome or rebooting can get my screen back.

Thanks for any fixes/suggestions.

William Grant (wgrant) wrote :

I have a Dell Inspiron 630m laptop, and I get the same behaviour if the lid action in System->Preferences->Power Management is set to `Do Nothing.' However, the screen can be woken up by switching to a VT (Ctrl+Alt+F1) and back again (Alt+F7). Can you please try that workaround?

Changed in acpi:
importance: Untriaged → Medium
status: Unconfirmed → Needs Info
wonderfullyrich (rjeong) wrote :

I've got a Dell Laitude D420 Running Feisty and exhibits the same problem. I've set the power management to do nothing, but with no results. Anyone figure this one out?

ddumanis (dave-davedumanis) wrote :

"Do nothing" won't help, but "blank screen" will. Try it. (You might
have to close and open your lid to get the backlight to come on, but at
least it won't lock black permanently.)

wonderfullyrich wrote:
> I've got a Dell Laitude D420 Running Feisty and exhibits the same
> problem. I've set the power management to do nothing, but with no
> results. Anyone figure this one out?

wonderfullyrich (rjeong) wrote :

Amazing, one little thing. You think you try everything and something obvious turns out to fix it. Many thanks ddumanis.

Launchpad Janitor (janitor) wrote :

[Expired for acpi (Ubuntu) because there has been no activity for 60 days.]

Dave Bekker (phyrexicaid-gmail) wrote :

This bug has resurfaced in Hardy Heron (Beta). All updates up until 03/04/2008 have been applied.

Closing laptop lid causes screen to go black. To get screen back on, there are two workarounds. Kill Xserver (Ctrl+Alt+Backspace) or use the Switch screen key (Fn+F4 on HP DV 6000)

Changed in acpi:
status: Invalid → Confirmed
Shawn vega (svega85-gmail) wrote :

I have this same problem on hardy 8.04. there is a really easy work around. all you have to do is go in to power management and change the setting from "blank screen" to "do nothing",or "suspend" or "hibernate". on my computer even if you set it to do nothing it still turns off and i don't get this bug.

Dave Bekker (phyrexicaid-gmail) wrote :

That work around doesn't seem to work in Kubuntu. The only workaround that fixes it for me is the switch screen key combination.

One of the updates has removed the switch screen workaround I outlined above. That no longer works. Luckily, I have found a new workaround :P

ctrl+alt+F1 then ctrl+alt+F7 restores the desktop.

Any ideas why this would be the case?

edward2020 (edward2020) wrote :

The same behavior is exhibited by Hardy 8.04 on my Thinkpad x41. That is, when I close and then open the lid the screen stays black. Only restarting xserver or rebooting does anything.

Changing the Power Management setting for 'When laptop is closed' to suspend does actually put the machine into suspend. However, coming out of suspend is slower than just restarting xserver.

Changing the Power Management setting for 'When laptop is closed' to 'do nothing' does not work. Nor does 'blank screen' or 'hibernate' do anything to fix this.

Edward, do you have an Nvidia card? I have managed to pin the problem down to the Nvidia driver.

When the Nvidia driver is loaded, the screen locks black, and I cannot see the terminal on tty1 (i.e. ctrl+shift+F1 results in black screen), however I can return to X11. If I *don't* load Nvidia then everything is fine. I can close the laptop lid, I can switch to tty1.

Here is the diff between the xorg.conf that gives no errors and the one which loads Nvidia:
< Section "Device"
< Identifier "Configured Video Device"
> Section "Module"
> Load "extmod"
> Load "type1"
> Load "freetype"
> load "glx"
> load "v4l"
> Section "Device"
> identifier "Configured Video Device"
> driver "nvidia"
> EndSection

I have attached both files as well as the xorg.conf I normally use (i.e. the one I was using in 7.10 without hassles). What is the next step in bug reporting?

edward2020 (edward2020) wrote :

No Nvidia card on my machine. Its a "16MB Intel Graphics Media Accelerator 900 video chipset."

jclw (jclw) wrote :

Edward, resetting xorg.conf using 'sudo dpkg-reconfigure -phigh xserver-xorg' did the trick for my X41.

Sokraates (sokraates) wrote :

Same or similar problem on my HP nx6110. Kubuntu Hardy. While my screen does not lock up completely and can be brought back to life by hitting some keys or using the touchpad (just like deactivating a screensaver), it will turn black a few moments after I stop typing or moving the cursor.

The screensaver is off and power manager is set to do nothing on closing the lid. Switching terminals doesn't help.

I've also seen this problem in Gutsy. I think it started when I stopped using laptop-mode doe to the hd-parking bug. Does anyone of you use laptop-mode?

Michael Greifeneder (mikegr) wrote :

Hello, I had the same problem on my Thinkapd X41 after upgrading to Hardy.
'sudo dpkg-reconfigure -phighxserver-xorg' solved the problem for me. It has removed almost everything from xorg.conf and uses a default configuration. However it starts in correct resolution and Google Earth, Mplayer and Frozen-Bubble work. So nothing to complain on my side.

lobner (soren-lobner) wrote :

Reporting that the fix also applies for the ThinkPad X60 after upgrade to hardy. Trimmed the xorg.conf somewhat excessively, but guess none of that old crap was needed anymore.

Great fix - maybe consider making this regeneration of xorg.conf mandatory to upgrade.

Just to comment that the fix:
'sudo dpkg-reconfigure -phighxserver-xorg'
does *not* solve the problem for me.

As stated above, the problem (for me) seems to be related to using the nvidia driver. If I use nv then I don't get the black screen, and I can switch (and view) the terminals via ctrl+alt+F1 etc.

fINTiP (lacking-latin) wrote :

I also have this problem.

I'm using a Dell Latitude C640. I don't know what kind of video card I have. I can find out later... doing this right before I go to bed.

If I set the laptop lid to turn screen off, or to go to sleep, when closed, I get a glitched up screen that changing TTY's does not fix (have not tried other work arounds). The computer is still running- I opened a terminal blind and ran hibernate one time (sudo pm-hibernate), but when I tried to bring back out of hibernate, it wouldn't load for over 15 minutes- got stuck on the "Ubuntu Studio" load screen.

Sleeping at all is not functional.

Hibernate is glitchy, and when it does work, takes forever to come out of. Sometimes it tells me that the hibernation failed.

As stated above, using 8.04. Also, my load screen use to be at a much higher resolution- now it takes up the whole screen. I don't know what could have caused that to change... the problems were not affected that I noticed (though who knows), so that's a separate question.

Bryce Harrington (bryce) wrote :

If you have intel graphics hardware which locks up or corrupts the screen when closing the lid, it's possible you may need the PipeA quirk. Please see the following link for more info: Pipe A Quirk

ddumanis, if adding 'Option "ForceEnablePipeA" "true"' in your xorg.conf as described in that link solves the issue, please post your lspci -vvnn output and assign this bug to me, and I'll incorporate a quirk for fixing it. Everyone else - if this fixes it for you, please file a new bug as described in the above page.

Sokraates (sokraates) wrote :

This seems to be partially fixed in Kubuntu Intrepid Ibex. Sometimes, I guess around 10% of the time one closes the lid, the lockup will occur. My previously reported problem with a blinking screen is fixed.

evolipel (mlepilov) wrote :

This seems to be an issue affecting many Dell laptops. I'm running a Dell Inspiron 8100 with an nvidia GeForce 2 Go (using the proprietary driver) on Hardy, and have fixed it with the advice given in this thread:

My variation on the advice (it is essentially the same as above) was to place

grep -q open /proc/acpi/button/lid/*/state
if [ $? = 0 ]
    # lid is open; turn the screen on
    vbetool dpms on


if [ `CheckPolicy` == 0 ]; then exit; fi

in /etc/acpi/

Basically, there seems to be *something* on Dell laptops that turns off a screen regardless of the OS or anything, and the only way to turn it back on is to run "vbetool dpms on"; "xset dpms force on", which the script uses, doesn't seem to work, so the screen remains blank. Additionally, it also seems that in recent releases of Ubuntu, or at least on Hardy, the script never even gets past the aforementioned policy check.

The following bugs seem to be related:

Freddo (damberge) wrote :

I also have an IBM X41 and when I upgraded from 7.10 to 8.04 this bug appeared. I tried changing power management settings (do nothing, suspend, hibernate etc) but this did not fix it.
I also tried to add 'Option "ForceEnablePipeA" "true"' to xorg.conf, but it did not help. The F1 F7 workaround worked for me, but I had to login again or I lost the wifi connection. What fixed it is running 'sudo dpkg-reconfigure -phigh xserver-xorg' as for the other X41 users.

Will Draven (will-draven) wrote :

Affected by this after upgrading to Karmic 9.10 on a Gateway 7426. 'sudo dpkg-reconfigure -phigh xserver-xorg' fixed it for me as well.

jgjoy (freyjoy) wrote :

For my (work) Dell D820 running 9.10 (karmic), the fix in #22 worked.
I was able to ssh into my laptop and run the ' vbetool dpms on ' command to get the screen back on when testing, which was handy. Ctrl-alt-f1/ alt-f7 did not work.

I should note that I have another local user defined which has default gconf values for gnome-power-manager (and others), and it did not appear to exhibit the problem with the screen blanking and not returning. If there is interest I can try to test that further.

Firestem4 (firestem4) wrote :

I have a Dell XPS M1210, and This has affected me ever since a few months after Kubuntu 9.10 was released. My laptop is in great working condition so I do not believe it is the laptops fault.

When I close the lid and try to open it the screen does not turn on. Not even the backlight in most cases. Switching to a VTE doesn't work either. I'm not sure why its doing this but I've also just reformatted my computer a few days ago and this issue is persisting. (Running current patches from Kubuntu 9.10, and latest Kernel).

I hope this gets fixed soon because this is becoming a real problem for me since I use this laptop a lot for my personal use and personal-business use.

If you need any information contact me.

bperu (ryan-paradiso) wrote :

I had the same problems on my Dell XPS M1210 running Ubuntu 9.10. When I closed the lid the screen turned off and would not turn back on when it was opened. Here is what I did to resolve the issue:

# Make a backup of if it exists
sudo mv
#Create new
sudo vi

# always turn on screen on open lid, regardless of policy or anything
grep -q open /proc/acpi/button/lid/*/state
if [ $? = 0 ]
    # lid is open; turn the screen on
    vbetool dpms on
    # lid is closed; turn the screen off
    vbetool dpms off

if [ `CheckPolicy` == 0 ]; then exit; fi

#Make executable
sudo chmod +x

#Restart acpi daemon
sudo /etc/init.d/acpid restart

This solution worked when using AC or battery power. I also noticed that the screen was turning back on after a few seconds when the lid was closed and if I opened it the screen would turn off again. Everything seems to be working correctly now.

Peter M. Clausen (pclausen) wrote :

I had the problem too in 9.10 but was too lazy to report it (shame on me)

Now I have installed ubuntu 10.04 and with Kernel 2.6.32-15 it works, but with the newer Kernel 2.6.32-16 it does not !

I have tried the above workarounds #14 (resetting xorg, but I am unsure if this really works for the new xorg ?) and above #27 (changing Both did NOT work with Kernel 2.6.32-16.

Peter M. Clausen (pclausen) wrote :

Closing the lid causes a total freeze of my system, not even ssh is possible.

I am giving up for now. I can not find a solution on my own and I am afraid that this problem may affect others with intel graphic card / dell laptops...

My laptop is a Dell Latitude D505 with fairly fresh install and upgraded version of Lucid, Ubuntu 10.04:
> uname -a
Linux clausen-laptop 2.6.32-16-generic #25-Ubuntu SMP Tue Mar 9 16:33:52 UTC 2010 i686 GNU/Linux

I have also tried the " Pipe A Quirk" with the file "/etc/X11/xorg.conf_NO_GO" which resulted in system black-out (no screen, not even ssh from other box). In the attached archive dell_lattitude_D505_Lucid.tar.gz I have added :
$ lspci -vvnn | grep -A1 "VGA compat" > vga_compat.txt
$ sudo dmidecode > dmi.txt

As well as the not working xorg.conf (generated with Xorg -configure + Option "ForceEnablePipeA" "true" ) as well as my "/etc/acpi/"

I'll be happy to give you additional infos, just tell me what you need. If I am posting in the wrong bug, please let me know.

Just for the record: Graphics do look fine, seem to have OK performance. With my old "Ubuntu 8.04.4 LTS" installation did NOT have this problem and as far as I remember I have not fixed or quirked anything...

jgjoy (freyjoy) wrote :

I share the same problem as Mr. Clausen with the 10.4 alpha and 2.6.32-16.

Peter M. Clausen (pclausen) wrote :

According to:

I tried to set boot option GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" which leads to crash, see Bug #539939.

James (jfinstrom) wrote :

Toshiba A205S5000
Runing Lucid Beta-1

Screen will go blank and sometimes does not come back, sometimes it does but if it does come back it takes about 2 miinutes and kills the session so possibly killing X. Not sure if this is the same bug bug but sounds too close to create a different one.

tags: added: lucid
Andrew (andy-miesem) wrote :

Inspiron 9100 here. No problems with previous Ubuntu, but now screen stays black after lid is closed.

Firestem4 (firestem4) wrote :

Dell XPS M1210. I had an issue with the previous version of Kubuntu but not with the latest version (10.04). Screen works perfectly.

T0beus (t0beus) wrote :

I have a Dell Latitude E4300. Lucid 10.04 w/ gnome load. Close lid, and black screen... locked. Intel video. This is when it is set to suspend on lid close. If I change to blank screen on lid closed, the "locked" screen pops up asking for a password, but the machine locks up with no response. I have to perform full power-down and reboot. Latest updates.

Hope we see some action on this one ;)

Jamie (solowinter) wrote :

This problem strikes randomly for me. When it happens, it's when my laptop is running in battery mode and I shut the lid. My power management setting is for it to do nothing but lock the screen but the screen gets turned off sometimes and will not come back on when the lid is opened. My only solution is to kill the power.

The problem with killing the power is that I am using the Ext4 filesystem, so when I reboot I get to see all of the orphaned inodes possibly containing important data that was lost as a result of this reboot. Losing data is not acceptable and I'm pretty pissed about this bug.

firmit (firmit) wrote :

I can confirm that # 27 partially ( literally ) solved things for me. At least every second time I open the lid... the resolution of my external screen is wrong half of the time together with the laptop lid being on even when closed.

On a Dell E6400

I have a very similar bug. This has appeared over a number of OS installations. Currently with 10.04. I'm running a Dell Inspiron 5400 and having issues with the screen going black, and remaining so. This happens most often when I've had the lid closed, but perhaps 10% of the time I'm just sitting watching my screen and *bango* black screen. Mouse movement doesn't bring it back. I have all powersaving options turned off. No hybernate, or screen blank, or screensaver. This can happen even just a few seconds after key/mouse interaction (though not often). I have not tried any of the suggested solutions, but just wanted to add that when this does happen to me, I've found that opening and shutting the lid... many times... eventually gets me to where the backlight comes on again. I can also sometimes see a very black impression of windows onscreen, so I know that the LCD is displaying stuff but the backlight isn't on. It's pretty obvious when I shut/open the lid when I've "got it"... when it's OK the screen is blank, but I can see the backlight is operational. I then just touch the mousepad to get the display back to normal. Every once in a while it takes dozens of close/open tests to get it to work, and once in a blue moon I just (hard reset) reboot and it's right straight away.
Very annoying little bug.
Next time I will try the suggested workarounds and report on progress.

Peter M. Clausen (pclausen) wrote :

@Andrew: Do you have a intel graphic card? See also Bug #462939 (my dell lattitude D505 has intel 855GM graphics)

Michal (mikeos) wrote :

Same problem on Dell Latitude E6410 with running Maverick 2.6.35-22-generic; nVidia proprietary drivers 256.53. Tested with 2.6.36 RC kernels and PPA nVidia drivers (260.x series from x-swat) and Xorg Edgers PPA too with same results.

Results of different scenarios:

1) $ xset dpms force off
-> display goes off
...touching mouse and keyboard
-> display backlight comes up, but nothing is shown unless virtual terminal toggled or "xset dpms force on" command invoked

2) $ xset dpms force standby
-> mostly produces the same behaviour as scenario 1
-> sometimes touching mouse and keyboard does not even turn on backlight and the command "xset dpms force on" needs to be called twice. Firstly the result of the call is backlight restore, after second call graphics starts to appear on display

3) # vbetool dpms off
-> display backlight turned off but graphics (barely) visible
...touching mouse and keyboard
-> nothing happens with display state
...need to invoke "# vbetool dpms on" or "$ xset dpms force on" to restore display to a backlit state

Note: with Xorg.conf empty, default open-source display driver is used (nv? nouveau?), which results in low-res X without acceleration however dpms on and off works correctly.

Michal (mikeos) wrote :

In my case the problem is fixed. It was caused by nvidia proprietary drivers; with version 260.19.06 this bug has disappeared.
"xset dpms force suspend" suspends the display, pressing any key or moving mouse pointer wakes it up. read it to me.I will get back to you soon.
Sent from my BlackBerry®
powered by Sinyal Kuat INDOSAT

Prunus dulcis (prunus-dulcis) wrote :

I am using an IBM X41 Tablet with a freshly installed maverick (no update) and the above mentioned tricks ('sudo dpkg-reconfigure -phigh xserver-xorg' and F1 F7) did not do anything so I still have to hard shut the notebook down and then restart it whenever I forget NOT to close the lid. This is not a minor issue, since I can potentially lose documents, mail and evolution configurations (happened only once thankfully)!

I would be happy to help with any information necessary in resolving this bug - I never encountered this bug in any of the previous four ubuntu versions with this notebook.

Joschi Poschi (joschiposchi) wrote :

I'm experiencing this issue on a Lenovo U160 (Intel GMA HD) running Xubuntu 11.04 instantly after closing the lid. The lid close action is set to "do nothing".

This is a bug from 2006. Wonder if it will ever get assigned?

Kushal Jain (t-contact2kushal) wrote :

Hi, I have Lenovo G550, and I installed Ubuntu 11.04 on it. Everything was working fine till few days but now I am experiencing the same problem.

When I close the lid, the screen gets black and I get no response. I tried to press Alt F1, F2 etc. but nothing worked. After that, I tried to change my power settings but it also didn't worked. The only action I left with is to restart my laptop.

As I am new to Ubuntu and using it first time, stepwise solution will be highly appreciated.

Below are the info. that I think we be helpful to you:-

Exact kernel version:
Linux kushal-Lenovo-G550 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686 i686 i386 GNU/Linux

If you need any further information, please let me know.

Joey Perry (zimmatic) wrote :

Have been having the same problem for a while, on an HP Pavilion dm1 laptop. Thought it had been resolved and found out the hard way it haven't after my laptop overheated in it's case while closed. It seems when it "locks up", the CPU ramps up really high and the fan starts pumping out heat. If anyone can suggest how to troubleshoot this, I'd appreciate it, before my laptop ends up melting itself (outside the case it just quickly runs the battery dry).

Same problem: Macbook Pro 5,3

Linux 3.2.0-24-generic #37-Ubuntu SMP

Eddie (system-w) wrote :

I do not need suspend, after doing disable of /etc/acpi/ all is going well;
on lid close then open - the system stays fresh and ready for battle. :)

TraceyC (grrlgeek) wrote :

I'm experiencing a very similar issue on a Lenovo W530 laptop running Xubuntu 13.04.
Immediately after closing the lid, when I re-open the lid, the screen is frozen. It is not black, it displays what was open when the lid was closed. The mouse cursor does not move. Both mouse & keyboard are unresponsive, so I am unable to switch to a virtual terminal.

The lid close action is set to "do nothing" for both AC and battery power.
I'm running XFCE with xfce-power-manager.

# uname -a
Linux tracey-ThinkPad-W530 3.8.0-27-generic #40-Ubuntu SMP Tue Jul 9 00:17:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The problem may not be the acpi package, as on my system I see:

% apport-collect 49521
Package acpi not installed and no hook available, ignoring

TraceyC (grrlgeek) wrote :

This problem still exists in the exact same way as my last message on 14.04 at this time. It surfaced with both the free and nvidia-proprietary drivers. Unfortunately, it means I need to switch to another distro. I am taking the laptop on a business trip. I absolutely need to be able to close the lid without the system freezing as I move from place to place.

Curt Sampson (cjs-cynic) wrote :

I've just now, with 14.04 (fully updated as of the date of this message) had a similar problem on my Lenovo T510. However, it seems somewhat variable with the standard (open source) Nvidia driver. (I've set my logind.conf to ignore lid close rather than suspend, but I saw similar issues before I did that.)

Most of the time, on closing the lid and re-opening it, I'm greeted with a black display, and Ctrl-Alt-F1 will not bring up the console window. However, Ctrl-Alt-Del will still reboot the machine. On two occasions, however, the display came back normally after re-opening the lid, and on one occasion the machine locked up so badly that Ctrl-Alt-Del wouldn't reboot nor would even the caps lock light come on when pressing the caps lock key.

Switching to the closed source Nvidia driver seems to have fixed the problem for me.

ddumanis, is this still an issue on a supported release? If so, could you please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 49521

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

affects: acpi (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
importance: Medium → Low
status: Confirmed → Incomplete
tags: removed: lucid
snurfle (snurfle) wrote :

Lenovo W530

Close screen, and the machine locks.

No amount of keystrokes can unlock the screen - ctrl/alt/f1 does nothing, neither does c/a/del, c/a/bkspc, reisub... nothing.

Oddly though - function key + spacebar will still cycle through the backlight on the keyboard.

I see that this bug set to expire in 1 day if no further action takes place... I have already wiped 14.04 off my home machine because of all the issues, and the laptop is next now more so than ever. I would never have bothered posting yet another bug report, but I saw another Lenove W530 in this thread, and I figured maybe somebody will be able to at get this issue fixed if it is hardware related... however, it was working just fine a month ago, so who knows what's causing it now.

snurfle (snurfle) wrote :

OK, still broken.

Now - this is not an exact duplicate of the bugs listed in this thread - The other Lenovo listed on here apparently will still allow ctrl-alt-del to work, but on mine it does not.

I had intended on uninstalling 14.04, but this is a work machine and unfortunately I have to keep ubuntu on it. So now my problem - at least, the most problematic problem - is that closing the screen renders the machine unusable without doing a hard reboot. And even then, it is a crap shoot on whether or not it will reboot without cycling the power a few times after that; it is also now rebooting to a flashing cursor and just halting with absolutely nothing ever showing in any of the logs... but only after it locks up because someone was unlucky enough to close the lid. If I am able to use the normal shut down or restart method, then it is still suddenly making me log in twice when it does reboot... once at a CLI, and then a second time at the regular GUI login screen.

All of this, the freezing, the failed boot, the multiple logins - this all started a few days ago.

So... do I file a new bug report, or keep adding to this one, or is this just another "that's just the way it is" bugs that will eventually have a workaround in a random thread somewhere?

snurfle, it would help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

snurfle (snurfle) wrote :

Sorry for taking so long to respond to this.

bug # 1423917 created this morning after upgrading to 14.04.2, just in case it was fixed in that release, but it was not.

Not sure how to subscribe someone else to a bug report.

Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers