Mouse and Keyboard stuttering/unresponsive - results in some lost key strokes

Bug #480644 reported by pierz on 2009-11-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Since upgrading to Ubuntu 9.10 my USB mouse and keyboard 'stutter' - they're unresponsive and keep stopping (the mouse), and when I type (quickly) I'm seeing some missed keystrokes. This is when the machine is idling (load ave:0.06), though some apps are running, and it gets worse when the machine loaded.

It was fine in 9.04 - apart from when the system was heavily loaded the mouse would be somewhat unresponsive but I never lost keystrokes.

The machine (Sun W1100z/2100z) is a dual 2GHz AMD Opteron(tm) Processor 246 with 2GB RAM, the usb( 2@ AMD-8111 + 3@NEC Corporation) USB is being driven by Linux 2.6.31-15-generic ohci_hcd. It doesn't seem to make a difference which USB socket I use.

Soo-Hyun Choi (s.choi) wrote :

I can confirm that I have experienced a similar symptom (or worse than the above description). I also upgraded to Ubuntu 9.10 from 9.04, and keyboard and mouse became something that cannot be tolerated - e.g., unresponsive keyboard strokes, especially when I type fast, jumping mouse points here and there, and very sluggish application startup (it looks like hang about a sec, and then come up). This happens virtually all the times (with no heavy application is in use).

The machine has dual AMD Opteron 246 with 2GB RAM. It is running Ubuntu 9.10 amd64 server edition (2.6.31-14-server).

Changed in ubuntu:
status: New → Confirmed

Is this bug still occuring in Lucid or Maverick? Please report back. Thanks!

affects: ubuntu → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
pierz (p-ohanlon) wrote :

I spent some time looking in to this. In the end it was cured by disabling the ondemand service (which seemed to become enabled when I upgraded to 9.10). It seems that older processors like mine (Opteron 246) don't do ondemand very well and the result is a very sluggish machine.

I the bug can be closed though it might be worth feeding back the fact that the upgrade process (or ondemand) should warn about the potential issues when an older CPU is detected.

Bryce Harrington (bryce) wrote :

[From reporter's comment it sounds like this is now fixed. If not, please reopen with clarification.]

Changed in xorg (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers