Shift+Backspace Kill X

Bug #46814 reported by Lukas Sabota on 2006-05-26
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

I'm running the latest Dapper x86.
If a remember correctly, the keystroke to kill X was alt-ctrl-backspace. If I press shift-backspace, X is killed. This is VERY frustrating, as those keys are easy to press on accident. This is my third attempt at filing this bug, because the last two times I tried to file it, I accidently killed my X server.

The keystroke to restart X should be alt-ctrl-backspace, and not shift-backspace.

PS: Is there any workaround in the meantime to disable keystrokes that kill X completely? I'm going crazy, I can't get anything done!

Simon Law (sfllaw) wrote :

The DontZap option for /etc/xorg.conf is supposed to disable that.
Please see the xorg.conf(5x) manpage.

Does that also stop S-Backspace from killing your system?

Changed in xorg:
status: Unconfirmed → Needs Info

I'm 99% sure you're running XGL. This is an XGL feature. (Feature from
hell if you ask me, but it's a feature)

 status Rejected

Changed in xorg:
status: Needs Info → Rejected
Lukas Sabota (punkrockguy318) wrote :

Yes, I was running XGL. I had no idea, I changed my /etc/X11/X to Xgl and forgot to change it back. Sorry!

not using xgl and I have this problem

problem now exists

Changed in xorg:
status: Invalid → Confirmed
Bryce Harrington (bryce) wrote :

Shift-Backspace is an XGL "feature", not an xorg bug, so closing as invalid.

Changed in xorg:
status: Confirmed → Invalid
Martin Th. Fei (nimoth) wrote :

I do think this is a bug because it has suddenly been enabled on my machine after upgrading from 9.04 to 9.10. I do not really have an idea of what XGL is but as far as I know I am using X. I have never actively installed XGL. Why is the shortcut suddenly enabled?

Changed in xorg (Ubuntu):
status: Invalid → New
Martin Th. Fei (nimoth) wrote :

The easiest solution is xmodmap -e "keycode 22 = BackSpace BackSpace Terminate_Server" as explained here: http://ubuntuforums.org/showthread.php?t=202654&page=2

Bryce Harrington (bryce) wrote :

Martin, rather than reopen an old bug (which is almost certainly unrelated), you should file a new bug.

Changed in xorg (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers