X/GDM doesn't start on Karmic Koala

Bug #434320 reported by Wouter Stomp on 2009-09-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

On Karmic (either upgraded from Jaunty or using the alpha 6 cd), boot fails at the point where xsplash should switch to gdm. Xsplash is displayed normally, but then in the end it keeps flashing to a black screen and then back to xsplash again. It does this in an endless loop. Attached are the files ubuntu-bug collects on jaunty, only KarmicXorg.0.log is from Karmic.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
MediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release i386 (20090420.1)
Package: xorg 1:7.4~5ubuntu18
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5hostname4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xorg
Uname: Linux 2.6.28-11-generic i686

Bryce Harrington (bryce) on 2009-09-22
Changed in xorg (Ubuntu):
status: New → Confirmed
tags: added: ubuntu-boot

Does X fail to start, or is GDM not started? They would be quite different bugs

If you login to a console and type "status gdm" what do you see?

Are there any boot messages?

Do you see X try and start, does it fail?

Changed in xorg (Ubuntu):
status: Confirmed → Incomplete

It is hard to tell which one of the two fails, but my best guess would be X. I can't login to a console to check, because when I press ctrl-alt-f1 I get a scrambled screen and can't do anything. There are no boot messages shown, just xsplash and a black screen repeating each other.

Changed in xorg (Ubuntu):
status: Incomplete → Confirmed

This has been fixed now, reinstalling jaunty and installing the latest karmic updates worked fine. It seems like this was a duplicate of bug 421225 I got the same error messages when trying to run startx from the console.

Changed in xorg (Ubuntu):
status: Confirmed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers