xserver crash after an update of xserver-xorg with a matrox card

Bug #43094 reported by acouphenix on 2006-05-05
12
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned
xorg (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: xserver-xorg

An update security recommands me to update the meta "xserver-xorg". I approve and launch the update (65 packages with xserver-xorg-xxx).

After a reboot, xserver crash and I have:

"Required Symbol MGA...
Fatal server error:
Some required symbols were unresolved"

With a dpkg-reconfigure xserver-xorg, the problem persists.
I have a Matrox graphic card G200.

I use "vesa" in device of xorg.conf but i can't use 1280*1024 résolution.

Changed in xorg:
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

The recent breezy security update didn't really change much, I doubt that the patch caused the crash. Does it help if you downgrade to the previous version?

  sudo apt-get install --reinstall xserver-xorg/breezy xserver-xorg-core/breezy

Or, the other way round, did you do a full apt-get dist-upgrade, or did you just update xserver-xorg? If the latter, can you please try a full dist-upgrade (which will update the various drivers as well) and check again?

Thanks!

Changed in xserver-xorg:
status: Unconfirmed → Needs Info
acouphenix (acouphenix) wrote :

I use the update notifier of gnome. This applet call me for update-security of xserver-xorg. But not full dist-upgrade, a simple upgrade.
The update have got kernel update and i reboot.

So, I downgraded :
- xserver-xorg
- xserver-xorg-core
- xserver-xorg-dbg
- xserver-xorg-driver-mga

And reboot the xserver with device "mga" at xorg.conf.
It's OK like yesterday, I have my native résolution 1280x1024.

But if i update xserver-xorg, xserver crash.

Thanks for the help.

Martin Pitt (pitti) wrote :

source is 'xorg' for breezy and hoary, but changing it back to not confuse dapper bug triagers.

Martin Pitt (pitti) wrote :

Can you please attach /var/log/Xorg.0.log after the crash?

Aatos Kaatos (aatos-kaatos) wrote :
Download full text (30.6 KiB)

hi,

I have exactly the same problem, xserver (with "mga" device) didn't start after an update. (Matrox G450)

here is Xorg.0.log after the crash:

br, Henri

-----------
X Window System Version 6.8.2 (Ubuntu 6.8.2-77.1 20060503192905 <email address hidden>)
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.12 i686 [ELF]
Current Operating System: Linux marsu 2.6.12-10-386 #1 Fri Apr 28 13:13:44 UTC 2006 i686
Build Date: 03 May 2006
 Before reporting problems, check http://wiki.X.Org
 to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.12-10-386 (buildd@terranova) (gcc version 3.4.5 20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8.1)) #1 Fri Apr 28 13:13:44 UTC 2006
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May 7 09:52:52 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "Matrox Graphics, Inc. MGA G400 AGP"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
 Entry deleted from font path.
(WW) The directory "/usr/share/X11/fonts/CID" does not exist.
 Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID".
 Entry deleted from font path.
 (Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID").
(**) FontPath set to "/usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.2
 X.Org Video Driver: 0.7
 X.Org XInput driver : 0.4
 X.Org Server Extension : 0.2
 X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
 compiled for 6.8.2, module version = 1.0.0
 Module class: X.Org Font Renderer
 ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="X.Org Foundation"
 compiled for 6.8.2, module version = 1.0.0
 ABI class: X.Org Video Driver, version 0.7
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3189 card 1106,0000 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b168 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:0a:0: chip 10ec,8139 card 10ec,8139 rev 10 class 02,00,00 hdr 00
(II) PCI: 00:0c...

acouphenix (acouphenix) wrote :

My Xorg.0.log file is likely the same.

- I downgraded xserver-xorg
- I reboot
- Update notifier's gnome call me for update of xserver-xorg
- I click OK
- I reboot
- No crash of Xserver with "mga" device and the new xserver-xorg package.

Martin Pitt (pitti) wrote :

I just tried this on a clean breezy install. I do not have a Matrox card, so I cannot actually start the X server, but the module was loaded without any problems (unresolved references). acouphenix, your last comment seems to indicate that it works now). Can you confirm that upgrading xserver-xorg alone breaks, but xserver-xorg and xserver-xorg-driver-mga together works?

Jerome S. Gotangco (jsgotangco) wrote :

Please confirm if this is fixed per Martin's last reply. We're cleaning up the bug tracker so input would be appreciated. Thanks.

Jerome

Aatos Kaatos (aatos-kaatos) wrote :

hi,

I changed to the dapper release because with breezy it was not possible to start X after the upgrade and it seemed that a bugfix has not been coming soon.. So I don't know how breezy works with a Matrox G200 or G450 graphic card now.

br,
Henri

Right we're tagging this as fixed then since it now works fine with Dapper. Thank you.

Changed in xserver-xorg:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers