Ubuntu

exmh-bg dying, becoming a zombie

Reported by Bodo Bellut on 2009-09-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
exmh (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: exmh

When starting exmh configured to auto inc, the background process exmh-bg is started correctly, after some seconds the backbroung process dies and becomes a zombie, afterwards auto inc doesn't work any more (as would be expected).

This is on AMD64 Jaunty with all updates installed.

bodo@sakura:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

bodo@sakura:~$ apt-cache policy exmh
exmh:
  Installed: 1:2.7.2-16
  Candidate: 1:2.7.2-16
  Version table:
 *** 1:2.7.2-16 0
        500 http://de.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Bodo Bellut (bodo-bellut) wrote :

This also happens with Karmic:

bodo@sakura:~$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

bodo@sakura:~$ apt-cache policy exmh
exmh:
  Installed: 1:2.7.2-18
  Candidate: 1:2.7.2-18
  Version table:
 *** 1:2.7.2-18 0
        500 http://de.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

Bodo Bellut (bodo-bellut) wrote :

I've finally found out why this happens. The two processes use the Tk send function to communicate with each other which only worls, when the xhost list is empty. For some reason, my xhost list wasn't empty but contained these entries:

bodo@sakura:~$ xhost
access control enabled, only authorized clients can connect
SI:localuser:bodo
SI:localuser:gdm
SI:localuser:root

These entries are added by /etc/X11/Xsession.d/60x11-common_localhost contained in x11-common.

bodo@sakura:~$ apt-cache policy x11-common
x11-common:
  Installed: 1:7.4+3ubuntu10
  Candidate: 1:7.4+3ubuntu10
  Version table:
 *** 1:7.4+3ubuntu10 0
        500 http://de.archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     1:7.4+3ubuntu7 0
        500 http://de.archive.ubuntu.com karmic/main Packages

Bryce Harrington (bryce) wrote :

Hi bodo-bellut,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2010-02-25
tags: added: jaunty
Bodo Bellut (bodo-bellut) wrote :

Hi,

output of lspci and Xorg.0.log are irrelevant as this bug is against /etc/X11/Xsession.d/60x11-common_localhost and not Xorg itself.

regards,
Bodo

Changed in xorg (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2010-11-04
Changed in xorg (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: lucid
Bryce Harrington (bryce) on 2011-02-15
Changed in xorg (Ubuntu):
importance: Medium → Low
Timo Aaltonen (tjaalton) wrote :

It's still an exmh bug, XAUTH is needed and not going away.

Changed in xorg (Ubuntu):
status: Triaged → Invalid
Bodo Bellut (bodo-bellut) wrote :

Yes, XAUTH is needed but we're talking about XHOST that's causing problems. Causing problems not only with exmh but each and every Tk application using the send function to communicate with its child windows.

From the Tk send man page:

"In order to provide at least a small amount of security, Tk checks the access control being used by the server and rejects incoming sends unless (a) xhost-style access control is enabled (i.e. only certain hosts can establish connections) and (b) the list of enabled hosts is empty. This means that applications cannot connect to your server unless they use some other form of authorization such as that provide by xauth."

So this bug is still valid as for some reasons there are entried added into the XHOST list which aren't necessary in any way, in fact, all systems I'm using run fine with an empty XHOST list since XAUTH has been invented some ten years ago.

Changed in xorg (Ubuntu):
status: Invalid → Confirmed
Rajiv Shah (compukid) on 2013-06-03
Changed in exmh (Ubuntu):
status: New → Confirmed
status: Confirmed → New
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers