sometimes, when caps lock is not active, characters are displayed in uppercase under X

Bug #366801 reported by marco.pallotta on 2009-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I noticed that sometimes (in particular after resuming from suspend/hibernate but I haven't tested if this issue is really related to this) even if the caps lock key is not active the system detects that caps lock is enabled so the characters I type are displayed in uppercase. I have to enable caps lock to insert them in lowercase. This issue only seems related to X. In fact if I switch to ttys the things work ok.

Tested with Hardy and Xorg 1:7.3+10ubuntu10.2

Bryce Harrington (bryce) wrote :

Can you please test the Jaunty Live CD and see if you can reproduce the issue there?
CD images are available at http://cdimages.ubuntu.com/releases/
Thanks ahead of time.

Changed in xorg (Ubuntu Karmic):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Also, if you can reproduce it on Jaunty, please run the following command to collect files we'll need:

apport-collect 366801

Bryce Harrington (bryce) on 2009-04-28
Changed in xorg (Ubuntu Karmic):
status: Incomplete → New
status: New → Incomplete
Nicklas W Bjurman (lordmetroid) wrote :

This happened to me as well a few days ago, I had played Quake Wars and after I quit the caps lock key somehow was reversed so that capital letters was produced when caps lock indicated it was off and vice versa.

marco.pallotta (marco-pallotta) wrote :

Nicklas, in which distro did you notice this issue?

Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg (Ubuntu Karmic):
status: Incomplete → Invalid
marco.pallotta (marco-pallotta) wrote :

Bryce, I made some tests on Jaunty as you asked to me, and I haven't be able to reproduce the issue that sometimes (even if it happens seldom) happens on Hardy. So I think that the bug may be marked as "fix released" on Hardy.
I also think, at this point, that Jaunty and Karmic may be deleted on the section related to the system affected by this bug.

JC Hulce (soaringsky) wrote :

We're closing this bug since it is has been some time with no response from the original bug reporter. However, if the issue still exists in the latest development version of Ubuntu and you are the original reporter please feel free to reopen with the requested information. If you are not the original reporter, please don't reopen this one but instead file a new bug and reference this one.

Changed in xorg (Ubuntu Hardy):
status: New → Invalid
Changed in xorg (Ubuntu Jaunty):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers