Upgrade to Jaunty from Intrepid fails broken packages: brasero libbrasero-media0 libxcb1 xserver-xorg-video-all

Bug #359006 reported by Marek Slama on 2009-04-10
2
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-all

I wanted to upgrade to current Jaunty dev version so I changed all 'intrepid' to 'jaunty' in /etc/apt/sources.list, run sudo aptitude update, sudo aptitude full-upgrade and get log below. I know there was some version mismatch before but it was reported to be fixed. Not sure it is problem in repository or on my machine.

Log:
[apt]> sudo aptitude full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  brasero libbrasero-media0 libxcb1 xserver-xorg-video-all
....
The following packages will be REMOVED:
  amarok-engine-xine{u} dkms{u} fakeroot{u} lib32nss-mdns{u} libart2.0-cil{a} libarts1c2a{u} libartsc0{u}
  libboost-program-options1.34.1{u} libcanberra-gnome{a} libdb4.5-java{a} libdb4.5-java-gcj{u} libexiv2-4{u} libgconf2.0-cil{a}
  libgmime2.2-cil{a} libgnome-vfs2.0-cil{a} libgnome2.0-cil{a} libifp4{u} libnb-ide9-java{u} libnb-platform8-devel-java{a}
  libnb-platform8-java{u} libnjb5{u} libofa0{u} librasqal0{u} libsuitesparse-3.1.0{u} libtunepimp5{u} libwxbase2.6-0{u}
  libwxgtk2.6-0{u} libxcb-xlib0-dev{u} libxext-dev{u} libxi-dev{u} libxml-namespacesupport-perl{u} libxml-sax-expat-perl{u}
  libxml-sax-perl{u} libxml-simple-perl{u} linux-headers-2.6.26-4{u} linux-headers-2.6.26-4-generic{u} linux-headers-2.6.27-10{u}
  linux-headers-2.6.27-10-generic{u} linux-headers-2.6.27-11{u} linux-headers-2.6.27-11-generic{u} linux-headers-2.6.27-12{u}
  linux-headers-2.6.27-12-generic{u} linux-headers-2.6.27-13{u} linux-headers-2.6.27-13-generic{u} linux-headers-2.6.27-14{u}
  linux-headers-2.6.27-14-generic{u} linux-headers-2.6.27-3{u} linux-headers-2.6.27-3-generic{u} linux-headers-2.6.27-4{u}
  linux-headers-2.6.27-4-generic{u} linux-headers-2.6.27-5{u} linux-headers-2.6.27-5-generic{u} linux-headers-2.6.27-7{u}
  linux-headers-2.6.27-7-generic{u} nvidia-177-kernel-source{u} nvidia-glx-177{a} nvidia-settings{u} python-beaker{u} python-qt3{u}
  python-sqlalchemy{u} python2.5-dev{u} system-cleaner{a} system-cleaner-gtk{a} ttf-dustin{u} x11proto-xext-dev{u}
  xserver-xorg-video-apm{a} xserver-xorg-video-ark{a} xserver-xorg-video-chips{a} xserver-xorg-video-mga{a}
  xserver-xorg-video-openchrome{a} xserver-xorg-video-radeonhd{a} xserver-xorg-video-s3virge{a} xserver-xorg-video-tga{a}
  xserver-xorg-video-v4l{a}
......
The following packages have unmet dependencies:
  xserver-xorg-video-all: Depends: xserver-xorg-video-apm but it is not installable
                          Depends: xserver-xorg-video-ark but it is not installable
                          Depends: xserver-xorg-video-chips but it is not installable
                          Depends: xserver-xorg-video-mga but it is not installable
                          Depends: xserver-xorg-video-s3virge but it is not installable
                          Depends: xserver-xorg-video-openchrome but it is not installable
                          Depends: xserver-xorg-video-v4l but it is not installable
  libbrasero-media0: Conflicts: nautilus-cd-burner but 2.25.3-0ubuntu1 is to be installed.
  libxcb1: Breaks: libxcb-xlib0 but 1.1-1.1 is installed.
  brasero: Conflicts: nautilus-cd-burner but 2.25.3-0ubuntu1 is to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
libxcb-xlib0
xserver-xorg-video-all

Keep the following packages at their current version:
brasero [0.9.1-0ubuntu3~intrepid1 (now)]
libbrasero-media0 [0.9.1-0ubuntu3~intrepid1 (now)]

Leave the following dependencies unresolved:
epiphany-browser-dbg recommends xulrunner-1.9-dbg | libwebkitgtk1d-dbg
gnome-dbg recommends libmozjs1d-dbg
gnome-dbg recommends xulrunner-1.9-dbg
gnome-dbg recommends libxine2-dbg
Score is -532

Bryce Harrington (bryce) wrote :

Hi mslama-email,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg (Ubuntu):
status: New → Incomplete
Marek Slama (mslama-email) wrote :

Do you mean before I perform update or after? If I will do it after I expect X Server will be broken due to missing drivers => machine will be unusable unless I will make backup first and restore it. So I want to be sure before I will start.

Bryce Harrington (bryce) on 2009-04-22
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Bryce Harrington (bryce) wrote :

[No need to have this double-filed against xorg as well]

Changed in xorg (Ubuntu):
status: New → Invalid
Timo Aaltonen (tjaalton) wrote :

We would've needed full logs from the upgrade to be able to help. The situation has either fixed itself or the logs are long gone. Closing the bug.

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers