Screen blinks randomly on external monitor

Bug #349943 reported by Vitaly on 2009-03-27
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Hardware: Asus F8Va laptop (Core 2 Duo P8600, ATI HD3650, 1440x900)
OS: Ubuntu 9.04 beta x64 (Wubi installation inside Windows Vista Home Premium x64 SP1)

External monitor (Samsung SyncMaster 2493HM, 1920x1200), connected via HDMI, blinks several times a minute, randomly. When there is no user activity, it doesn't seem to blink however.
By "blinking" I mean, the monitor goes off and then on, like it usually does when it changes resolution, only resolution doesn't change. Also, when I move windows around, thin horizontal stripes flash in fraction of second from time to time (only on external monitor).

Screen configuration:

Samsung 24": On
Resolution: 1920x1200
Refresh rate: 60 Hz
Rotation: Normal

Laptop 14": On
Resolution: 1440x900
Refresh rate: 67 Hz
Rotation: Normal

Mirror screens: unchecked

Relative position of screens (physical and in Display Preferences) laptop screen below the external screen, centred.

jyoungtaylor (jyoungtaylor) wrote :
Download full text (3.9 KiB)

I too am seeing the same symptoms on my DVI external monitor. It seems to only happen when the computer is being used or any program is hanging. I would be willing to provide any further diagnostic information/steps.

OS: 9.04 release x32 Native install
Hardware: T60p

I have two external monitors only the DVI blinks

Screen config:

NEC 2070NX 20"
Resolution: 1600x1200
Refresh: 60Hz
Rotation: Normal
Connection: DVI

Soyo Topaz S 24"
Resolution: 1920x1200
Refresh: 60 Hz
Rotation: Normal
Connection: VGA

Screens are side by side in a "big desktop" fashion:

xorg.conf:

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 SubSection "Display"
  Virtual 3520 1200
 EndSubSection
EndSection

Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "ServerFlags"
 Option "DontZap" "False"
EndSection

Video card from lspci:
ATI Technologies Inc M56GL [Mobility FireGL V5250

Driver:
Default driver (open source I think)

Lsmod:
Module Size Used by
aes_i586 15744 0
aes_generic 35880 1 aes_i586
nls_iso8859_1 12032 1
nls_cp437 13696 1
vfat 18816 1
fat 58272 1 vfat
binfmt_misc 16776 1
tun 18820 0
radeon 342816 2
drm 96296 3 radeon
bridge 56340 0
stp 10500 1 bridge
bnep 20224 2
vmnet 47812 14
vmblock 21028 3
vmci 58452 0
vmmon 76912 6
input_polldev 11912 0
lp 17156 0
arc4 9856 2
ecb 10752 2
snd_hda_intel 435636 4
snd_pcm_oss 46336 0
snd_mixer_oss 22656 1 snd_pcm_oss
snd_pcm 82948 3 snd_hda_intel,snd_pcm_oss
snd_seq_dummy 10756 0
snd_seq_oss 37760 0
snd_seq_midi 14336 0
snd_rawmidi 29696 1 snd_seq_midi
iwl3945 97912 0
snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
pcmcia 44748 0
snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
mac80211 217208 1 iwl3945
iTCO_wdt 19108 0
snd_timer 29704 2 snd_pcm,snd_seq
snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
joydev 18368 0
iTCO_vendor_support 11652 1 iTCO_wdt
thinkpad_acpi 66560 0
usbhid 42336 0
led_class 12036 2 iwl3945,thinkpad_acpi
snd 62628 16 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
psmouse 61972 0
btusb 19608 2
video 25360 0
intel_agp 34108 0
agpgart 42696 2 drm,intel_agp
ppdev 15620 0
yenta_socket 32396 1
rsrc_nonstatic 19328 1 yenta_socket
pcmcia_core...

Read more...

jyoungtaylor (jyoungtaylor) wrote :

Update:

High CPU causes the issue. I can reproduce it by opening a long webpage in firefox and scrolling up and down the page fast with a wheel mouse. At this time you can see cpu utilization increasing to 50-80% on each core.

jyoungtaylor (jyoungtaylor) wrote :

Update 2:

Upon further investigation, it seems that the DVI monitor and computer go out of sync and that is what causes the blinking. As a workround I have I found that after reducing the resolution of the DVI monitor the issue has ceased. It is unfortunate since it is now running at 1280x960 whereas it could be running at 1600x1200.

Vitaly (vitalyx) wrote :

Regarding sync. Sorry, the refresh rate for laptop screen is different from the refresh rate for the external monitor and is 67 Hz. Will update the description.

description: updated
tags: added: external flicker monitor
vickoxy (vickoxy) wrote :

Same here: Acer X193HQ 19" monitor (VGA) with dell mini 9 running Ubuntu 9.04. But i noticed that if i disable "Extra visual effects" there is no flickering there. So, it has something to do also with Compiz. Or?

Bryan Zimmerman (codeabit) wrote :

I'm seeing this too. ATI radeon X1900 with two Samsung 1600x1200 monitors. Only happens on one monitor. Flashes randomly. Appears to be related to use, but may not happen for some time and then random flashing starts again. Please let me know if I can provide additional information that will assist with resolving this issue. Thanks.

Victor Trac (victor-trac) wrote :

I think I am also experiencing this. ATI Radeon HD3300 onboard video with DVI using ATI fglrx drivers out to a Dell 2407WFP monitor. It'll be fine for months, and then it'll just start randomly blinking, like it's gone into DPMI sleep and then immediately back on. The inverval seems completely random, from every 15 seconds to 5-10 minutes, and this can last for hours, but generally I get annoyed and reboot to make it go back to normal.

Load or usage doesn't seem to be related in my case. It's happening right now and my load is nearly 0, and I just have a web browser open.

I had this happen on 9.04 as well as 9.10.

ezinar scrooge (draeder) wrote :

I'm experiencing this same issue, except when using SVGA (versus DMI). I have a Dell Inspiron 1501 with the following adapter:

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]

I'm plugged into a Sanyo 42" LCD (Model: DP42849). Both the display settings in Ubuntu and the Refresh rate supplied by the Monitor are 60HZ.

The issue only seems to manifest when running flash based content. I would be happy to provide more details if needed to see this resolved.

Thanks!

ezinar scrooge (draeder) wrote :

Update - I discovered that my HDTV has a Dot Clock slider to adjust the dot timing. I believe this corresponds to the "refresh rate". I moved the slider all the way to the right and found a decrease in blinks. (unfortunately, there are no numeric values on the TV's interface to tell me what it is set to)

ezinar scrooge (draeder) wrote :

Correction - changing the monitor's Dot Clock didn't help at all.

David Tombs (dgtombs) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in xorg.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → xorg (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi Vitaly,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2010-03-18
tags: added: jaunty
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg (Ubuntu):
status: Incomplete → Invalid
bart.snapp (bart-snapp) wrote :

This is still an issue - I am running 10.04.

I've attached the output of lspic -vvnn,

bart.snapp (bart-snapp) wrote :

Here is dmesg

bart.snapp (bart-snapp) wrote :

Here is the Xorg.0.log

David Tombs (dgtombs) wrote :

Reopening since information was provided. Please feel free to reopen yourself in the future.

Changed in xorg (Ubuntu):
status: Invalid → New
Bryce Harrington (bryce) on 2010-07-02
Changed in xorg (Ubuntu):
status: New → Confirmed
thefluxster (buy-ikentech) wrote :

Same problem for me - Ubuntu 10.04, DVI external monitor, Dell E6410.

Bryce Harrington (bryce) wrote :

bart.snapp, well... thanks for providing the information we requested of the original reporter, however it appears you're on Intel graphics whereas the original bug report was about ATI. So I think your findings are completely unrelated.

"randomly" isn't really a suitable description for a bug because it could mean anything. It's not sufficient to pinpoint how your bug happens vs. his.

Changed in xorg (Ubuntu):
status: Confirmed → Won't Fix
Victor Trac (victor-trac) wrote :

For what it's worth, my problem was fixed when I bought a video card (ATI Radeon 5570) to replace the onboard video. I never saw the problem again.

Download full text (75.4 KiB)

I recently upgraded my Dell E196FP 19" LCD Flat Panel SVGA Monitor to a Dell E2009W 20" LCD Flat Panel DVI Monitor and I am experiencing random screen blinking too. I am running Mandriva Linux 2008.1, kernel 2.6.24.7-2mnb with KDE Version 3.5.9 and X.Org X Server 1.4.0.90. My computer system consists of an ASUS P4B533 motherboard with an Award BIOS and an Intel Pentium 4 running at 2.4 GHz, 2 Gigs of DDR Memory, ATI 9200 Graphics Card, Adaptec SCSI Card 29160N, etc. I have my screen resolution set to 1680 x 1050 x 24-bit color.

My xorg.conf file is as follows:

# File generated by XFdrake (rev 234840)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
  #DontZap # disable <Ctrl><Alt><BS> (server abort)
  AllowMouseOpenFail # allows the server to start up even if the mouse does not work
  #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
  Load "dbe" # Double-Buffering Extension
  Load "v4l" # Video for Linux
  Load "extmod"
  Load "type1"
  Load "freetype"
  Load "glx" # 3D layer
  Load "dri" # direct rendering
EndSection

Section "InputDevice"
  Identifier "Keyboard1"
  Driver "kbd"
  Option "XkbModel" "pc105"
  Option "XkbLayout" "us"
  Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
  Identifier "Mouse1"
  Driver "mouse"
  Option "Protocol" "Microsoft"
  Option "Device" "/dev/mouse"
  Option "Emulate3Buttons"
  Option "Emulate3Timeout" "50"
EndSection

Section "Monitor"
  Identifier "monitor1"
  VendorName "Plug'n Play"
  ModelName "DELL E2009W"
  HorizSync 30-83
  VertRefresh 56-75
    # Monitor preferred modeline (60.0 Hz vsync, 65.3 kHz hsync, ratio 16/10)
  ModeLine "1680x1050" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 +hsync -vsync
    # TV fullscreen mode or DVD fullscreen output.
  # 768x576 @ 79 Hz, 50 kHz hsync
  ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630
    # 768x576 @ 100 Hz, 61.6 kHz hsync
  ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
    # modeline generated by gtf(1) [handled by XFdrake]
  ModeLine "1680x1050_120" 313.20 1680 1816 2000 2320 1050 1051 1054 1125 -HSync +Vsync
    # modeline generated by gtf(1) [handled by XFdrake]
  ModeLine "1680x1050_100" 256.20 1680 1808 1992 2304 1050 1051 1054 1112 -HSync +Vsync
    # modeline generated by gtf(1) [handled by XFdrake]
  ModeLine "1680x1050_85" 214.51 1680 1800 1984 2288 1050 1051 1054 1103 -HSync +Vsync
    # modeline generated by gtf(1) [handled by XFdrake]
  ModeLine "1680x1050_75" 188.07 1680 1800 1984 2288 1050 1051 1054 1096 -HSync +Vsync
    # modeline generated by gtf(1) [handled by XFdrake]
  ModeLine "1680x1050_60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync
    # modeline generated by gtf(1) [handled by XFdrake]
  ModeLine "1680x1050_50" 120.21 1680 1776 1952 2224 1050 1051 1054 1081 -HSync +Vsync
    # modeline generated by gtf(1) [handled by XFdrake]
  ModeLine "1600x1000_120" 284.04 1600 1728 1904 2...

David Tombs (dgtombs) wrote :

@David: Mandriva? I suggest reporting the issue to Mandriva, then, not Ubuntu. Thanks.

bart.snapp (bart-snapp) wrote :

Actually this is still an issue with Ubuntu (10.04).

@David Smith -- It seems to help me if I turn my monitor off, leave it off for something like 10 seconds and then turn it back on. I will not have this blinking problem again for maybe 2 months or so.

It is still an issue in 10.10

I only noticed it when I recently switched from VGA to DVI though. My monitor goes off and on randomly, as said by other people it seems to happen when there is some user activity (like scrolling in a webpage).

Please let me know what kind of report is need to provide useful information.

bart.snapp (bart-snapp) wrote :

Yup - I just updated to 10.10, the issue persists. Same with Leonardo, it is just the DVI monitor that has the problem. (As has always been the case)

Okonkole (odaly-poubelle) wrote :

Hello I've the same problem

Ubuntu 10.04 - ASUS VE278Q 27' - Athlon X3 720 - GeForce 9600 GT

It blink, when I have activity (scrolling page), and when the only activity is to listen to music ...

bl8n8r (bl8n8r-gmail) wrote :

I have the same problem running dual monitors. Thought it was my video card because it only did it on one dvi channel, even when I swapped monitors around so sold the video card on ebay as "defective but working". $5 bucks for an 8600GT. Got a new card and it does THE EXACT SAME THING -- WTF!!?

David Tombs (dgtombs) wrote :

Anybody still experiencing the issue should report a separate bug with 'ubuntu-bug display'. Please also try to test that it is the video card and not the monitor. Thanks.

Rinaldo (claudio-rinaldini) wrote :

I have the same issue on Ubuntu 13.04 64bit with a external monitor attached to my Lenovo T400 (with Intel Mobile 4 Series Chipset Integrated Graphics Controller).
I rediced the resolution to 1024x768 without any results.

Colin Williams (lackita) wrote :

FWIW, my problem was just that one of my wires was loose.

Guria (guria) wrote :

I have a very similar behaviour on my i7 PC with two Benq monitors: 23" vga and 24" dvi.
Dvi one can blink several times in a row or not to blink for some long time. Haven't found any consistent pattern about it.
I am running Ubuntu Gnome 15.10 that I have upgraded to 16.04 recently. Problem was from very beginning and continues after upgrade.

Nenad S (nenadstojanoski) wrote :

I am using Ubuntu 16.04LTS and had a similar behavior. I have External Dell monitor and whenever I was visiting sites that has flash, or moving the windows my monitor was flickering like crazy.
Setting the refresh rate to 60Hz made everything fine.

xrandr -s 1920x1080 -r 60.00

The screen blanks after BIOS, flickers a few times, and then plymouth dies, leaving the system in an inconsistent state. You may or may not see the Plymouth boot splash graphics.

Problem: Black screen after resume:-

Typical scenario is "use a laptop docked with lid closed, only the external screen is active, suspend, take the laptop, open it somewhere"... which leads to "no screen active".

To debug this problem, check if gnome-settings-daemons is getting a signal that the display configuration has changed, by running xtrace against it, and look for a RRScreenChangeNotify event when resuming the machine. If that signal is being sent, then it indicates a possible bug in g-s-d. Otherwise, it suggests a bug in either X or (more likely) the kernel which is not causing the signal to be emitted to begin with.

Problem: Lockup When Closing Lid with Intel Graphics

There is a long known issue with the -intel driver where pipe A/B mixups can cause hangs at the point where the lid is closed. The good news is that it is easily quirkable. In general this is most often seen with newer hardware, because older hardware either has already gotten a quirk or doesn't need one.

Kedar Apte (kedar-apte) wrote :

I have a similar issue with my Dell Latitude 7250. I have Ubuntu Gnome 16.04, 64 bit installed on the laptop and connected to a dock. I have 3 Dell 22" monitors connected. One of the monitor is using a VGA connector, and two are using DVI connectors on the monitor.

The issue is - when I start my day the set up works nicely. But when the screens go in the sleep mode and the laptop also goes in suspend, getting the screens working properly is a pain. One of the screens keep flickering. The fix that I have to apply is go to display settings, disable the monitor that is flickering and then re-enable the monitor. The monitor then stops flickering and works well. But then I have to re-arrange the monitor display.

Attaching dmesg and lspci-vvnn outputs.

Regards
Kedar

Kedar Apte (kedar-apte) wrote :

could not attach lspci in the previous comment. attaching now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers