[X1100] flickering after resume from ram

Bug #318325 reported by Id2ndR on 2009-01-18
This bug affects 23 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)

Bug Description

Binary package hint: xserver-xorg-video-radeon

System : Ubuntu 8.10 (up to date)
GPU : ATI express X1100
Video driver : radeon

Steps to reproduce :
- put the computer on standby
- resume from ram
=> the screen will flicker while CPU activity is not high

workaround :
- just launch an infinite loop that consume CPU : $ while true; do echo >/dev/null; done
=> the screen won't flicker while the CPU is use (even if only one core is being used)

There isn't error either in Xorg, xsession logs or in dmesg after resuming.

Notice that this trouble doesn't occured with fglrx driver.

Id2ndR (id2ndr) on 2009-01-18
description: updated
description: updated
Bryce Harrington (bryce) wrote :

Hi fabien-id,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Please attach the output of `lspci -vvnn` too.

[This is an automated message. If this script has reached you erroneously, please accept our apologies; any reply to this message will be sufficient to prevent it from doing further automated processing.]

Changed in xserver-xorg-video-ati:
status: New → Incomplete
Id2ndR (id2ndr) wrote :
Id2ndR (id2ndr) wrote :
Bryce Harrington (bryce) wrote :


Changed in xserver-xorg-video-ati:
importance: Undecided → Medium
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Hmm, next I'd like to forward this issue upstream, but first it must be retested on latest Jaunty to make sure the issue still happens there with the latest code. ISO images are available at http://cdimages.ubuntu.com/releases/jaunty/. If you can reproduce it in the LiveCD environment, you shouldn't need to modify your installed system. Also please attach a fresh Xorg.0.log from this testing.

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete
Id2ndR (id2ndr) wrote :

Confirm with today daily liveCD.

Changed in xserver-xorg-video-ati:
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-02-27
Changed in xserver-xorg-video-ati:
status: Confirmed → Triaged

Created an attachment (id=23555)

Forwarding this bug from a Ubuntu reporter:

After resuming from RAM, the screen flickers when the CPU load drops to a low level.

[Original Report]
System : Ubuntu 8.10 (up to date)
GPU : ATI express X1100
Video driver : radeon

Steps to reproduce :
- put the computer on standby
- resume from ram
=> the screen will flicker while CPU activity is not high

workaround :
- just launch an infinite loop that consume CPU : $ while true; do echo >/dev/null; done
=> the screen won't flicker while the CPU is use (even if only one core is being used)

There isn't error either in Xorg, xsession logs or in dmesg after resuming.

Notice that this trouble doesn't occur with fglrx driver.

00:00.0 0600: 1002:5950 (rev 10)
 Subsystem: 1025:009f
01:05.0 0300: 1002:5975
 Subsystem: 1025:009f

Bryce Harrington (bryce) wrote :

Hi Id2,

I've forwarded your bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=20478 - please subscribe to this bug in case upstream needs more information or wishes you to test something. Thanks ahead of time!

Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2009-05-14
summary: - [x1100] flickering after resume from ram
+ [X1100] flickering after resume from ram
Bryce Harrington (bryce) on 2009-05-15
tags: added: flicker
tags: added: resume
Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid
Id2ndR (id2ndr) wrote :

The bug still exist on karmic (beta) with or without KMS enable (and using PPA of xorg-edgers).

It's not only appears after suspend to ram but also after suspend to disk. This problem is with us for very long. I think this is high time to solve this problem. I suppose that it will be hard to reproduce this problem on other machines so I can assist in tests. I know something about programming and debugging but I have zero knowledge about graphic drivers. I can follow instructions from someone experienced.
This is how screen exactly looks after suspend: http://www.youtube.com/watch?v=xuvfXgcQC94

Chris (bridgeriver) wrote :

This command will suspend imbrium (Acer 5100) correctly with Intrepid 64-bit and open-source ATI video driver. It works fine on Jaunty as well:

pm-suspend --quirk-radeon-off --quirk-vbemode-restore --quirk-vbestate-restore --quirk-vbe-post

The corresponding entries in /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi are:

        <match key="system.hardware.product" contains_outof="1520;1650;5100;5110;5570;5920">
          <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
          <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
          <merge key="power_management.quirk.vbemode_restore" type="bool">true</merge>
          <merge key="power_management.quirk.vbestate_restore" type="bool">true</merge>

I don't think these changes will break anything with the closed-source driver. However, it might be worth considering including driver information in the fdi file, so that different quirks can be applied depending on the driver used for a given set of hardware.

Thomas David (nemphis) wrote :

Can confirm that the solution above works for me. Thank you Chris!

I tested it also with Karmic and it worked so i would suggest to implement this fix quickly before the Karmic release.

Id2ndR (id2ndr) wrote :

Adding the following line in /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi fix the problem in karmic :
<merge key="power_management.quirk.vbestate_restore" type="bool">true</merge>

Piotr Krysik (perper) wrote :

Hi Chris. Your solution works for me also but I have to place it in other <match> tag. It turns out that Acers service had put Aspire 3100 motherboard in my computer. It looks the same as old one, but it identifies itself as Apire 3100:
   $ lshal |grep system.hardware.product
     system.hardware.product = 'Aspire 3100' (string)
I wonder how many products are affected by this bug (for example if Aspire 3100 is affected too)?
Is there a way to find on launchpad people who have ATI express X1100 graphic card and ask them?

Piotr Krysik (perper) wrote :

Those quirks worked well in beta of Ubuntu 9.10 but now this line:
<merge key="power_management.quirk.radeon_off" type="bool">true</merge>
causes that computer hung up (with black screen) during resume from suspend.
So problem is still there (flickering screen after suspend) but now known solution doesn't work any more (at least on my computer).
I don't know what was broken in period between beta and final version.

Id2ndR (id2ndr) wrote :

I can confirm that with final version the computer doesn't wakeup (keyboard is unresponsive) with the same quirks.
I will try with KMS to see if it's better.

Chris (bridgeriver) wrote :

Confirmed that the fixes described above do not fix Karmic (fully updated release version, running from a USB pen drive) on my Aspire 5100. Also found that the AGP mode tweaks from


don't help.

So if you have one of these machines I'd stick with Jaunty for now.

Piotr Krysik (perper) wrote :

Quirks mentioned before in this thread work with older xserver-xorg-video-package.
Newest version which works on my Acer Aspire 5100 with "radeon_off" quirk turned "on" is xserver-xorg-video-ati_6.12.99+git20090825.fc74e119-0ubuntu2_amd64.
You can download working package from:
(for amd64)
(for i386)
and install it with "dpkg -i" command.
If you try this workaround please report if it works for you or not.

If it works for everyone then probably we should look what changes were introduced in next version:
All versions of xserver-xorg-video-package for karmic can be found here:

Id2ndR (id2ndr) wrote :

I can confirm the package of Piotr Krysik's comment works.

Piotr Krysik (perper) wrote :

After one day more of tests I have to report that solution proposed by myself isn't good enough. Sometimes it works, but there were many situations when I had blank screen with unresponsive keyboard.

I am also experiencing this bug in karmic on acer aspire 5100-3583.

Installed: xserver-xorg-video-ati_6.12.99+git20090825.fc74e119-0ubuntu2_amd64 from link above installed with dpkg -i
and changed the section in /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi to:
<match key="system.hardware.product" contains_outof="1520;1650;5100;5110;5570;5920">
  <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
  <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
  <merge key="power_management.quirk.vbemode_restore" type="bool">true</merge>
  <merge key="power_management.quirk.vbestate_restore" type="bool">true</merge>
and then rebooted the computer.

its still hanging on resume from suspend to ram with a black screen on acer aspire 5100-3583. I went back and confirmed with apt-cache policy xserver-xorg-video-ati is the right version and it is.

Id2ndR (id2ndr) wrote :

The package from karmic repository works better that the package. The computer often seems to freeze on resume with the package whereas it always resume flickering but responsive without the package.

In continuation of my post #20 above, I think that my computer is using the radeon, not ati driver.
I'm running karmic with all updates installed. An older version of xserver-xorg-video-radeon might work?

Alright update:
I grabbed xserver-xorg-video-radeon_6.12.0-0ubuntu1_amd64.deb from:
and it works. Not technically a karmic package but who cares?

don.borsto@web.de (don-borsto) wrote :

Maybe this problem will be solved with pm-utils version

Release notes Release Announcement

    * Readd smart-kernel-video support for non-KMS i915 Intel framebuffer drivers.

Chris (bridgeriver) wrote :

One can hope, but since the update says it's for the Intel chipset I wouldn't get my hopes up.

don.borsto@web.de (don-borsto) wrote :

Success, for my FireGL T2 on IBM T41p with Karmic I did the following steps:

1. Install "pm-utils" from https://launchpad.net/ubuntu/lucid/+source/pm-utils/
2. Modify /usr/lib/pm-utils/sleep.d/98smart-kernel-video,
    comment the funtion-call "remove_all_video_quirks" in the section <b>have_kms()</b>

As result this section looks like

    # if we are running with a KMS-enabled video driver, we should not
    # attempt to run any quirks
    grep -q -E '(noveau|drm)fb' /proc/fb || return 1
    # remove_all_video_quirks
    add_parameters --quirk-no-chvt

In /etc/default/acpi-support the following parameters are set:


It's possible that it runs without "pm-utils"

Paul Oranje (por) wrote :

Flickering after resume from ram and also from disk, with
Laptop: Acer Aspire 5100, AMD turion64 x2
System : Ubuntu 9.10 (64 bits)
GPU : ATI express X200M (R300)
Video driver : radeon

k_laci (laszlokaroly) wrote :

I have the same problem with Lucid. Very annoying, nothing happened since Jaunty.

Laptop: Acer Aspire 3103 (AMD Sempron 3400+)
System : Ubuntu 10.4 (64 bits)
GPU: ATI Radeon XPRESS 200M 5975 (PCIE)

Chris (bridgeriver) wrote :

k_laci, if you add the quirks as described in Comment #9 and the changes to /usr/lib/pm-utils/sleep.d/98smart-kernel-video as described in Comment #26 there's a good chance it will cure your problem.

If you try this, please let us know how it went.

k_laci (laszlokaroly) wrote :

I tried several possibilities, but the problem remained. However note that I could not apply the quirks described in #26 since Lucid now has a different version of pm-utils (1.3.0).

Anyway, thanks.

Added new bug #560104 which is certainly a duplicate of the present one, but creating a new bug was the only way I found to upload my system's data gathered by "ubuntu-bug".

So my machine is Acer Aspire 3104 WLMi, ATI Technologies Inc RS482 [Radeon Xpress 200M]

Suffering from this bug since fglrx doesn't manage this "old" board anymore and had to switch to ati_drv.

More info in my bug #560104 .

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Id2ndR,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:


If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 318325

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 318325 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:


Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june
Jay (killersiafu) wrote :

I'm seeing this behavior on my Acer Aspire 5100 (Radeon Xpress 1100) running Lucid. On initial login the display is fine... after resuming from sleep the screen flickers so badly it's not usable.

Jay (killersiafu) wrote :

... added related bug 576181 for Lucid with the Acer Aspire 5100

Bryce Harrington (bryce) on 2010-05-06
tags: removed: needs-xorglog
tags: removed: needs-lspci-vvnn
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Id2ndR (id2ndr) wrote :

I can confirm that it's still an issue in Lucid, and that running following command an resume still is a "warkaround":
$ while true ; do echo "toto" > /dev/null ; done

Jay (killersiafu) wrote :

I can also confirm that this "workaround" that Id2ndR posted does work in Lucid. What I did, until this bug is fixed, is created a bash script that runs on startup that executes that command. It's a horrible waste of CPU cycles... but hey, the screen isn't flickering.

The bash script, called stop-flicker.sh, looks like:

while true ; do echo "toto" > /dev/null ; done

I then gave the script execute privileges:

sudo chmod +x stop-flicker.sh

And finally I added a custom startup application, System -> Preferences -> Startup Applications -> Add

I called this application Stop Flicker and gave it the command /home/$user/stop-flicker.sh

Where $user is your user name...

This is hacky... but it works. Please fix this bug soon!

Ulf Mehlig (umehlig) wrote :

I've observed quite the same behaviour as reported here on a Lenovo Thinkpad R60 (Radeon Mobility X1400). If additional data (lspci, Xorg.0.log, ...) would help fixing this bug, let me know.

Id2ndR (id2ndr) wrote :

Adding one or the other or both of following lines :
<merge key="power_management.quirk.vbemode_restore" type="bool">true</merge>
<merge key="power_management.quirk.vbestate_restore" type="bool">true</merge>

in section <match key="system.hardware.product" contains_outof="1520;1650;5100;5110;5570;5920">
of file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi
doesn't work anymore on lucid.

Chris (bridgeriver) wrote :

I think what's happening is that Karmic and Lucid have implemented new (but different) sets of scripts which control whether and how the quirks are applied. In Karmic it was possible to prevent the quirks from being disabled by editing /usr/lib/pm-utils/sleep.d/98smart-kernel-video to comment out the call to remove_all_video_quirks. That hack got suspend/resume working for me on at least one machine (including a Dell laptop with NVIDIA graphics).

In Lucid the scripts have been changed again in an attempt to make them more intelligent so the video suspend/resume will work on more hardware. But it continues to fail on the ATI X1100. If you study the scripts you should be able to figure out how the hack them to allow the quirks to run, and there's a good chance that will cure the problem. But I haven't tested it.

I frankly don't understand why this kind of problem has been allowed to persist for so long. It seems to me that if the user manually enables quirks by creating or editing the .fdi file then the script should not thwart his efforts by disabling the quirks. But the devs seem to disagree.

Bryce Harrington (bryce) on 2010-05-21
tags: added: hardy
Chris (bridgeriver) wrote :

For Lucid, the script /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler accepts a new pseudo-quirk called --quirk-test which appears to prevent the script from disabling other quirks. Without --quirk-test it looks like whatever other quirks you pass to pm-suspend will be ignored on one of these machines.

So it might be worth testing the following:

Get root and run the command

pm-suspend --quirk-test --quirk-vbe-post --quirk-vbemode-restore --quirk-vbestate-restore

That might possibly get the fix working in Lucid. I'm not confident, though, because this approach failed on a Dell D830 laptop with NVIDIA graphics which had become able to suspend/resume successfully in Karmic after adding a different set of quirks and hacking the script that had been disabling them).

Piotr Krysik (perper) wrote :

I've checked the command from Chris on Ubuntu 10.04 and Acer Aspire 5100. After wake up the computer is responsible (for example I can reboot it cleanly from virtual console with ctrl+alt+delete) but there's nothing on the computer's screen (it's black). So the command doesn't work.
I think it would be helpflul to find out why the hack with bash script make the screen stop flickering.

Chris (bridgeriver) wrote :

Piotr, I'm sorry to hear it didn't work. But it does seem to do *something*, which suggests that there is at least a chance that some combination of quirks including --quirk-test will solve the problem.

Here is a list of possible video quirk handler options. I found the original solution (for Jaunty only, unfortunately) by trial and error with this list.


Id2ndR (id2ndr) wrote :

I can add more details :

I confirm that in Karmic with the package xserver-xorg-video-radeon version 1:6.12.0-0ubuntu1 instead of the default package version, the suspend/resume cycle works fine using the following command:
$ sudo pm-suspend --quirk-vbestate-restore
The option --quirk-vbestate-restore is the only one which is important. Other options can be added but this is useless because it works the same way.

I tried many combinaison of options with the version 1:6.12.0 of the package on Lucid (using --force-all option to install it) but it doesn't fix the suspend/resume cycle.

Xirev (xsguo) wrote :

I have this bug as well in Lucid with ATI Xpress 200M. The display has constant flickering (50% of the time, not always) when I resume from hibernate, but very rarely from sleep (suspend to RAM). Did not have in Jaunty. I suspect a regression in the newer version of xserver-xorg-video-ati.

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Chris (bridgeriver) wrote :

Just checked again on my Aspire 5100 (same machine referenced in comments above) a fully updated Lucid x86. Machine booted and ran cleanly, but after resume from suspend-to-ram the screen flickered very badly, to the point that it was hard to reboot it using the dialog.

I've come back to this bug because Jaunty, which suspends and resumes perfectly after the tweak described in one of my earlier posts above, just reached end-of-life. What to do, what to do...?

Id2ndR (id2ndr) wrote :

I don't have the answer but maybe you can repport the result on Maverick using xorg edgers' PPA (which provide the latest drivers and X stack).

Chris (bridgeriver) wrote :

I can't easily test the xorg PPA version on this machine since its USB subsystem is blown. I did download the Maverik RC and try it from the CD. It has the bug, unfortunately.

Maybe one of the other posters can install the RC to a thumb drive and test the PPA xorg?

Has there been any effort to fix this in the PPA version?

Piotr Krysik (perper) wrote :

I've tested edgers xorg drivers. The result is the same (my subjective feeling is that the screen flickers even more). With Jaunty support expiring I guess our options are on decline. I've tested Fedora and the result is exactly the same. It appears that the bug arose in the heart of the xorg driver. I don't have any experience with xorg drivers (or any other drivers) hacking but if someone has some clue where the problem might lie I might check it. This is over two years since this bug, which is very serious for my user experience, emerged and it's getting pretty frustrating. So if someone has any idea where to look in the driver's code for this bug - I'm ready to verify it.

Chris (bridgeriver) wrote :

Yes, I am frustrated by this also, and I think this chipset is a pretty common one so it's probable that a lot of users are seeing this issue. Most probably just shrug and give up on suspend, or possibly on Linux.

New install of Maverick UNE to a new (to me) Acer Aspire 5100-3949. Ran into this bug, and going through the workarounds. So far the only workaround that "works" is the one in Bug #576181 (keep the processor busy with a bash script). Yuck. Especially if you're on battery.

Just tried the Ubuntu-X PPA at https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
No improvement.

Will next try the Xorg Crack PPA https://launchpad.net/~xorg-edgers
I will report back IF it fixes this.

P.S.: I installed UNE, and Unity doesn't work at all on this beast, so I'm logging in using GNOME. In Unity the desktop is blank, and the widgets flash blank rectangles when I mouse over but they are unreadable. I found the power widget in the top-right corner so I could make the menu come up to get it logged out. Related problem? When I get a chance I will file a Unity bug.

Tried the xorg-edgers PPA and it did not apparently affect this bug; the screen still flickers after suspend.

HOWEVER as a side note, Unity works with the newer xorg.

I noticed upstream http://bugs.freedesktop.org/show_bug.cgi?id=20478 asked whether it's a problem with a newer version of the driver or with KMS so I am trying to learn how to figure this out. I believe the xorg-edgers PPA tested the newer version but until now I wasn't aware of KMS at all.

I haven't experienced KMS issuex yet on my other hardware. SO I read http://www.netsplit.com/2010/03/30/all-about-kernel-mode-setting/ for an overview and https://wiki.ubuntu.com/X/KernelModeSetting for how to try different modes.

I hope nobody minds me making my notes in this bug. If anyone can suggest the most efficient way to test this please let me know.

P.S.: The Acer 5100 original install was a 10.04 Lucid UNE image, then upgraded online to 10.10 Maverick UNE. I believe the laptop's boot volume may be encrypted (it displays a message on boot), though I didn't intentionally choose the encrypted option. The ubuntu wiki mentions kernel mode changes need to get into initramfs for encrypted volumes, so I might reinstall Maverick from scratch to avoid that complication. Just in case.

On this Acer Aspire 5100 I just tried the following:

  -- disabled KMS using # echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf
          but disabling KMS had no noticeable effect on flicker.

  -- tried vesa driver by creating an xorg.conf
         The vesa driver came up in low resolution, AND the machine flickered after suspend.

  -- tried fbdev driver by creating an xorg.conf
         The fbdev driver didn't work with X at all; X wouldn't start.

All of the above was tested using the stock Maverick 10.10 xorg, NOT the newer PPAs. When I get a chance I may try the Xorg Crack PPA.

I consider suspend and resume essential on a laptop, so I am open to suggestions for other things I might try.

P.S.: I believe this particular laptop only contains the stock 1Gb RAM.

activated the xorg-edgers PPA, and found that with KMS disabled, xorg segfaults and will not operate at all, and I could not even use any console terminals. Fortunately I had installed sshd so I could ssh in via the network and remove /etc/modprobe.d/radeon-kms.conf

Confirming. On Acer Aspire 3104 WLMi, xorg-edgers gives no improvement on this bug (alas !) and disabling KMS causes X to segfault immediately. (However I could acces my system's VTs)

I can also reproduce the flickering after resume from RAM on my Acer TravelMate 4002 laptop under Kubuntu 10.10. On my hardware configuration, the flickering is not dependent on CPU load, the infinite loop mentioned in the original post doesn't solve the problem for me.

Laptop: Acer TravelMate 4002 LMi
Graphics card : ATI Mobility Radeon 9700 (r300)
System : Ubuntu 10.10 (maverick)
Video driver : radeon

If you need more info, just let me know.

Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Bryce Harrington (bryce) wrote :

Upstream would like to know if anyone has reproduced this bug on natty (kernel 2.6.38) as they suspect it may be fixed now.

Please give it a try and report your findings back to the upstream bug report (http://bugs.freedesktop.org/show_bug.cgi?id=20478)

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete

Bug still present in Natty. Looks to be "a slight bit less of flickering", but still there is :-(

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Simon Butcher (sbutcher) wrote :

Confirm that still in Natty (actually have a X1250 but the same issue). Is there any relation to bug #20283 ? A fix is long overdue since the proprietary driver doesn't work

Marco_Case (casemarco) wrote :

For anyone interested, I have found a solution for my Acer Aspire 5100 in UBUNTU 11.04 (64bit version)
The flashing screen is caused by the kernel modesetting feature (KMS) that doesn't work good on the ATI radeon xpress 1100 graphic chip, so I disabled this feature by editing the file "/etc/default/grub" and changing the line: GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash” to: GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash nomodeset”. Then I ran: sudo update-grub. Don't know if this is working for ubuntu versions below 11.04.

For the googlers around here's the sequence:

1) open the terminal and type: gksudo gedit/etc/default/grub
2) find a line that says: GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”
3) modify that line this way: GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash nomodeset”
4) save, go back to terminal and type: sudo update-grub
5) reboot your laptop, then try to suspend it and resume, it should work.

Hope this helps someone.

Chris (bridgeriver) wrote :

Hi Marco,

I tried your suggestion (adding nomodeset to the commandline) with Debian Squeeze, but it didn't cure the flicker on resume.

Also tried it with an Onieric LiveCD, but it didn't solve it there either.

Bad news...

Chris (bridgeriver) wrote :

NB: With Debian Squeeze, I was able to cure this flicker on my Aspire 5100 by doing the following (as root):

pm-suspend --quirk-s3-bios --quirk-s3-mode --quirk-vbe-post --quirk-vbemode-restore --quirk-vbestate-restore --quirk-test --store-quirks-as-lkw

The parameters up to --quirk-test cause the machine to suspend. When I tap a keyboard key it comes back to the deskop without the flickering.

The --store-quirks-as-lkw parameter seems to cause the previous parameters to be written to a database where they are found and used again on the next suspend attempt. So now my machine suspends and resumes normally (the above commandline was needed only once).

Note that you can use the pm-suspend command to experiment with quirks. The --quirk-test parameter was needed to make sure the pm scripts didn't ignore the other parameters during testing.

For testing quirks, I found it useful to edit the power-management settings to make the machine hibernate when I pushed the power button. That made it possible to recover when the screen flickered too badly to use the normal shutdown dialog. When the machine resumed from hibernation, the flicker was gone and Iwas ready to test another combination of suspend quirks.

Note that I have done a couple of other thngs which I don't think matter (they didn't cure the problem by themselves). These are adding the nomodeset parameter to the linux commandline, and adding some of the same quirks to the file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi.

The current Debian Squeeze appears to be pretty similar to Ubuntu Lucid. It's running Linux 2.6.32-5-686 (but with an October 2011 compile date). I'm not sure how the two systems differ in their power management, but I bet they're pretty close. I do not know if the tweaks I describe here would work for Natty or Onieric.

I hope this helps somebody.

Attila Szász (tilusnet) wrote :

Marco your suggestion worked for me, I am really grateful for it.
I have always had this problem since Ubuntu 10.10.

I am using Ubuntu 12.04 64-bit / AMD Turion 64 x2 / ATI Radeon Xpress 1150.

madbiologist (me-again) on 2012-09-28
tags: added: lucid maverick natty precise
removed: needs-retested-on-lucid-by-june
Seb (zapp-deactivatedaccount) wrote :

This Bug is still present on Quantal.
I have a Radeon Xpress 1250.

tags: added: quantal
eris23 (jdkatz23) wrote :

Problem still exists on a fresh install of Xubuntu Trusty on a Acer 5100.

eris23 (jdkatz23) wrote :

Also confirmed that "nomodeset" solution doesn't work.

micsu (micsu-z) wrote :

I have the same problem with xUbuntu 14.04 (Trusty Tahr)
I guess it will never be fixed, so we have to install windows xp instead :(

Laptop: Acer Aspire 3104 (AMD Sempron 3500+)
GPU: ATI Radeon Xpress 1100
System : xUbuntu 14.04 32 bit (Trusty Tahr)

There is one workaround, but it requires nomodeset (and the quirks suggested by Chris at #65).
Using nomodeset is not a good idea, since it prevents all graphics accelerations.

no longer affects: xserver-xorg-video-ati (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed

Id2ndR, Lucid Desktop reached EOL as of May 9, 2013. For more on this, please see https://wiki.ubuntu.com/Releases.

Is this reproducible on a supported release?

If not, please mark the Status Invalid.

If so, could you please run the following command once from a terminal by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information:
apport-collect -p xorg 318325

affects: xserver-xorg-video-ati (Fedora) → xserver-xorg-video-ati (Ubuntu)
no longer affects: xserver-xorg-video-ati (Ubuntu)
affects: xserver-xorg-driver-ati → xorg (Ubuntu)
Changed in xorg (Ubuntu):
importance: Medium → Undecided
status: Confirmed → New
importance: Undecided → Low
status: New → Incomplete
tags: removed: flicker maverick natty precise quantal

I can confirm the bug still exists in Trusty, and I just tried a Wily live image and it exists there, too. The affected hardware is getting a bit old but still seems to work fine with Ubuntu in all other ways.

As I am not Id2ndR should I run apport-collect on a new bug and mark it as a duplicate of this one?

Tommy Trussell, it will help immensely if you filed a new report with Ubuntu by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

I have the same hardware as reported in Bug #1333697

Daniel van Vugt (vanvugt) wrote :

This bug is too old to work with and the related Ubuntu versions are past end of life.

Tommy: If you or others experience problems then please log new bugs.

Changed in xorg (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.