mouse and keyboard unresponsive when gdm first runs

Bug #271138 reported by Martin Pool on 2008-09-17
80
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Medium
Unassigned
Intrepid
Medium
Unassigned
xorg (Ubuntu)
High
Bryce Harrington
Intrepid
High
Bryce Harrington

Bug Description

Binary package hint: gdm

After a recent upgrade to Intrepid, neither the mouse or keyboard respond at the gdm login screen. ctrl-alt-backspace does not work. However, I can switch to vt1, and from there kill gdm. I can then either start gdm again, after which it does work normally, or run startx and that also works. Both the mouse and keyboard are usb and directly attached to the computer.

This might be similar to bug 240456? It might also be an X bug rather than gdm.

Related branches

Martin Pool (mbp) wrote :
Martin Pool (mbp) wrote :
Martin Pool (mbp) wrote :

There are no gdm messages in /var/log/messages

Sebastien Bacher (seb128) wrote :

thank you for your bug report. could you try to attach gdb to gdm or strace it when it's hanging and attach those informations to the bug? could you try xdm and see if has the same issue?

Changed in gdm:
importance: Undecided → Low
status: New → Incomplete

I also found that if I kill just the X server process gdm will restart
it and then it's ok.

--
Martin <http://launchpad.net/~mbp/>

Martin Pool (mbp) wrote :

Two bits of further information:

I saw the text I typed into the login screen was briefly visible on a text virtual console that popped up when I killed gdm. It wasn't a vc with a getty running on it.

Also, if I configure gdm to auto-login then my gnome session does start up correctly, but again the keyboard is unresponsive the first time it starts after booting.

OK, the gdm processes are like this:

  1 Reading symbols from /lib/tls/i686/cmov/libpthread.so.0...(no debugging symbols
  2 found)...done.
  3 [Thread debugging using libthread_db enabled]
  4 [New Thread 0xb733c910 (LWP 7577)]
  5 Loaded symbols for /lib/tls/i686/cmov/libpthread.so.0
  6 Reading symbols from /lib/tls/i686/cmov/libnss_compat.so.2...
  7 (no debugging symbols found)...done.
  8 Loaded symbols for /lib/tls/i686/cmov/libnss_compat.so.2
  9 Reading symbols from /lib/tls/i686/cmov/libnss_nis.so.2...(no debugging symbols
 10 found)...done.
 11 Loaded symbols for /lib/tls/i686/cmov/libnss_nis.so.2
 12 Reading symbols from /lib/tls/i686/cmov/libnss_files.so.2...
 13 (no debugging symbols found)...done.
 14 Loaded symbols for /lib/tls/i686/cmov/libnss_files.so.2
 15 (no debugging symbols found)
 16 0xb7f24430 in __kernel_vsyscall ()
 17 (gdb) bt
 18 #0 0xb7f24430 in __kernel_vsyscall ()
 19 #1 0xb74c7dab in poll () from /lib/tls/i686/cmov/libc.so.6
 20 #2 0xb758fc32 in ?? () from /usr/lib/libglib-2.0.so.0
 21 #3 0xb75902c2 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
 22 #4 0x08052d75 in ?? ()
 23 #5 0xb7407685 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
 24 #6 0x0804fe71 in ?? ()
 25 (gdb)

Reading symbols from /usr/lib/libck-connector.so.0...
(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libck-connector.so.0
(no debugging symbols found)
0xb7f24430 in __kernel_vsyscall ()
(gdb) bt
#0 0xb7f24430 in __kernel_vsyscall ()
#1 0xb74c2183 in read () from /lib/tls/i686/cmov/libc.so.6
#2 0x080718a6 in ?? ()
#3 0x08062558 in ?? ()
#4 0x080792da in ?? ()
#5 0xb7f0578a in pam_get_user () from /lib/libpam.so.0
#6 0xb7f0d87a in ?? () from /lib/security/pam_nologin.so
#7 0xb7f0dacf in pam_sm_authenticate () from /lib/security/pam_nologin.so
#8 0xb7f023c1 in ?? () from /lib/libpam.so.0
#9 0xb7f01bdd in pam_authenticate () from /lib/libpam.so.0
#10 0x0807959b in ?? ()
#11 0x08065a5b in ?? ()
#12 0x0806c159 in ?? ()
#13 0x0805d658 in ?? ()
#14 0x080521fd in ?? ()
#15 0x08052d27 in ?? ()
#16 0xb7407685 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#17 0x0804fe71 in ?? ()
(gdb)

Martin Pool (mbp) wrote :

I see there's some code in /etc/init.d/gdm to do with killing usplash and switching terminals, and I wonder if that is related to the problem. It would account for why it's only occurring at initial startup.

Changed in gdm:
status: Incomplete → Confirmed
Martin Pool (mbp) wrote :

Booting up with the 'splash' parameter removed, so that usplash does not run, does not fix the problem.

Removing the rc2.d file so gdm does not start at bootup, and then starting it from a text console after the machine comes up does fix it.

If I change the script to just run X directly rather than through gdm then the problem still occurs, so I'm guessing this is actually an X problem.

Martin Pool (mbp) wrote :

Changing VTAllocation from true to false in gdm.conf has no effect.

Sebastien Bacher (seb128) wrote :

confirming the issue, that started to happen recently on my intrepid installation too, gdm didn't change a lot this cycle could rather be an xorg bug

Changed in gdm:
importance: Undecided → Medium
status: New → Confirmed
Joshua Blount (jblount) wrote :
Joshua Blount (jblount) wrote :
Joshua Blount (jblount) wrote :
sirkubador (sirkubador) wrote :

I have exactly the same problem.

numlockx turned on in /etc/gdm/Init/Default does not have any effect.

Restarting Xorg, gdm, reconfiguring xserver-xorg, gdm did not work for me.

Joshua Blount (jblount) wrote :

I attempted to restart X, attempted to remove xorg.conf and restart X, killed GDM and restarted it all with the same result (no working inputs)

Ambricka (petter-ambricka) wrote :

I have the same problem since todays updates which involved xinput and some gdm stuff.

sirkubador (sirkubador) wrote :

It definitely seems like X problem. I booted by killing X and startx so I got into GNOME desktop, but mouse and keyboard did not work anyway.

Ambricka (petter-ambricka) wrote :

I manually installed xserver-xorg-input and gnome, then it all started working again.
Will probably work for others too.

sirkubador (sirkubador) wrote :

sudo apt-get install xserver-xorg-input-all

worked for me. Thanks

Pablo Angulo (pablo-angulo) wrote :

Importance is only medium??!?

It's impossible to work without mouse and keyboard.
And restarting x server does not work in my machine either.

Pablo Angulo (pablo-angulo) wrote :

Manually reinstalled xserver-xorg-input and gnome, and booted several times without success. However, it eventually recovered and is now working normally.

Martin Pool (mbp) wrote :

> Importance is only medium??!?

Yes, I think it's pretty severe for people who hit it.

Sebastien Bacher (seb128) wrote :

bug #276857 is a similar issue and has some possible explanations

Changed in xorg:
assignee: nobody → bryce
importance: Low → High
assignee: bryce → bryceharrington
milestone: none → ubuntu-8.10
Martin Pitt (pitti) wrote :

First I marked both as duplicates now, since they clearly describe the same effect, but on second look that might not actually be true (see below).

It would be interesting to compare /var/log/Xorg.0.log from a gdm which has no input devices and the followup gdm where things work. Can folks who experience this please attach both versions?

Some interesting things: In Ted's log in bug 276857 (http://launchpadlibrarian.net/18137667/Xorg.0.log.nohal) hal does not seem to have started up fully:

  EE) config/hal: couldn't initialise context: (null) ((null))

and there is no attempt at all to load evdev.

In Joshua's log (http://launchpadlibrarian.net/18409850/Xorg.0.log), hal *does* seem to work, but evdev fails to load:

  (II) config/hal: Adding input device Macintosh mouse button emulation
(II) LoadModule: "evdev"

(WW) Warning, couldn't open module evdev
(II) UnloadModule: "evdev"
(EE) Failed to load module "evdev" (module does not exist, 0)

Joshua, when you restart X, do you still get messages like this? Do you have xserver-xorg-input-evdev installed, and /usr/lib/xorg/modules/input/evdev_drv.so exists?

Martin Pitt (pitti) wrote :

Can people here please use an augmented /etc/init.d/gdm from https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/276857/comments/8 and attach /tmp/gdm-hal-log.txt in both cases? Thanks!

Timo Aaltonen (tjaalton) wrote :

xserver-xorg should depend on xserver-xorg-input-evdev so that it gets installed on upgrades.

Bryce Harrington (bryce) wrote :

Committed to git change to make xserver-xorg package depend directly on -evdev.

Changed in xorg:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Bryce, thanks. Please upload, so that it is readily available in the queue right after the RC is released.

Andrew Betts (andrew-betts) wrote :

I had this problem also. No keyboard or mouse when gdm starts.

I managed to eventually get the keyboard to work by putting:
Section "InputDevice"
Identifier "blah"
Driver "kbd"
Option "CoreKeyboard"
EndSection

(or something like that) in xorg.conf but I never managed to get the mouse to work. Hence reinstalled 8.04.

My keyboard and mouse are both PS2

In the queue:

  718899 | S- | xorg | 1:7.4~5ubuntu3 | 28 minutes
  | * xorg/1:7.4~5ubuntu3 Component: main Section: x11
  718896 | S- | xorg-server | 2:1.5.2-2ubuntu2 | 33 minutes
  | * xorg-server/2:1.5.2-2ubuntu2 Component: main Section: x11

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg - 1:7.4~5ubuntu3

---------------
xorg (1:7.4~5ubuntu3) intrepid; urgency=low

  * debian/control:
    - Depend on -evdev so it will get installed on upgrades.
      Otherwise, in certain upgrade scenarios this can result in
      non-functioning keyboard/mouse.
      (LP: #271138)
    - Remove displayconfig-gtk from Suggests since it is no longer present
      in the archive anyway

 -- Bryce Harrington <email address hidden> Tue, 21 Oct 2008 16:16:10 -0700

Changed in xorg:
status: Fix Committed → Fix Released
Martin Pool (mbp) wrote :

I installed xorg 1:7.4~5ubuntu3 (and everything else from Intrepid's updates this morning), and the problem persists.

Changed in xorg:
status: Fix Released → Confirmed
Keith Drummond (victor9098) wrote :

I have just installed the Intrepid Ibex RC and I no longer have the problem, maybe it is just a beta issue? My system is up to date at the time of writing this.

Steve Langasek (vorlon) wrote :

Looking at the original Xorg.log posted by Martin, it appears that his bug is /not/ caused by the absence of the evdev driver.

So I suppose this is going to require more investigation, which unfortunately we're now pretty much out of time for for 8.10. Moving the milestone to intrepid-updates.

Changed in xorg:
milestone: ubuntu-8.10 → intrepid-updates
Ovidiu Rosoiu (ovidiu.rosoiu) wrote :

I can confirm this behavior after an upgrade from Kubuntu 8.04 to 8.10. kdm.log said "(EE) config/hal: couldn't initialise context: (null) ((null))" which lead me to the conclusion that kdm started before hal. Indeed, in /etc/rc2.d, scripts are S20kdm and S24hal.
So i moved S20kdm to S25kdm, and everything is fine now, keyboard and mouse working as intended when kdm starts. I suppose the problem with gdm in Intrepid is similar.

Martin Pool (mbp) wrote :

Moving gdm to run at priority 40 fixes this. Well done Ovidiu!

Ovidiu Rosoiu (ovidiu.rosoiu) wrote :

Actually now my startup config is:

/etc/rc0.d/K01kdm
/etc/rc1.d/K01kdm
/etc/rc2.d/S99kdm
/etc/rc3.d/S99kdm
/etc/rc4.d/S99kdm
/etc/rc5.d/S99kdm
/etc/rc6.d/K01kdm

which I had to set mannualy, because an `update-rc.d kdm defaults` would set kdm start scripts at priority 20, lower than hal. Setting the priority manually fixes the problem.

Martin Pool (mbp) wrote :

On Fri, Oct 31, 2008 at 11:46 PM, Ovidiu Rosoiu
<email address hidden> wrote:
> Actually now my startup config is:
>
> /etc/rc0.d/K01kdm
> /etc/rc1.d/K01kdm
> /etc/rc2.d/S99kdm
> /etc/rc3.d/S99kdm
> /etc/rc4.d/S99kdm
> /etc/rc5.d/S99kdm
> /etc/rc6.d/K01kdm
>
> which I had to set mannualy, because an `update-rc.d kdm defaults` would
> set kdm start scripts at priority 20, lower than hal. Setting the
> priority manually fixes the problem.

I did something similar, also by hand. Strictly speaking I think the
K links should also be at 99, because they're run in reverse order.
But precise shutdown order is a bit moot.

--
Martin <http://launchpad.net/~mbp/>

Frank Schmidt (f-schmidt) wrote :

Moving gdm to priority 25 (instead of 40) solved to problem for me.

Bryce Harrington (bryce) wrote :

Sounds like the original issue (and many of the issues by subsequent commenters) are fixed by the gdm priority change, so closing out the xorg task - if I'm wrong please feel free to reopen the task with an explanation.

Changed in xorg:
status: Confirmed → Fix Released
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2008-11-04
Changed in gdm:
milestone: none → intrepid-updates
Bryce Harrington (bryce) wrote :

Btw, I've also added a depends on hal to xserver-xorg, which should also help reduce occurrences of this. (lool found a situation where in kvm xorg can be launched without hal having been installed, leading to a similar issue as this.)

Sebastien Bacher (seb128) wrote :

The intrepid version will not change now

Changed in gdm (Ubuntu Intrepid):
status: Confirmed → Won't Fix
Sebastien Bacher (seb128) wrote :

Or rather assume that the issue was only xorg since nobody got the issue since it has been fixed there

Changed in gdm (Ubuntu Intrepid):
status: Won't Fix → Fix Released
Changed in gdm (Ubuntu):
status: Confirmed → Fix Released

I have not seen this on either of my machines for months, so it
probably has been fixed.

--
Martin <http://launchpad.net/~mbp/>

Peter Belew (peterbe) wrote :

I have not, either, so I assume it is no longer a bug.

On Fri, Jul 24, 2009 at 1:52 PM, Martin Pool<email address hidden> wrote:
> I have not seen this on either of my machines for months, so it
> probably has been fixed.
>
>
> --
> Martin <http://launchpad.net/~mbp/>
>
> --
> mouse and keyboard unresponsive when gdm first runs
> https://bugs.launchpad.net/bugs/271138
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers