xorg fails to correctly detect Satellite pro 4600 and 6000 screen resolution

Bug #239722 reported by Nick_Hill on 2008-06-13
42
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-trident (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

On previous versions of Ubuntu, dpkg-reconfigure allowed me to specify monitor resolution etc. With hardy, this feature appears to have been removed. I believe that will encourage better detection code, and more usable front ends for less technical users. Nevertheless, I am right now left with 800x600 on my Toshiba Satellite Pro 4600, which has a native resolution of 1024x768 with only option to manually edit xorg.conf.

Steps to show bug:
Install a fresh copy of Ubuntu Hardy 8.04 on a Toshiba Satellite pro laptop.
Observe the GUI gives maximum resolution of 800x600.

Expected:
Resolution should include 1024x768 native screen resolution. This resolution has shown to work where screen resolution set manually.

lspci >error_report ; cat /var/log/Xorg.0.log >> error_report
[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub [8086:1130] (rev 11)
     Subsystem: Toshiba America Info Systems Device [1179:0001]
01:00.0 VGA compatible controller [0300]: Trident Microsystems CyberBlade/XP [1023:9910] (rev 63)
     Subsystem: Toshiba America Info Systems Device [1179:0001]

This bug is also apparent on SP 6000. lspci -vvnn snippet from SP6000:
01:00.0 VGA compatible controller [0300]: Trident Microsystems CyberBlade XPAi1 [1023:8820] (rev 82)
 Subsystem: Toshiba America Info Systems Device [1179:0001]
See massage from 17 Jan 09 for full details

Nick_Hill (nick-nickhill) wrote :
Dereck Wonnacott (dereck) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you include the following information please? Then set the bug status to 'new' to signify that it is ready for triage / review.

Resolution, rate, or other parameter expected
Resolutions, rates, or other parameters actually obtained

output of sudo ddcprobe
output of xrandr

Changed in xorg:
status: New → Incomplete

I'm having the same problem with the Toshiba Satellite Pro 4600 I got yesterday. Hope the xrandr and ddcprobe outputs help you figure out the problem. In the meantime I'll fix this manually from xorg.conf and report the necessary configuration steps here.

HorizSync and VertRefresh values taken from http://tuxmobil.org/XF86Config_4_sp4600.html seem to work just fine. So, to work around this problem on Hardy do the following... First check if you have /etc/X11/xorg.conf. If you don't, do a

sudo dpkg-reconfigure xserver-xorg

This will create the /etc/X11/xorg.conf. You will be asked some questions about framebuffer and keyboard layout. Next open the xorg.conf:

nano /etc/X11/xorg.conf.

Add HorizSync and VertRefresh settings to the end of the "Monitor" section:

Section "Monitor"
   Identifier "Configured Monitor"
   HorizSync 31-60
   VertRefresh 50-75
EndSection

If that's not enough, edit the "Screen" section also:

Section "Screen"
  Identifier "Default Screen"
  Monitor "Configured Monitor"
  Device "Configured Video Driver"
  Subsection "Display"
     Modes "1024x768"
  EndSubsection
EndSection

That should do it. Just restart gdm with /etc/init.d/gdm and you're done.

Nick_Hill (nick-nickhill) wrote :

Samuli, thank you for filing the additional information. I missed the request for additional info.

Changed in xorg:
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hi nick-nickhill,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in xorg:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg:
status: Incomplete → Invalid
Nick_Hill (nick-nickhill) wrote :

Using Jaunty 18 December build, same effect. 800x600 max resolution. lspci -vvnn attached

Changed in xorg:
status: Invalid → Confirmed
Nick_Hill (nick-nickhill) wrote :

I notice this has been moved to xorg-video-trident.

I am not certain that this bug belongs to trident, as it appears to be a detection problem rather than a driver problem.

It is possible to make the 4600 work at 1024x768 by modifying xorg.conf.

Bryce Harrington (bryce) on 2009-01-17
description: updated
Nick_Hill (nick-nickhill) wrote :

I notice the same bug is apparent with the Toshiba Satellite pro 6000 with the latest Alpha 3 version of 9.04. Native resolution is 1024x768 but the default resolution is 800x600 maximum resolution via the GUI is 800x600. I will probably need to alter xorg.conf like I have had to on the Tosh SatPro 4600 to get full resolution.

I have included outputs for ddcprobe, dmidecode, lspci -vvnn, Xorg.0.log in the attached .tgz file for the Toshiba Satellite Pro 6000 running Alpha-3 9.04.

description: updated
kimharding (harding-k) wrote :

This problem still exists I have been unable to change the screen resolution, even following the instructions above. It is this sort of thing that stops Linux moving into the main stream.

Unfortunately still not fixed in jaunty ...
I'm using the xorg.conf from a previous Sidux install.
I've attached both the original xorg file and the Sidux xorg file - which works as expected.

--- On Fri, 4/24/09, kimharding <email address hidden> wrote:

From: kimharding <email address hidden>
Subject: [Bug 239722] Re: xorg fails to correctly detect Satellite pro 4600 and 6000 screen resolution
To: <email address hidden>
Date: Friday, April 24, 2009, 11:53 PM

This problem still exists I have been unable to change the screen
resolution, even following the instructions above. It is this sort of
thing that stops Linux moving into the main stream.

--
xorg fails to correctly detect Satellite pro 4600 and 6000 screen resolution
https://bugs.launchpad.net/bugs/239722
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Status in “xorg” source package in Ubuntu: New
Status in “xserver-xorg-video-trident” source package in Ubuntu: Confirmed

Bug description:
Binary package hint: xorg

On previous versions of Ubuntu, dpkg-reconfigure allowed me to specify monitor resolution etc. With hardy, this feature appears to have been removed. I believe that will encourage better detection code, and more usable front ends for less technical users. Nevertheless, I am right now left with 800x600 on my Toshiba Satellite Pro 4600, which has a native resolution of 1024x768 with only option to manually edit xorg.conf.

Steps to show bug:
Install a fresh copy of Ubuntu Hardy 8.04 on a Toshiba Satellite pro laptop.
Observe the GUI gives maximum resolution of 800x600.

Expected:
Resolution should include 1024x768 native screen resolution. This resolution has shown to work where screen resolution set manually.

lspci >error_report ; cat /var/log/Xorg.0.log >> error_report
[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub [8086:1130] (rev 11)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
01:00.0 VGA compatible controller [0300]: Trident Microsystems CyberBlade/XP [1023:9910] (rev 63)
        Subsystem: Toshiba America Info Systems Device [1179:0001]

This bug is also apparent on SP 6000.  lspci -vvnn snippet from SP6000:
01:00.0 VGA compatible controller [0300]: Trident Microsystems CyberBlade XPAi1 [1023:8820] (rev 82)
    Subsystem: Toshiba America Info Systems Device [1179:0001]
See massage from 17 Jan 09 for full details

Bryce Harrington (bryce) wrote :

[No need to have this double-filed against xorg as well]

Changed in xorg (Ubuntu):
status: New → Invalid
merlin_bean (merlinbean) wrote :

Still a problem with 9-04 desktop, 800x600 instead of native 1024x768. 9-04 Jaunty was fresh download within last 48 hours.

To be fair these cards could give similar issues under Xp with generic drivers, but I have seen Knoppix work fine on this hardware several years ago.

Having trouble getting built in WiFi to talk to even a wide-open router, also.

I would welcome any suggestions or patches!

Bryce Harrington (bryce) on 2009-09-02
tags: added: hardy
Nick_Hill (nick-nickhill) wrote :

Tested with Tosh 4600 and can confirm still a problem with 9.10 final.

tcsp (tcspwa) wrote :

driving me crazy. See bug question 89632

tcsp (tcspwa) wrote :

Anyone with a Toshiba satellite Pro 4600 make certain the cpu fan is operating! Mine does not, which may be something I did.
Under M$/XP it works fine

tcsp (tcspwa) wrote :
Download full text (5.0 KiB)

Just re-installed 6.06, all is well with the screen, and here is the /etc/X11/xorg.conf file

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc104"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "stylus"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "stylus"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "eraser"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "eraser"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "cursor"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "cursor"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "Trident Microsystems CyberBlade/XP"
 Driver "trident"
 BusID "PCI:1:0:0"
EndSection

Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
 HorizSync 28-51
 VertRefresh 43-60
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Trident...

Read more...

I can confirm the bug on a SP6000 using Ubuntu 10.04.

The maximum resolution that it supports by default is 800x600. The odd thing is that even though I have enabled image stretching in the BIOS, the displayed screen is squarely at the centre of the monitor.

Anyway, by creating an xorg file trough a tty:

$ sudo service gdm stop
$ sudo Xorg -configure
$ sudo mv ~/xorg.conf.new /etc/X11/xorg.conf

and editing it to add the following HorizSync and VertRefresh settings in the Monitor section

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
    HorizSync 31-60
    VertRefresh 50-75
EndSection

along with adding 'modes "1024x768"' in the Screen's display subsections, it works fine.

tcsp (tcspwa) wrote :

Nice to see someone is working on this.
Unfortunately my ignorance is limitless I cannot make the changes suggested by Alexandros.Schillings.
When I go to terminal & enter sudo service gdm stop my Toshiba goes to a black screen & I have to reset to reboot.
Guess gdm means graphic display monitor? & so I'm killing my interface?
Suggestions please?
tx

tcsp (tcspwa) wrote :

Update.

I bodily dragged the Ubuntu 6.06 /etc/X11/xorg.conf file across and all is well with the screen.

This implies something else has changed as /etc/X11/xorg.conf file editing made no difference to 9.04 et al

Still, all seems ok now. GREAT!

However!!! My cpu fan seems to not work now! (1st seen in 9.04) So I don't know if it is safe to use the laptop!

Obviously this topic is not concerned with fans but I suspect others with display problems may have this to deal with too!

Regards

MoLE (moleonthehill) wrote :

I have tested lubuntu 10.10 on a Toshiba Satellite Pro 4600 with the Cyberblade video hardware. Unfortunately the problem continues to persist.

I can test with Natty if any developers are still interested in this bug.

tcsp (tcspwa) wrote :

Yes problem still exists, and the Ubuntu 6.06 /etc/X11/xorg.conf file still is needed to fix it.
Guess the age of the laptop makes it of minimal interest as it can be worked around.
Note the fan does work but at much reduced level so it gets pretty hot!
Regards

tcsp (tcspwa) wrote :

Just installed U 11.4
And resolution/display is correct!!
Running tests for lower settings gives weird screen sizes, but main setting is perfect.
Jury still out on fan control.
Thanks to whomever(s) swept up that problem in the upgrades.

Timo Aaltonen (tjaalton) wrote :

could you attach your /var/log/Xorg.0.log here so it could be confirmed to be fixed?

tcsp (tcspwa) wrote :

________________________________
There you go!
Hope it helps
T

From: Timo Aaltonen <email address hidden>
To: <email address hidden>
Sent: Wednesday, 15 June 2011 9:27 PM
Subject: [Bug 239722] Re: xorg fails to correctly detect Satellite pro 4600 and 6000 screen resolution

could you attach your /var/log/Xorg.0.log here so it could be confirmed
to be fixed
--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/239722

Title:
  xorg fails to correctly detect Satellite pro 4600 and 6000 screen
  resolution

Status in “xorg” package in Ubuntu:
  Invalid
Status in “xserver-xorg-video-trident” package in Ubuntu:
  Confirmed

Bug description:
  Binary package hint: xorg

  On previous versions of Ubuntu, dpkg-reconfigure allowed me to specify
  monitor resolution etc. With hardy, this feature appears to have been
  removed. I believe that will encourage better detection code, and more
  usable front ends for less technical users. Nevertheless, I am right
  now left with 800x600 on my Toshiba Satellite Pro 4600, which has a
  native resolution of 1024x768 with only option to manually edit
  xorg.conf.

  Steps to show bug:
  Install a fresh copy of Ubuntu Hardy 8.04 on a Toshiba Satellite pro laptop.
  Observe the GUI gives maximum resolution of 800x600.

  Expected:
  Resolution should include 1024x768 native screen resolution. This resolution has shown to work where screen resolution set manually.

  lspci >error_report ; cat /var/log/Xorg.0.log >> error_report
  [lspci]
  00:00.0 Host bridge [0600]: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub [8086:1130] (rev 11)
          Subsystem: Toshiba America Info Systems Device [1179:0001]
  01:00.0 VGA compatible controller [0300]: Trident Microsystems CyberBlade/XP [1023:9910] (rev 63)
          Subsystem: Toshiba America Info Systems Device [1179:0001]

  This bug is also apparent on SP 6000.  lspci -vvnn snippet from SP6000:
  01:00.0 VGA compatible controller [0300]: Trident Microsystems CyberBlade XPAi1 [1023:8820] (rev 82)
      Subsystem: Toshiba America Info Systems Device [1179:0001]
  See massage from 17 Jan 09 for full details

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/239722/+subscriptions

Timo Aaltonen (tjaalton) wrote :

Thanks, closing as fixed. It was probably some xserver change that fixed it, since the driver itself hasn't seen functional changes in many years.

Changed in xserver-xorg-video-trident (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions