There is no user interactive menu method to configure xorg.conf from a shell

Bug #207409 reported by komputes
62
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Won't Fix
Wishlist
Unassigned

Bug Description

Binary package hint: xserver-xorg

I understand the point of X trying to configure the video driver automatically, but in case that it is done erroneously, the option to run dpkg-reconfigure (to interactively set the video driver) has been taken away.

X being able to auto configure is a good goal, but they should leave the old tools until it has been thoroughly tested. Here we are that I need to know which video driver is in use. Before I could just open xorg.conf (not the best indication of the driver in use, but nevertheless easy) to find the video driver name. In hardy all you see is "Configured Device"

When I run dpkg-reconfigure -phigh xserver-xorg to get the user-interactive method to configure X, it skips over all the video questions. So if X makes the wrong choice in driver/configuration, the user has to change the xorg.conf file manually which is not good (prone to errors). What I would like to know is if any of you have a command that will tell you what video driver(s) is in use. I have tried looking in /var/log/Xorg.0.log, but it only gives a hint of what the driver is, well it's not very efficient (or scale-able), although it may be more reliable than looking at an old xorg.conf file.

Do you think users should be forced to report bugs? From a historical perspective, how long has it taken in the past for an xorg bug fix to be released? A day? A month? I can tell you that no user is going to want to submit a bug report and wait a month for a response so that they can get Ubuntu up and running. This feature of user-interactively reconfiguring xorg.conf from the shell was crucial as a last resort. Now, with Hardy, that feature, the last resort, is gone.

The issue:
There is no user interactive menu method to configure xorg.conf from a shell
AFAIK There is no way to poll the computer for the name of the video driver in use (with only tools/packages included with the distibution).
The xorg.conf file is configured at startup, there is no config file and xorg.conf only shows "Configured Video Device", so the user without a GUI can't knows what driver is being used.

To read more on this issue please look at the following threads:

http://ubuntuforums.org/showthread.php?t=735118
http://ubuntuforums.org/showthread.php?p=4593208

Revision history for this message
Bryce Harrington (bryce) wrote :

Here is a c program that gets the driver out of the log.

Revision history for this message
Bryce Harrington (bryce) wrote :

And here's a bash script, in case you don't like compiling C. This is adapted from compiz-manager.

Revision history for this message
Bryce Harrington (bryce) wrote :

displayconfig-gtk is a user interactive method for configuring xorg.conf. Like dpkg-reconfigure it also often produces invalid configurations. We recommend using the autoconfiguration approach, and if that does not work for some reason, please report it as a bug. This way we can roll out a true fix for everyone.

Changed in xorg:
status: New → Fix Released
Revision history for this message
komputes (komputes) wrote :

Bryce, you have to look at this from a support point of view.

1) xorg_info or xorg_driver is not included by default on the OS so I cannot ask a user to run it remotely so that I can get the info of what driver their machine is running. If they do not have an internet connection and a working video display, then we are at a loss because the OS is not supportablke out of the box. Do you see how this can be a major major issue? We cannot assume that the user should have a working internet connection, ask them to install custom software, just to know what driver is being used. This is not a supportable solution.

2) displayconfig-gtk is a gtk application, thus visual. The user will experience an error saying "RuntimeError: could not open display". If a user cannot get to GDM or the graphical login screen, how would you expect them to run displayconfig-gtk. As I have told you VESA is not bullet-proof and does not currently support all video cards as a "fall-back". The fact that you are recommending a graphical tool to someone who can't get a GUI up make me believe that you do not understand the issue. To get this to work, the user would have to manually change/copy xorg.conf until it works so that they could run GDM and run displayconfig-gtk to be able to change the xorg.conf file. Which come first the chicken or the egg? Can you say Catch 22?

Until you have been put in the situation of not being able to configure your card from the shell, you will not understand the frustration of the user. Obviously you do not fully understand the extent of this bug since you are suggesting a GUI application to a user that has nothing but the shell. This is why I say that there needs to be a text-based tool to make changed to xorg.conf (to force overriding the automated xorg configuration).

Bring back dpkg-reconfigure -phigh xserver-xorg without the automation, or at least create something similar and make sure it gets placed into hardy before release.

Revision history for this message
komputes (komputes) wrote :

A fix has not been released. A user with only shell access cannot reconfigure the driver and resolutions without manually re-writing xorg.conf.

description: updated
Changed in xorg:
status: Fix Released → Confirmed
komputes (komputes)
description: updated
description: updated
Revision history for this message
Kivech (kivech-deactivatedaccount) wrote :

I have to agree with komputes here. It is absolutely vital that there are text-based tools to configure xorg.conf.

We are not looking forward to a "Windows" type philosophy being implemented into Linux where the system knows best and when it doesn't, all you can do is curse and pull out your hair.
Linux is about flexibility and having the option to do things in several ways, where you can pick the one that suits you best. Adding an autoconfig tool is nice and good, but one cannot take out the other tools. That is effectively downgrading your system.

Also, if we have to bring up these kind of discussions, I really start to think that there is a huge misconception on behalf of the developers with regard to what the user wants. The user wants usability, ease of use, flexibility and compatibility. Taking out those tools eliminates all those factors if the autoconfig tools happens to miss-identify your video card.

So yes, put the tools back as a fall back for those less fortunate ones, who will at least have a chance to use Ubuntu. Or are you suggesting that from the Ubuntu team no one really cares that there will be users who want to use Ubuntu but can't, simply because of wrong policies being used by the team?

Really, you don't want to build yourself a reputation of just doing what you think the user wants and is best for him/her, while ignoring their actual needs and wishes. That will really rapidly build a really bad reputation for this OS.

Revision history for this message
67GTA (67gta) wrote :

I also agree that there needs to be some way to fix this when it doesn't work. It is going to be impossible to make every piece of hardware work flawlessly by the final release. In the rare occasion something goes haywire, you can't expect a new user to edit config files by hand.

Revision history for this message
john matthewman (ynnhoj) wrote :

i'm also going to have to agree with komputes on this topic. on this machine, my display is never detected properly; however, that was okay in the past because fixing it was always one "sudo dpkg-reconfigure ..." away. that's not the case now! fortunately, i was able to use displayconfig-gtk to fix the problem (thanks for mentioning that app., by the way!) but if i hadn't been able to start xorg at all... would i have written an xorg.conf from scratch? not bloody likely!

Revision history for this message
Matthieu Yiptong (ergosteur) wrote :

I was actually in a situation where I couldn't start X, and didn't have internet access. I must concur that there should be a relatively easy to use console tool to configure X in case the autodetection fails. I don't have the patience to write an xorg.conf!

Revision history for this message
Tomas 'tt' Krag (tt) wrote :

I have a situation here, where it seems that the X autoconfiguration works fine, but my monitor refuses to show any output with the refresh rates chosen, thus even when autoconfiguration works, there is a need for text-based tools to reconfigure. Since I have no output from X i cannot login and reconfigure.

It also makes it hard for me to report a bug, as suggested, because there really is no error, except that my monitor cannot show the same resolution and refresh rate as my laptop.

Revision history for this message
Tomas 'tt' Krag (tt) wrote :

Just an additional update:

I have now tried remote logging in with a vnc viewer and running displayconfig-gtk, but have been unable to actually change my displaysettings this way. This pretty much makes hardy unusable on my setup, as i have no idea how to get a xserver display on my screen. So either i have to buy a new screen or revert to gutsy, neither og which i relish. And this on a mac mini where the xserver settings are all detected correctly....

Revision history for this message
sojourner (itsmealso2) wrote :

some way of manualy configuring your hardware and preferably both from term and gui must remain , there is some hardware ( one of my monitors for instance) that does not report itself via edid and therefore is never configured correctly , I freely admit this is due to cheap non compliant hardware but there must remain a way of handling that kind of hdw because there is a lot of that out there . I hand edit my xorg.conf but this is beyond a lot of people so please keep the necessary tools avaiable.

Revision history for this message
alpha-X-geek (alpha-x-geek) wrote :

Am I right in thinking that "xrandr" has replaced "dpkg-reconfigure" as a way to manually configure graphics devices in text-mode?

Nathan

Revision history for this message
josh04 (josh04) wrote :

xrandr doesn't make permanent changes to the configuration, iirc.

Just adding my voice, I had the issue where auto-configure wouldn't detect my Intel 965, and in addition displayconfig-gtk wouldn't change the driver either. I could only resolve the issue by installing xserver-xorg from gutsy and running dpkg-reconfigure, then upgrading again.

Revision history for this message
Pawel Jasnos (pjasnos) wrote :

Am I wrong in thinking that dexconf should generate xorg.conf which would use vesa and 800x600 resolution, which should always work, and be a good starting point?

Revision history for this message
Serge SMEESTERS (sergesmeesters) wrote :

For me to, it's a bad surprise :(
I thing some Ubuntu peoples don't understand well some important thing about free software again :/
Awaiting "bug"(stupidity) correction...

Revision history for this message
Max Schukin (schukin) wrote :

Autoconfiguration doesn't work for me either. I had to use my gutsy xorg.conf to make it work.

Please, fix this "bug".

Revision history for this message
ashik (ashiktkmc) wrote :

I couldn't change the resolution from 640x480 in hardy (Intel 845 PC).I had to copy the xorg.conf file from gusty installation to change the resolution.

Revision history for this message
Thomas (teoverton) wrote :

Guys, I've got to agree here. I've clean installed xubuntu hardy over gutsy on a laptop which has used every ubuntu variation since warty...and cannot get the resolution to work right. Auto config rarely works on this laptop (via graphics) but I've always been able to get it to work by tweaking xorg.cong...now there is nothing in xorg.conf to tweak, and dpkg-reconfigure has been emasculated. I cannot rebuild xorg from scratch. I didn't keep my gutsy xorg because it has always been a couple of minutes work to make it function. I have 11 computers running ubuntu variants in my house, and 20 odd others that I am responsible for, and this was the first upgrade to Hardy which has now taken hours of frustration...please fix this and give us back our tools.

Revision history for this message
Yuanle Song (sylecn) wrote :

I agree with this bug.
I was a bit surprised when I found just one line in my Section "Device", that's
    Identifier "Configured Video Device"
Then I guess x.org has changed some behavior. Although the graphic card is working, I want to known how x.org manager to 'guess' my driver and options.
I found a GUI setting window (hides in Other -> Screens and Graphic) for users to select a model or select a driver.
Then I 'accidently' choosed intel -> i915 driver, cause x.org is running well I don't really need to choose. Next time I login, I was in low resolution and x report a error, driver not found! I have to change xorg.conf manually, especially adding the *one line* I mentioned above, to get X working again.
I beg this should not happen especially to newbies.

Revision history for this message
infurnus (axemaninferno) wrote :

This sucks that this "bug" has not been updated as of yet. You would think this would be top priority. I'll exclude additional reasonings to avoid being redundant but it should appear as though this would be a necessity not a want or wish list. I really would like to see the growth of ubuntu but this won't happen by restricting/removing tools needed to properly configure ill configs.

Revision history for this message
CanadianLinux (ryangharrington) wrote :

I have experienced this video issue with every Linux distro I have used, except knoppix and a few others. I am not sure if it is something with my monitor or my ATI video card, but I always got a black screen when booting. Using dpkg-reconfigure xserver-xorg or a similar command resolves the issue. I am not that technical but with doing research I was able to get X working, However, many Windows users might not have gone and found a solution. They will Boot to a black screen and just give up there, now "Linux" doesn't work. With dpkg-reconfigure xserver-xorg disappearing all of a sudden I am not happy. I thought the Ubuntu Team would for sure release another option in the final release. NOPE, its a "WIndows" thing to make things auto-detect. Its only good when it works!!! This makes me look elsewhere for my Linux OS.

Revision history for this message
Digger78 (bigyin50) wrote :

I was pleasantly surprised that the auto-configure worked for me until i installed the nvidia driver and rebooted to the console login. I have onboard graphics and a PCI graphics card.

I was disappointed that "dpkg-reconfigure xserver-xorg" no longer did what i expected it to do.

I had to manually add "BusID "01:01:0" to the device section of xorg.conf

Luckily i knew what i had to do, but i believe a lot of new users will be lost.

(of course it would be better if the nvidia driver detected the correct BusID :p )

Revision history for this message
Cristian Gómez (cristianpark) wrote :

I have some issues and have to do a dpkg-reconfigure xserver-xorg, and unfortunaly, i found that the command doesn't do what it use to do before....the only thing that i can configure was my keyboard, but can't configure anything about video card. I hope that hardy improve few things to make it the best ubuntu.

Revision history for this message
Mark (mmccaghrey) wrote :

I agree with all the negative comments above. Startx does not work. I am a Linux/Ubuntu newbie so don't know enough to edit xorg and cannot connect to Internet with my Ubuntu pc. I have S3 Trio which I understand by googling does not always work out of the box, so how am I supposed to fix this?

Revision history for this message
Serge SMEESTERS (sergesmeesters) wrote : Re: [Bug 207409] Re: [HARDY] xserver-xorg does not auto-configure correctly

> I agree with all the negative comments above. Startx does not work. I am
> a Linux/Ubuntu newbie so don't know enough to edit xorg and cannot
> connect to Internet with my Ubuntu pc. I have S3 Trio which I understand
> by googling does not always work out of the box, so how am I supposed to
> fix this?

Try another than [last] Ubuntu :(

Serge.

Revision history for this message
joeythedog (joeythedog) wrote : Re: [HARDY] xserver-xorg does not auto-configure correctly

i have been on Ubuntu for about a year now... i've managed to talk my girlfriend and her friend into switching over to it for their laptops... now this... black screen... i'm pretty savy but reverting to an old xorg.conf file after a hardy upgrade screwed everything up... i don't care if canonical doesn't want manual edits of xorg... but please bring back ALL functionality of dpkg-reconfigure... i write this using (ahggh) windows xp... please keep me a loyal ubuntu-er and include support for all us who can't afford new video cards... PS i'm using an on-board card... also... hardy screwed up my friends broadcom wireless (damn it took me days to get that thing working in edgy and gutsy)... I may stop talking people into the switch to Ubuntu if only ultra-modern hardware is acknowledged... thanks for all the great months of virus free computing... but again... please bring back the extended video config options... i get 10 keyboard options for an X-config, and NONE for the actual card!!! that makes NO sense!?!?!?

Revision history for this message
Officeitplus (officeitplus) wrote :

Is this bug likely to get fixed? I have a ASUS Pundit-R which has worked happily with Gusty since it was issued but is less useful now.

A simple work around would do in the interim but longer term it the system needs to be flexible if the automatic configuration fails. This type of problem is what has put lots of people off MS products.

Revision history for this message
Valen (master-ed) wrote :

I have a similiar problem which *might* be a way for developers to experience what's happening when autoconfiguring fails:
I'm trying to set up a virtual machine with Sun's VirtualBox and Ubuntu 8.04. First of all, the direct installation doesn't work, but that doesn't matter here. So I installed Ubuntu 7.10 first (remark: the display was set to 1280x1024) and then I updated it to 8.04 without installing any updates first. The effect was, that after the update the resolution was set to 640x480. Since then I managed to get a resolution of 800x600 but that's not really nice either.
The thing that's really pissing me off is this: after editing xorg.conf manually I get at least 1024x768 on the Login-Screen, but as soon as I'm logged in, the resolution is set back to 800x600, and that's just stupid.

Revision history for this message
David S (d-searle) wrote :

After a week of trying (and learning quite a lot in the process) I'm unable to improve on 800x600 when the native resolution of my laptop screen is 1280x800. This is useless and I'm very sad to say I'll be forced to return to the OS I so desperately wanted to leave behind.

Revision history for this message
Strange_Movement (strangemovement) wrote :

I'm kind of hoping that just by adding my name to the end of this ever growing list someone at Canonical may realize that this is a bug that should be taken seriously. I've just encountered it on a PC that I had convinced a paying customer to make the swap to Ubuntu on. I believe I may have actually run into this bug once before while mucking around with some old PC parts, but fortunately that time I wasn't doing anything important and so was able to ditch the whole project without bothering to investigate.

Revision history for this message
Pawel Jasnos (pjasnos) wrote :

Emm.... why not just try:
sudo apt-get install displayconfig-gtk
sudo displayconfig-gtk

Revision history for this message
Officeitplus (officeitplus) wrote :

Because it doesn't work. :-(

Traceback (most recent call last):
  File "/usr/bin/displayconfig-gtk", line 75, in <module>
    app = DisplayConfig(options)
  File "/usr/lib/python2.5/site-packages/displayconfiggtk/DisplayConfig.py", line 189, in __init__
    debug_scan_pci_filename=self.options.pcitable)
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 394, in __init__
    self._finalizeInit()
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 404, in _finalizeInit
    gfxcard._finalizeInit()
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 1123, in _finalizeInit
    screen._finalizeInit()
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 1588, in _finalizeInit
    (cw,ch,x,x) = self.x_live_screen.getSize()
  File "/var/lib/python-support/python2.5/xf86misc.py", line 77, in getSize
    return self.sizes[self.currentsizeid]
IndexError: list index out of range

Revision history for this message
Pawel Jasnos (pjasnos) wrote :

hmmm... Stupid question - you are running it from GUI, not console??

You may also try to run dexconf first, just to reset xorg.conf to whatever it thinks is default and then try again. (it looks like displayconfig-gtk couldn't get screen size - I'd report this as a separate bug. It's still a package in Hardy (and works fine for me), so it can be reported :-).

Revision history for this message
catch (catch56) wrote :

I get periodic black screens (out of range), and of course have the same issue that dpkg-reconfigure xserver-xorg (and displayconfig-gtk) don't allow me to reset in any sensible way, nor does my old gutsy xorg.conf help. Having done a lot of searching for this particular bug, I can confirm it's leading to many dozens of mostly unresolved support requests (which I'll be adding to once I'm sure I've not got an exact duplicate of another one).

Revision history for this message
Chris (chrisjmyers1204) wrote :

I think this is happening to me also. I tried sudo dpkg-reconfigure xserver-xorg, but with no video questions i think that is a dead end.
I tried sudo displayconfig-gtk, but it is ignoring my monitor. Here's what I receive when i push the test button:

on_button_test_config_clicked()
xauth: creating new authority file /tmp/dcg-BlL39Z8610/xauthority
Got pid 8628
(0, 0)
checkpoint 1
None
False
Sorry, this configuration video card driver
and monitor doesn't appear to work:

Messages from the X server:
(EE) I810(0): Cannot read V_BIOS (3)
(EE) I810(0): VBE initialization failed.
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:

I tried sudo dexconf, I am not sure what it actually does, but i thought it wouldn't hurt to try. And I cannot see any real change after this command. It did whatever but no signs of improvement.
I have a Nvidia card that usually works after I enable restricted device driver for it, but not this time.
I uninstalled all Nvidia software,drivers,ect and try another method that usually works as a backup and that EnvyNG, but once again, same 320x240 resolution with no other options except downgrading to Xubuntu 7.10 which is okay but could someone let me know if this ever gets back to normal?
Could something that usually relays the info to xserver-xorg be busted or possibly someone removed some lines of code or something?
I am not sure and don't know how to check it myself.
I don't have the time anytime soon but could someone check and see if anybody has reported this to https://bugs.freedesktop.org/ and if it has not been reported, Please make a bug report there linking back to this page and come back here and link to that page so we can follow it?

Revision history for this message
ba.page (ba-page) wrote :

Our enemies has this ridiculously easy slide bar that somehow works near perfectly.

X really should have a distro-unified interface (GTK and Text) with a tab for each device it controls. Video card, Monitors (yeah all of your monitors, not just one), mouse, keyboard, etc...

Failing that, I would settle for a box that said: "Punch in the resolution you'd like to see"

I've installed Hardy on probably 8 different kinds of computers and autoconfig hits the mark on about half of them.

Revision history for this message
Andreas Heinlein (aheinlein) wrote :

Just wanted to put my name under this list...

I can second ba.page; I have tried hardy on about 6-8 different machines where only 2 worked out of the box. All except one did work with Feisty/Gutsy. Worse still, we're currently trying to develop a modified live ubuntu CD, where using sudo displayconfig-gtk every time is not an option. We will probably stick with Gutsy until this is solved.

Revision history for this message
Bryce Harrington (bryce) wrote :

Guys, the old dpkg-reconfigure was no panacea. It was barely more tolerable to people than editing xorg.conf. Tons more people complained about it than are complaining now that it's gone. It failed more than it worked anyway, was a huge buggy hack of a code, and it consumed too much maintenance energy upstream at Debian. They dropped it with good riddance once the autoconfigure stuff proved to be sufficiently reliable. And for similar reasons, its too cumbersome to be practical for Ubuntu to maintain instead.

This bug report seems to have turned into more of a discussion forum than something that can feasibly be implemented. Unless someone can propose an actually implementable idea, then I think this should be closed as invalid. I'll leave it open for now to see if any practical approaches get suggested.

Changed in xorg:
importance: Undecided → Wishlist
status: Confirmed → Incomplete
Revision history for this message
Chris (chrisjmyers1204) wrote :

Until there is a solution for all of us with this issue it should remain open. I feel crippled on another os. If anyone has anymore information that might be useful, please provide that info. Well, i guess i could go back to gutsy...
But anyway, this is not only a discussion. Most of us are here because we ran into this problem and have no solution now. If you have a solution other than downgrade or just run using bad resolution, please let all of us know.

Revision history for this message
Bryce Harrington (bryce) wrote : Re: [Bug 207409] Re: There is no user interactive menu method to configure xorg.conf from a shell

On Sat, Jul 19, 2008 at 08:42:54PM -0000, Chris wrote:
> Until there is a solution for all of us with this issue it should remain open. I feel crippled on another os. If anyone has anymore information that might be useful, please provide that info. Well, i guess i could go back to gutsy...

If you had a working xorg.conf on Gutsy, just reuse that on Hardy. If
it doesn't work, then bringing back the dpkg-configure stuff (as this
bug is demanding) would not solve whatever your issue is anyway.

> But anyway, this is not only a discussion. Most of us are here because we ran into this problem and have no solution now. If you have a solution other than downgrade or just run using bad resolution, please let all of us know.
>

No, your root problem is whatever caused your X to not start up, and
that issue is almost certainly unique compared with the other commenters
on this bug.

If people are choosing to put a comment on a bug report requesting a
workaround, rather than actually reporting their real, root bug so that
it can get solved properly, that would be quite unfortunate.

Revision history for this message
Chris (chrisjmyers1204) wrote :

It's all rather confusing to me. It's strange that information or whatever is not just carried over on an upgrade. Such as most of the time hardware remains the same. Are files being deleted and/or overwritten and why if it works? Shouldn't it check for working configurations before trying to make its own or before it modifies or deletes it? I don't know. I'm not really sure about how to look for what and where to look for what, not to mention if X doesn't start at all and your without graphical interfaces. I only know so much about command line interfaces, and its probably not enough to repair ubuntu in such cases except that sudo dpkg-reconfigure xserver-xorg and sudo apt-get install nvidia-glx used to work like a charm. Is there something other than xserver-xorg handling things like monitors and graphics cards now?

Revision history for this message
Chris (chrisjmyers1204) wrote :

Currently I am reading https://wiki.ubuntu.com/X/AutodetectMonitorFrequency because there seems to be something there but I just can't put my finger on it. I am trying to understand these things a little better. If xserver-xorg is not writing these detections anymore, what is and how to correspond with it. You know, is this basic stuff thats supposed to be easy or do i need some sort of training that would help? Also is there a page I should be looking for in particular for this instance because having a resolution of 640 x 480 isn't very good for the eyes. It used to be 1024 x 768. Is there some where i can write this resolution? What is the proper question I am looking for?

Revision history for this message
Chris (chrisjmyers1204) wrote :

Well, somehow sudo displayconfig-gtk was able to at least get me 800 x 600 , and right now i am using the Hardy Wubi 8.04.1 so maybe i will download 8.04.1 and do the same because i think i can handle 800 x 600.

Revision history for this message
Andreas Heinlein (aheinlein) wrote :

@Bryce
You need to see this from a users point of view: if Ubuntu 8.04 is not able to detect the correct/desired resolution or even not let the user set one (from System->Settings...), this may well be a reason to switch to another distro or even back to Win***. As such, "sufficiently reliable" is not enough. This may be a problem of the developers at x.org and not of the Ubuntu maintainers, but until X autodetection detects at least 99,9% of the monitors that win*** does, we have to live with ugly hacks and workarounds.
But now for the practically implementable ideas: Keep the old dpkg-reconfigure scripts/hacks as an alternate way. 'dpkg-reconfigure xserver-xorg' in hardy should then ask something like "How do you want your monitor to be detected? 1.) Autodetected by X server 2.) Autodetected by legacy script 3.) manually". 2.) would be the same as the old dpkg-reconfigure stuff with no questions asked, and 3.) the same with the well-known questions from feisty/gutsy. You could make this question low priority, so only those people who know what they're doing will ever get to see this question.
And upgrading from gutsy should of course leave a possibly working xorg.conf in place instead of overwriting.

Revision history for this message
komputes (komputes) wrote :

Andreas, I had to reflect on the reasoning behind #2 and it made me think of a probable resolution to this entire bug.

I think I see what benefit you would gain from autodetection using the legacy script: It will write out a defined xorg.conf file automatically instead of writing an xorg.conf file with "Configured Device" which contains no specifications/settings.

The way I would implement this for the user is to go into Recovery mode where (in Hardy) you will end up on (what I like to call) the "Blue Screen of Fix" also known as the "friendly-recovery" package.

The description of this package is as follows:
Make recovery more user-friendly
Make the recovery mode more user-friendly by providing a menu with plugable options.

Looking at the words "plugable options" made me think, why can't we just take the code from 7.10's autodetection/manual configuration and make it a module or a "pluggable option" in recovery mode available to 8.04 and future releases. This does not have to be in Ubuntu by default since xorg autoconfigure is getting better and better as time goes by (autodetection - it's the wave of the future), and it is currently "sufficiently reliable" as Bryce has said.

Therefore I think the "plugable option" is our best option. A new package should be created from the old detection/manual configuration code and be plugged into friendly recovery. This way the minority of users having auto-detection issues, could install a package from the repositories that will allow legacy (yet still compatible) well defined xorg.conf files.

I recommend it be implemented into the recovery menu as a secondary menu, after having selected "Autodetect Video/Display", like so:

>Autodetect Video/Display
>>Autodetect
>>Autodetect and write static xorg.conf
>>Manual Configuration
>Drop to root shell
>File system Check (fsck)
>Fix packages

In short: If someone is able to code this, we can fix this bug by creating a new optional package that resolves the issue.

Revision history for this message
holycow (mik-mars) wrote :

when will this gnome desease just die already?

i'm seconding all the negative comments on this bug.

please remember that xorg is sufficiently complicated that very few people can edit the file manually and chopping the head off a tool that worked VERY WELL (despite the whiners, i've helped them all and its mosly user error not ..-reconfigure) is beyond dumb.

bring back dpkg-reconfigure, and ditch this autodetection nonsense or at minimum allow the noted option above to select automatic or manual detection.

Revision history for this message
ba.page (ba-page) wrote :

Just the other day I configured a display on a Mac. (OS 10.4.11)
It failed to pick up my monitor automatically (Just like Ubuntu, CentOS and Untangle)

It did, however, have a useful control panel tool called display.
This little app let me scroll down a loooong list of possible resolutions and refresh rates.
I picked the one I wanted, it offered me a 15 second-no-reponse-back-out that required me to click 'OK' and it worked perfectly.

This is all we need:
If: you can't do it automatically, Then: let us pick the one we think is right.

Definitely Not:
If: you can't do it automatically, Then: 800x600@60

Revision history for this message
Bryce Harrington (bryce) wrote :

You're welcome to try putting the postfix script into a new package separate from xorg that uses curses or whatever to generate an xorg.conf for you. I think you overestimate the likelihood that it'd actually be able to fix these problems, but I could be wrong. In any case, since it'll be a new package, it's no longer needs filed against the 'xorg' package. Closing.

Changed in xorg:
status: Incomplete → Won't Fix
Revision history for this message
Jworkman (scholastic) wrote :

Also does not work for me. I have a SiS chipset, and when I drop my res using displayconfig-gtk it wants to reset itself to rediculous resolutions. Why was this changed? Who is the idiot smokin weed that decided to change a perfectly working system in the first place?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers