Ubuntu

Sticking Keys

Reported by Bryan Haskins on 2008-02-10
This bug report is a duplicate of:  Bug #194214: Keys get "stuck" down. Edit Remove
14
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
X.Org X server
Fix Released
Unknown
xorg (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

This was originally filed as a Wine bug, but I have recently determined it to be a more general bug in X, if someone can prove it otherwise, please do, do help narrow things down.

Anyway, occasionally when in an OpenGL application, Games, for instance... a Button with magically begin to repeat itself, as if being held down. It could be the up arrow, 1, 2, w, q, z, whatever, it's a general issue. It rarely happens right off, but seems entirely random when it occurs. It has been seen in both native and non-native (non-native-ish (wine)) OpenGL applications, and is becoming a real plague to gaming.

I can't offer very much specific information, I mean this is a hard thing to trace. Myself I mainly see it in Wine, but that is where I spend most of my time as far as gaming goes, and it has been witnessed by others in native applications, and found true by myself in trials.

After closing the application in question, the key remains repeating, sticking, if you will. For example, if it were the 'up' key, and I made it back to my terminal, the behavior would be scrolling through my type history. you get the idea on how that works most likely.

Changed in xorg-server:
status: Unknown → Confirmed
Bryan Haskins (bryan-h) on 2008-02-10
Changed in xorg:
status: New → Confirmed
Michael Blakeley (mike+ubuntu) wrote :
Download full text (7.1 KiB)

I've seen something like this with the alt key - it'll stick in the "down" state, so alt-tab and alt for menu access become problematic. Suspend-resume doesn't help, so I tend to agree that it's an xorg issue.

$ uname -a
Linux mblakele-lt 2.6.24-7-generic #1 SMP Thu Feb 7 00:56:31 UTC 2008 x86_64 GNU/Linux
$ lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]

$ apt-show-versions | grep xorg
xserver-xorg-input-kbd/hardy uptodate 1:1.2.2-3ubuntu1
xserver-xorg-video-s3/hardy uptodate 1:0.5.0-4
xserver-xorg/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-video-voodoo/hardy uptodate 1:1.1.1-5
xserver-xorg-video-vga/hardy uptodate 1:4.1.0-8
xserver-xorg-video-cirrus/hardy uptodate 1:1.1.0-8
xserver-xorg-input-synaptics/hardy uptodate 0.14.7~git20070706-1ubuntu2
xserver-xorg-video-intel/hardy uptodate 2:2.2.0.90-2ubuntu2
xserver-xorg-video-mga/hardy uptodate 1:1.4.8.dfsg.1-1
xserver-xorg-video-tseng/hardy uptodate 1:1.1.1-4
xserver-xorg-video-ati/hardy uptodate 1:6.7.197+git20080208.8606c1bd-0ubuntu0tormod
xserver-xorg-video-rendition/hardy uptodate 1:4.1.3.dfsg.1-4
xorg/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-input-evdev/hardy uptodate 1:1.2.0-1
xserver-xorg-input-vmmouse/hardy uptodate 1:12.4.3-1ubuntu1
xserver-xorg-video-fbdev/hardy uptodate 1:0.3.1-4
xserver-xorg-core/hardy uptodate 2:1.4.1~git20080131-1ubuntu2
xserver-xorg-input-all/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-video-cyrix/hardy uptodate 1:1.1.0-8
xserver-xorg-video-openchrome/hardy uptodate 1:0.2.901-0ubuntu4
xserver-xorg-video-sis/hardy uptodate 1:0.9.3-6
xserver-xorg-video-glint/hardy uptodate 1:1.1.1-8
xserver-xorg-video-vmware/hardy uptodate 1:10.15.2-1
xserver-xorg-video-all/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-video-dummy/hardy uptodate 1:0.2.0-7
xserver-xorg-video-radeonhd/hardy uptodate 1.1.0+git20080208.7606be1a-0ubuntu0tormod
xserver-xorg-video-trident/hardy uptodate 1:1.2.3-6
xserver-xorg-video-savage/hardy uptodate 1:2.1.3+git20080131.583051fc-0ubuntu0tormod
xserver-xorg-video-v4l/hardy uptodate 1:0.1.1-6ubuntu1
xserver-xorg-video-neomagic/hardy uptodate 1:1.1.1-8
xserver-xorg-input-wacom/hardy uptodate 1:0.7.9.3-2ubuntu2
xserver-xorg-video-sisusb/hardy uptodate 1:0.8.1-9
xserver-xorg-video-vesa/hardy uptodate 1:1.3.0-4ubuntu3
xserver-xorg-video-nv/hardy uptodate 1:2.1.7-1
xserver-xorg-video-s3virge/hardy uptodate 1:1.9.1-7
xserver-xorg-video-tga/hardy uptodate 1:1.1.0-9ubuntu1
xserver-xorg-video-ark/hardy uptodate 1:0.6.0-9
xserver-xorg-video-i128/hardy uptodate 1:1.2.1-4
xserver-xorg-input-mouse/hardy uptodate 1:1.2.3-2
xserver-xorg-video-via/hardy uptodate 1:0.2.2-5
xserver-xorg-video-tdfx/hardy uptodate 1:1.3.0-6
xserver-xorg-video-apm/hardy uptodate 1:1.1.1-10
xserver-xorg-video-i810/hardy uptodate 2:1.7.4-0ubuntu7
xserver-xorg-video-siliconmotion/hardy uptodate 1:1.5.1-3
xserver-xorg-video-chips/hardy uptodate 1:1.1.1-9
$ xdpyinfo
name of display: :0.0
version number: 11.0
vendor string: The X.Org Foundation
vendor release number: 10400090
X.Org version: 1.4.0.90
maximum request size: 16777212 bytes
motion buffer size: 256
bitmap unit, bit order, padding: 32, LSBFirst, 32
image byte orde...

Read more...

Bryan Haskins (bryan-h) wrote :

Makes sense, it's probably not directly an issue with 3D, but simply shows up there more often do to button mashing. Maybe it's something to do with that, as it's almost always my arrow keys while in a game, those are generally pressed frequently, or held for long period of time, most frequently it is "up" which is simply held most times. Assuming your issues are the same, which it seems at least crazily similar, we can rule it out as an nVidia bug.

elegos (elegos) wrote :
Download full text (3.3 KiB)

I can confirm this bug too... I thought it was a single-key iussue (and then hardware), but it isn't... In fact playing @ an FPS (and thus using WASD keys) the W key was pretty allways in the 'pressed state'... trying to test the same key using arrow keys, the [UP] key automagically 'binded' to down-state. Also playing on WINE it's the same thing, an I suspect that if we press any key for 10-20 seconds on the desktop the problem will be the same. So I think it's a xserver problem, and a very annoying one...

elegos@medea:~$ uname -a
Linux medea 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux
elegos@medea:~$ lspci | grep nVidia
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400M GS (rev a1)
elegos@medea:~$ apt-show-versions | grep xorg
xserver-xorg-input-kbd/hardy uptodate 1:1.2.2-3ubuntu1
xserver-xorg-video-s3/hardy uptodate 1:0.5.0-4
xserver-xorg/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-video-voodoo/hardy uptodate 1:1.1.1-5
xserver-xorg-video-vga/hardy uptodate 1:4.1.0-8
xserver-xorg-video-cirrus/hardy uptodate 1:1.1.0-8
xserver-xorg-video-newport/hardy uptodate 1:0.2.1-4ubuntu1
xserver-xorg-input-synaptics/hardy uptodate 0.14.7~git20070706-1ubuntu3
xserver-xorg-video-intel/hardy uptodate 2:2.2.0.90-2ubuntu2
xserver-xorg-video-mga/hardy uptodate 1:1.4.8.dfsg.1-1
xserver-xorg-video-tseng/hardy uptodate 1:1.1.1-4
xserver-xorg-video-ati/hardy uptodate 1:6.7.197-1ubuntu1
xserver-xorg-video-rendition/hardy uptodate 1:4.1.3.dfsg.1-4
xorg/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-video-nsc/hardy uptodate 1:2.8.3-2
xserver-xorg-input-evdev/hardy uptodate 1:1.2.0-1
xserver-xorg-video-i740/hardy uptodate 1:1.1.0-7
xserver-xorg-input-vmmouse/hardy uptodate 1:12.4.3-1ubuntu1
xserver-xorg-video-fbdev/hardy uptodate 1:0.3.1-4
xserver-xorg-core/hardy uptodate 2:1.4.1~git20080131-1ubuntu2
xserver-xorg-input-all/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-video-cyrix/hardy uptodate 1:1.1.0-8
xserver-xorg-video-openchrome/hardy uptodate 1:0.2.901-0ubuntu4
xserver-xorg-video-sis/hardy uptodate 1:0.9.3-6
xserver-xorg-video-glint/hardy uptodate 1:1.1.1-8
xserver-xorg-video-vmware/hardy uptodate 1:10.15.2-1
xserver-xorg-video-all/hardy uptodate 1:7.3+10ubuntu4
xserver-xorg-video-dummy/hardy uptodate 1:0.2.0-7
xserver-xorg-video-trident/hardy uptodate 1:1.2.3-6
xserver-xorg-video-savage/hardy uptodate 1:2.1.3-5
xserver-xorg-video-v4l/hardy uptodate 1:0.1.1-6ubuntu1
xserver-xorg-video-neomagic/hardy uptodate 1:1.1.1-8
xserver-xorg-video-imstt/hardy uptodate 1:1.1.0-7
xserver-xorg-input-wacom/hardy uptodate 1:0.7.9.3-2ubuntu2
xserver-xorg-video-sisusb/hardy uptodate 1:0.8.1-9
xserver-xorg-video-vesa/hardy uptodate 1:1.3.0-4ubuntu3
xserver-xorg-video-nv/hardy uptodate 1:2.1.7-1
xserver-xorg-video-s3virge/hardy uptodate 1:1.9.1-7
xserver-xorg-video-tga/hardy uptodate 1:1.1.0-9ubuntu1
xserver-xorg-video-ark/hardy uptodate 1:0.6.0-9
xserver-xorg-video-i128/hardy uptodate 1:1.2.1-4
xserver-xorg-input-mouse/hardy uptodate 1:1.2.3-2
xserver-xorg-video-via/hardy uptodate 1:0.2.2-5
xserver-xorg-video-tdfx/hardy uptodate 1:1.3.0-6
xserver-xorg-video-apm/hardy uptodate 1:1.1.1-10
xserver-xorg-video-psb/hardy uptodate 0.2.1-1ubuntu3
xser...

Read more...

Ship (shizuu) wrote :

Hi I have the same issue in debian sid, when I run WoW under compiz, sometimes the 'z' key sticks (azerty keyboard), and I must restart X to solve the problem.

But the problem doesn't appear when I don't run compiz, so I think it's raher a compiz bug than a xorg bug.

Are you guys running compiz too ?

$ uname -a
Linux debian 2.6.24-1-486 #1 Mon Feb 11 13:52:45 UTC 2008 i686 GNU/Linux
$ lspci | grep VGA
05:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7900 GT/GTO] (rev a1)
$ dpkg -l | grep xorg
ii xorg 1:7.3+10 X.Org X Window System
ii xorg-docs 1:1.4-2 Miscellaneous documentation for the X.Org software suite
ii xserver-xorg 1:7.3+10 the X.Org X server
ii xserver-xorg-core 2:1.4.1~git20080131-1 Xorg X server - core server
ii xserver-xorg-input-all 1:7.3+10 the X.Org X server -- input driver metapackage
ii xserver-xorg-input-evdev 1:1.2.0-1 X.Org X server -- evdev input driver
ii xserver-xorg-input-kbd 1:1.2.2-3 X.Org X server -- keyboard input driver
ii xserver-xorg-input-mouse 1:1.2.3-2 X.Org X server -- mouse input driver
ii xserver-xorg-input-synaptics 0.14.7~git20070706-2 Synaptics TouchPad driver for X.Org/XFree86 server
ii xserver-xorg-input-wacom 0.7.9.3-2 X.Org X server -- Wacom input driver
ii xserver-xorg-video-nv 1:2.1.7-1 X.Org X server -- NV display driver
ii xserver-xorg-video-vesa 1:1.3.0-4 X.Org X server -- VESA display driver
ii xserver-xorg-video-vga 1:4.1.0-8 X.Org X server -- VGA display driver
ii xserver-xorg-video-via 1:0.2.2-5 X.Org X server -- VIA display driver
$ dpkg -l | grep compiz
ii compiz 0.6.3~git20071222.061ff159-1 OpenGL window and compositing manager
ii compiz-core 0.6.3~git20071222.061ff159-1 OpenGL window and compositing manager
ii compiz-fusion-plugins-main 0.6.0-5 Compiz Fusion plugins - main collection
ii compiz-gnome 0.6.3~git20071222.061ff159-1 OpenGL window and compositing manager - GNOME window decorator
ii compiz-gtk 0.6.3~git20071222.061ff159-1 OpenGL window and compositing manager - Gtk window decorator
ii compiz-plugins 0.6.3~git20071222.061ff159-1 OpenGL window and compositing manager - plugins
ii compizconfig-settings-manager 0.6.0-4 Compizconfig Settings Manager
ii libcompizconfig0 0.6.0-3 Configuration settings library for compiz-fusion
ii python-compizconfig 0.6.0.1-2 Compizconfig bindings for python

James Andrewartha (trs80) wrote :

Nope, I'm running sawfish.

elegos (elegos) wrote :

I'll try running without compiz and I'll post the result here ^^

elegos (elegos) wrote :

confirmed: it's a Compiz (and in any case a Windows Manager) problem, without it enabled the 'sticked bug' has gone away.

Bryan Haskins (bryan-h) on 2008-02-19
Changed in compiz:
status: New → Confirmed
Zardoz (mrcleansambassador) wrote :

Also having the sticking keys problem with 7.10 Ubuntu & Xubuntu. Occasionally will happen at the login screen (before much of anything is loaded) on a fresh boot. Makes typing username/pass a real chore. My problem might be slightly different: while typing keyboard output will pause then repeat a key many times (20+). This can be any key including backspace or combo like ctrl+w which will close all my tabs in firefox. A quick fix is to disable sticky keys -- symptom here is a pause while typing then a fast burst of correct keybord output.

PS2 keyboard, mouse. ~2GHz P4, 512mb, integrated graphics.

David Hamm (davidthamm) wrote :

Confirmed. Having sticky key, always "w" after playing css in wine as well as perfect world also in wine, problem happens after playing for a few seconds. Have the same problem using different keyboards. After exiting wine problem persists until reboot.

Changed in compiz:
status: Confirmed → Invalid
Hew McLachlan (hew) wrote :

Also confirming this is a Compiz issue. Played Guild Wars with Wine for quite some time with different configurations, trying to reproduce this issue. Whenever Compiz was enabled, the 'w' key would become stuck within 10 seconds of playing an arena match. I played for a few hours with Compiz disabled and did not experience the issue. I did not encounter this on my Gutsy install that I used a month or two ago. Only way of stopping the repeating 'w' is alt-sysrq-k or a hard reset (ctrl-alt-del and ctrl-alt-bksp do nothing). I have not seen this issue outside of Wine, but as noted by others, it continues after exiting Wine. This issue seems to be easily reproducible for me, so I can perform extra testing if needed.

$ uname -a
Linux hardy6 2.6.24-12-generic #1 SMP Wed Mar 12 22:31:43 UTC 2008 x86_64 GNU/Linux
$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1)
$ apt-show-versions | grep -i compiz
compiz-gnome/hardy uptodate 1:0.7.2-0ubuntu2
python-compizconfig/hardy uptodate 0.7.2-0ubuntu1
compizconfig-settings-manager/hardy uptodate 0.7.2-0ubuntu1
compiz-plugins/hardy uptodate 1:0.7.2-0ubuntu2
compiz-fusion-plugins-extra/hardy uptodate 0.7.2-0ubuntu1
libcompizconfig0/hardy uptodate 0.7.2-0ubuntu1
compiz-fusion-plugins-main/hardy uptodate 0.7.2-0ubuntu1
compizconfig-backend-gconf/hardy uptodate 0.7.2-0ubuntu1
compiz-core/hardy uptodate 1:0.7.2-0ubuntu2
compiz/hardy uptodate 1:0.7.2-0ubuntu2

I have the same issue but I don't use compiz. I'm under fluxbox... I can reproduce the bug very easy with wine but also with other OpenGL applications, for example sauerbraten (it takes something like 5 min to appears), and then, as it says, need a restart of X to solve the problem.

Bryan Haskins (bryan-h) wrote :

This is *not* a duplicate. the issue is at least similar. the other user experiences sticking that goes away. I've had sticking continue through a several hour session of regular use. At any rate this bug was filed before it (note the bug id), and therefore impossible to be a duplicate.

Furthermore, this should not have been marked invalid for compiz. Compiz is the only WM in which this issue occurs, be it another 3D WM, or basic.

I cannot verify with all certainty it is a compiz issue, but likewise can no one disprove it yet.

Bryan Haskins (bryan-h) wrote :

Duplicate status removed.

Bryan Haskins (bryan-h) wrote :

There is no proof thus far that this is not a Compiz issue. (See second to last comment of mine, second paragraph)

Changed in compiz:
status: Invalid → New
Changed in xorg:
status: New → Confirmed
Bryan Haskins (bryan-h) wrote :

And just to clarify, sorry for the multi-spam, had another thought, Thought this has been reported in WMs other than compiz, it has not yet been confirmed with all certainty. As soon as that happens, more than happy to invalidate that part of the issue.

Need some more input.

Fred (eldmannen+launchpad) wrote :

Check out bug #194214

Travis Watkins (amaranth) wrote :

It's not possible for compiz to be at fault if the problem doesn't go away when you exit/restart compiz.

Changed in xorg-server:
status: Confirmed → Invalid
Changed in xorg-server:
status: Unknown → Confirmed
Timo Aaltonen (tjaalton) wrote :

Even though you claimed that this is not a dupe, please test the latest xserver-xorg-core uploaded today. It has the patch which is on the linked upstream bug and reviewed by upstream.

Changed in xorg:
status: Confirmed → Invalid
Changed in xorg-server:
status: Confirmed → Incomplete
Bryan Haskins (bryan-h) on 2008-03-31
Changed in xorg-server:
status: Incomplete → Fix Released
Changed in compiz:
status: New → Invalid
Cruncher (ubuntu-wkresse) wrote :

For clarification, endlessly repeating key events that usually can only be stopped by killing the X server are considered bug #194214, for which there is a patch now.
Key events that stop by themselves after a few seconds relate to bug #124406 instead, which is still open.

DanST (cromola) wrote :

Thanks a lot, after I turned compiz off I'm able to play normally perfect world :)

Changed in xorg-server:
status: Confirmed → Invalid
Changed in xorg-server:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.