Screen flickering

Bug #1883534 reported by Jeremy Lapierre
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

To whom it may concern,

As stated I have screen flickerings (see lightning like flickering on photo attached for portrait screen, for horizontal screen I also have screen flickering on the upper part but hard to catch in a photo) on freshly installed Ubuntu 20.04 LTS.
I have tried this:

https://askubuntu.com/questions/1231441/ubuntu-screen-flickering

and this:

https://learnubuntumate.weebly.com/screen-tearing-on-intel-graphics.html

without success. I have also seen some other people mentioning screen flickering on ubuntu 20.04 here:

https://www.reddit.com/r/Ubuntu/comments/fvk536/anyone_else_noticing_window_flickering_on_ubuntu/

without solution.

I also know that it is very unlikely hardware problem because my screens were displaying well on archlinux. I think my graphic card info are already included in the report but just in case: Intel Corporation UHD Graphics 630. Might be intel driver problems ?
Could you help me on this please ?

Best regards,
Jeremy

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Mon Jun 15 15:05:27 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation UHD Graphics 630 (Desktop) [8086:3e92] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. UHD Graphics 630 (Desktop) [1043:8694]
InstallationDate: Installed on 2020-06-12 (2 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 046a:0023 Cherry GmbH Keyboard
 Bus 001 Device 003: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Lsusb-t:
 /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/10p, 5000M
 /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/16p, 480M
     |__ Port 9: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
     |__ Port 9: Dev 2, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
     |__ Port 10: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-37-generic root=UUID=81cee77a-b529-4dac-9834-dc6d5ab2dc16 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/11/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0615
dmi.board.asset.tag: Default string
dmi.board.name: PRIME Z370-P
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0615:bd04/11/2018:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnPRIMEZ370-P:rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Revision history for this message
Jeremy Lapierre (alchemist2401) wrote :
affects: ubuntu → xorg (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thanks for the bug report.

It appears the tearing issue with the 'modesetting' driver is bug 1853094.

And you might also be experiencing extra flicker when you are using the 'intel' driver, which is bug 1867668.

So it seems you have to choose one bug or the other right now, sorry :(

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Oh, actually there is a solution... Just choose 'Ubuntu on Wayland' on the login screen.

Revision history for this message
Jeremy Lapierre (alchemist2401) wrote :

Dear Mr Daniel Van Vugt,

Choosing 'ubuntu on Wayland' in logging screen fixed the flickerings, thanks a lot !

Best,
Jeremy

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Revision history for this message
j2innet (j2innet) wrote :

ubuntu 18.04 on NUC intel graphic card

initially no problem
i was enabling vnc and it still ok
at some point i can't remember which component start to have this flicking appear in Chrome
i tried numerous solution from internet couldn't get rid of this flicking until this
disable "Use hardware acceleration when available" in chrome

just my 2 cents report

Revision history for this message
Jorge Herrera (jeherreracm) wrote :

I have de same problem, I change to star ubuntu wayland, but in different moments, ubuntu again present the same problem, this occurs when update the ubuntu because never see this problem the last year in my laptop. Where is the Answer to resolve this problem, I have intel graphic..

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Jorge,

Wayland should never have such problems. If it does then you should open a NEW bug by running:

  ubuntu-bug xorg

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers