Ubuntu

[Feisty,Gutsy] Switching to tty yields black screen (SiliconMotion)

Reported by K.Mandla on 2007-12-20
2
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I know this is particularly old and particularly unusual hardware, but on a Sotec e-Note 100 notebook (K6-2) with a SiliconMotion SM712 LynxEM+ video card, jumping from the X environment to any tty screen yields a black screen.

The tty is still active, and I can type commands into the terminal, but there is no video output. Pressing CTRL+ALT+F7 returns me to the X environment with no visible error. Exiting X with CTRL+ALT+Backspace yields the same dead screen, but restarting X (with startx again) will not bring back a visible GUI.

The X environment functions normally before and after switching between tty screens, with video colors, dimensions, depth and mouse control all as expected.

This bug occurs on a default system in both Gutsy and Feisty, command-line-plus-X or a full Gnome environment. Both the siliconmotion and vesa drivers give the same results. Other distros behave normally, with both the 1.4.1 and 1.5.1 siliconmotion drivers and other versions of X.

There seem to be other bugs that are similar, but not with this hardware.

From lspci -nn | grep VGA ...

01:00.0 VGA compatible controller [0300]: Silicon Motion, Inc. SM712 LynxEM+ [126f:0712] (rev a0)

Thanks in advance

K.Mandla (k.mandla) wrote :
K.Mandla (k.mandla) wrote :
K.Mandla (k.mandla) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers