keyboard selection (dvorak) not preserved after install in hardy

Bug #173008 reported by Steve Langasek on 2007-11-30
22
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

after selecting US. English Dvorak as my keyboard setting during install of hardy alpha1 (Ubuntu amd64), my keyboard map is in Dvorak as expected; but post-install, the keyboard map has reverted to qwerty.

Evan (ev) on 2007-11-30
Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
Evan (ev) wrote :

Confirmed. Reproduced in both 1.6.8 and 1.7.1.

Odd though. The version of ubiquity in alpha 1 is the same as the one in 7.10, meaning it's using the same d-i components, yet I (fortunately) cannot reproduce this in 7.10.

Colin Watson (cjwatson) wrote :

Steve, do you get the right keyboard map at the console? Could you attach /etc/default/console-setup and /etc/X11/xorg.conf?

Evan (ev) wrote :

I looked at this again based on Colin's suggestions. /etc/default/console-setup correctly has XKBVARIANT="dvorak", but /etc/X11/xorg.conf doesn't exist. Reassigning to xorg.

Timo Aaltonen (tjaalton) wrote :

This should be fixed in alpha2. Dexconf tried to use a debconf setting that was not set anymore, and it failed to write xorg.conf due to that.

Changed in xorg:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers