Comment 0 for bug 1724307

This may be a duplicate of https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1278223. In order to provide more information, there was a request to open another bug and attach the relevant info to it.

OS: Ubuntu 16.04 x64
Kernel: 4.10.0-37-generic
X.Org X Server: 1:7.7+13ubuntu3 (v1.19.3)

Monitor 1: 1920 x 1080 - Laptop's Native Monitor
Monitor 2: 1920 x 1080 - DisplayLink (USB) connected AOC E2775SJ Monitor

Using DisplayLink driver v1.4 (latest as of today), the mouse screen flickers on refresh both on the external as well as on the native monitor, and it seems worse on the laptop's monitor than on the external one, going as far as vanishing for several minutes (pointer still being active as I can see icons being highlighted, etc. but no mouse pointer being drawn). Usage of Google Chrome seems to aggravate the issue, although it's not gone otherwise.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-37.41~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-37-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Oct 17 10:01:55 2017
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Device [8086:5917] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:082a]
InstallationDate: Installed on 2017-10-16 (0 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
MachineType: Dell Inc. XPS 13 9360
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-37-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/18/2017
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.2.1
dmi.board.name: 05FPM2
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.2.1:bd08/18/2017:svnDellInc.:pnXPS139360:pvr:rvnDellInc.:rn05FPM2:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: XPS 13 9360
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.76-1~ubuntu16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.7-0ubuntu0.16.04.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.7-0ubuntu0.16.04.2
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Tue Oct 17 09:39:15 2017
xserver.configfile: default
xserver.errors: modeset(G0): glamor initialization failed
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 5193
 vendor SHP
xserver.version: 2:1.19.3-1ubuntu1~16.04.3