Multi monitor config issues

Bug #1717474 reported by lswn on 2017-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Since wayland will be the default with 17.10 it might be important to have it ready for multiple monitor support. I have the latest updates installed and I am on the artful channel.

SETUP:
HiDPI internal screen running at 2160x1440 (Surface Pro 3)
External FullHD HDMI monitor running at 1920x1080
Since the upgrade to the latest GNOME 3.26, wayland got activated again. I was running X before.
Usually, I set my internal screen off and only work with the external monitor if plugged in.

ISSUE:
With wayland active for both GDM and GNOME there is actually two issues:

1. I am able to configure my desired settings in the display settings as usual (=turn off internal screen and use only external monitor). But since the latest update this setting is not remembered after a new login. It can only remember the "mirror" or "join displays" options but not the "single display" option. Very annoying to reconfigure this after every login.

Before the update to the new GNOME settings look I was at least able to have this setting remembered (even with wayland). However, even back then it was not perfect since the internal screen was not completely turned off (black but with light on). After manually setting the displays again the screen was turned off but not after a login. This is a wayland related issue since it is not reproducable with X.

2. GDM is always on the internal screen and simply does not match and respect your GNOME config. I tried several ways to configure this:

sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config - does not work since wayland ignores this config file.

I tried to using shell scripts executed at startup with xrandr. But xrandr does not work with wayland, too. So this is also not a solution.

FIX:
I don't know how to configure GDM with wayland. I am willing to test things out but have no further ideas and am relatively new to Linux/Ubuntu. Thanks for any help.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xorg 1:7.7+19ubuntu2
ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
Uname: Linux 4.12.0-13-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 15 10:57:43 2017
DistUpgraded: Fresh install
DistroCodename: artful
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA controller])
   Subsystem: Microsoft Corporation Haswell-ULT Integrated Graphics Controller [1414:0005]
InstallationDate: Installed on 2017-08-24 (21 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170823)
MachineType: Microsoft Corporation Surface Pro 3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.12.0-13-generic.efi.signed root=UUID=f348de47-cb83-4d73-8de3-bdd738092165 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/26/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3.11.2150
dmi.board.asset.tag: 0
dmi.board.name: Surface Pro 3
dmi.board.vendor: Microsoft Corporation
dmi.board.version: 1
dmi.chassis.asset.tag: 0
dmi.chassis.type: 9
dmi.chassis.vendor: Microsoft Corporation
dmi.chassis.version: 1
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3.11.2150:bd04/26/2017:svnMicrosoftCorporation:pnSurfacePro3:pvr1:rvnMicrosoftCorporation:rnSurfacePro3:rvr1:cvnMicrosoftCorporation:ct9:cvr1:
dmi.product.family: Surface
dmi.product.name: Surface Pro 3
dmi.product.version: 1
dmi.sys.vendor: Microsoft Corporation
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.82-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.0-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.3-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.9.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

lswn (lswn) wrote :
tags: added: multimonitor
affects: wayland (Ubuntu) → gnome-shell (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Daniel van Vugt (vanvugt) wrote :

Thanks for the bug report. Please try to keep each bug about one issue only...

Your first issue is being discussed in bug 1726538 also. So let's make this a duplicate of that.

The second issue is probably bug 1723025 (?). Please comment in that one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers