Graphics Corruption on Hardware Accelerated Softwares

Bug #1687352 reported by Victor Barcelos Lacerda on 2017-05-01
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)

Bug Description

Applications like Blender (downloaded from blender website for linux) and SimCity 4 (running through Wine with Hardware Acceleration enabled) have their windows graphics corrupted as saw in the attachment's print screen image (Blender).
Maybe this problem is OpenGL related, it's just a guess.
It didn't occur on Ubuntu 16.10 Yakkety Yak.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: xorg 1:7.7+16ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-20.22-generic 4.10.8
Uname: Linux 4.10.0-20-generic x86_64

ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: XFCE
Date: Sun Apr 30 23:43:40 2017
DistUpgraded: Fresh install
DistroCodename: zesty
DistroVariant: ubuntu
ExtraDebuggingInterest: No
 Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6290] [1002:9807] (prog-if 00 [VGA controller])
   Subsystem: Elitegroup Computer Systems Wrestler [Radeon HD 6290] [1019:3141]
InstallationDate: Installed on 2017-01-14 (106 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-20-generic root=UUID=2db4e4b3-e99a-4d11-96af-5d10de0134c4 ro rootflags=sync splash
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install) 04/09/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.4 HDC-M
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.4:bd04/09/2012:svn:pnHDC-M:pvr1.0:rvn:rnHDC-M:rvr1.0:cvn:ct3:cvr1.0: HDC-M
dmi.product.version: 1.0
version.compiz: compiz 1:
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.76-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.3-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.3-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.3-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.9.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.14-0ubuntu1
xserver.bootTime: Sun Apr 30 23:33:33 2017
xserver.configfile: default

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.3-1ubuntu1
xserver.video_driver: radeon

description: updated
dino99 (9d9) wrote :
Changed in xorg (Ubuntu):
status: New → Invalid
To post a comment you must log in.