kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B

Bug #1660619 reported by Alessandro Polverini on 2017-01-31
104
This bug affects 21 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

I've a dual monitor setup and I'm running latest version of kubuntu.

After a few days of uptime the desktop becomes so slow that I've to reboot it.

In the log I find those errors, I don't know if they are related:

kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B (start=150051 end=150052) time 110 us, min 1073, max 1079, scanline start 1072, end 1080

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: xorg 1:7.7+13ubuntu4
ProcVersionSignature: Ubuntu 4.8.0-34.36-generic 4.8.11
Uname: Linux 4.8.0-34-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Tue Jan 31 14:06:17 2017
DistUpgraded: 2016-10-16 19:45:53,200 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: yakkety
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.8.0-30-generic, x86_64: installed
 bbswitch, 0.8, 4.8.0-32-generic, x86_64: installed
 bbswitch, 0.8, 4.8.0-34-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. [MSI] HD Graphics 530 [1462:7978]
InstallationDate: Installed on 2013-04-25 (1376 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
LightdmGreeterLogOld:
 QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
 QFileSystemWatcher: failed to add paths: /var/lib/lightdm/.config/ibus/bus
 Bus::open: Can not get ibus-daemon's address.
 IBusInputContext::createInputContext: no connection to ibus-daemon
 file:///usr/share/kde4/apps/lightdm-kde-greeter/themes/userbar/main.qml:135: Unable to assign [undefined] to QString usersession
MachineType: MSI MS-7978
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-34-generic root=UUID=f848f2e6-9d53-4c75-823a-fa97cfe10aa6 ro
SourcePackage: xorg
UpgradeStatus: Upgraded to yakkety on 2016-10-16 (106 days ago)
dmi.bios.date: 05/16/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: A.60
dmi.board.asset.tag: Default string
dmi.board.name: Z170A GAMING M3 (MS-7978)
dmi.board.vendor: MSI
dmi.board.version: 2.0
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 2.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrA.60:bd05/16/2016:svnMSI:pnMS-7978:pvr2.0:rvnMSI:rnZ170AGAMINGM3(MS-7978):rvr2.0:cvnMSI:ct3:cvr2.0:
dmi.product.name: MS-7978
dmi.product.version: 2.0
dmi.sys.vendor: MSI
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.3-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.3-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu6.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2
xserver.bootTime: Sat Jan 28 11:57:37 2017
xserver.configfile: default
xserver.errors:
 Failed to load module "fbdev" (module does not exist, 0)
 Failed to load module "vesa" (module does not exist, 0)
 Failed to load module "fbdev" (module does not exist, 0)
 Failed to load module "vesa" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.4-1ubuntu6.1
xserver.video_driver: modeset

Alessandro Polverini (polve) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Konrad Hofer (konrad.hofer) wrote :

I saw this today on my Lenovo T400. Ubuntu 16.04.1 LTS, running 4.4.0-62-generic x86_64

llewellyn709 (llewellyn709-u) wrote :

Same Bug on my Precision M2800, 4.8.0-41-generic, Ubuntu 16.10
My mate-Desktop froze randomly and I have to cold reboot it.

PabloAB (pabloab777) wrote :

Today on Asus UX303UB Ubuntu 16.04.2 LTS, running 4.4.0-66-generic x86_64

pauljohn32 (pauljohn) wrote :

Are we sure that the pipeline error is a separate cause of a freeze up? I've had a lot of freezes in Ubuntu 17.04 and the freeze has only once been accompanied by the pipeline update.

In my kernel logs, the pipeline appears once, but all seem to have the kernel BUG swapops.h, ( after --[cut here]--).

Apr 24 11:12:04 delllap-16 kernel: [ 7772.857813] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe C (start=254554 end=254555) time 189 us, min 1192, max 1199, scanline start 1188, end 1202
Apr 24 11:44:42 delllap-16 kernel: [ 9730.945494] ------------[ cut here ]------------
Apr 24 11:44:42 delllap-16 kernel: [ 9730.945521] kernel BUG at /build/linux-Fk60NP/linux-4.10.0/include/linux/swapops.h:129!
Apr 24 11:44:42 delllap-16 kernel: [ 9730.945551] invalid opcode: 0000 [#1] SMP

There is a separate bug report about the other one, that has had a lot of activity today:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1674838

netikras (netikras) wrote :

I'll spill some gasoline on this fire.

I've been suffering from laptop (dell xps 13 w/ skylake) freezes after it shuts down the screen due to inactivity. I call that frezes because when it happens there is no way to wake the screen up. SSH is down. ctrl-alt-f1 and bling-typing is not working. suspend button is not responding. s2ram command is ignorant too. And since I do not have a screen (a laptop, remember?) I try all these things blindly.

So the laptop basically stops responding. Each time (3-5 occurences this year) post mortem analysis reveals that one of last syslog entries is:

syslog.1:9316:Sep 20 20:51:56 netikras-xps kernel: [477714.359255] [drm:intel_pipe_update_end [i915_bpo]] *ERROR* Atomic update failure on pipe A (start=330999 end=331000) time 147 us, min 1788, max 1799, scanline start 1785, end 1801

As you see from the log attached this error occurs rather often. Maybe it's a coincidence, maybe it's not. But I have surely noticed that this error is always one of the last syslog records ante mortem.

Ping me if anyone needs any more details, I'm subscribing to this thread

netikras (netikras) wrote :

BTW I'm on Mint Sarah

Rustin Schenk (rmschenk) wrote :

I have an HP laptop and have been seeing these errors for many months:

Sep 29 11:33:51 hp-17 kernel: [ 7857.337291] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=113116 end=113117) time 484 us, min 894, max 899, scanline start 891, end 918
Sep 29 11:34:42 hp-17 kernel: [ 7908.344925] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=116180 end=116181) time 647 us, min 894, max 899, scanline start 873, end 873
Sep 29 11:36:45 hp-17 kernel: [ 8030.836446] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=123538 end=123539) time 662 us, min 894, max 899, scanline start 886, end 923

They haven't seemed to cause any problems until yesterday when my system frozen up. Couldn't do anything on the system and had to reboot. The above errors were the last thing shown in the system log before I rebooted. The errors were repeating at about 10 times a minute over the course of an hour before the system locked up. I am also seeing this error between the Atomic update failures (maybe unrelated or not):

Sep 28 12:56:38 hp-17 org.gnome.SettingsDaemon.MediaKeys.desktop[3088]: Memory pressure relief: Total: res = 8822784/8876032/53248, res+swap = 0/0/0
Sep 28 13:25:10 hp-17 org.gnome.SettingsDaemon.MediaKeys.desktop[3088]: Memory pressure relief: Total: res = 2236416/2293760/57344, res+swap = 0/0/0

D-nl-k (d-nl-k) wrote :

Got this error, too. 2 year anniversary is near and nobody seems to care. The best would be to move away from this Intel Graphics crap.

I'm also seeing this quite frequently on Dell Precision 5520 running Ubuntu 17.10 with Wayland:

[85710.937972] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=15608 end=15609) time 761 us, min 1073, max 1079, scanline start 1035, end 1086
[87385.139517] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=115949 end=115950) time 14743 us, min 1073, max 1079, scanline start 421, end 292

When it happens, screen very often freezes for a bit.

jeffbl (jeff-mulb) wrote :

I'm seeing this regularly as well. Often I am doing something with video or audio. This last time, I launched an mp3 in VLC, and the screen immediately froze. The audio kept playing. About 15 minutes later, when the mp3 ended, the screen immediately unfroze and everything seemed fine.

[155642.708062] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=5294256 end=5294257) time 155 us, min 2146, max 2159, scanline start 2143, end 2164

Ubuntu 17.10
Lenovo Thinkpad x260
Linux ... 4.13.0-21-generic #24-Ubuntu SMP Mon Dec 18 17:29:16 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

It has been happening once every 2 days or so, but has on occasion occurred multiple times on the same day. Often, I can't wait to see if it will come back, and sometimes it never does, so I have to reboot. This is brutal for things like presentations, having no idea if the machine will suddenly just freeze.

ybdjkfd (ybdjkfd) wrote :

I apologize for not being specific enough. I found a fix for this on my machine, but I am unsure what options you may need that I have gathered together to get things to work but found that I had missed replying to this bug. I can post material more in depth as needed. Some of these options helped me with other fixes for bbswitch. There are many options for grub2 below, but mostly I wanted to mention the i915 material that helps this bug.

I currently running:
* Linux 4.13.0-32-generic x86_64 GNU/Linux
* An MSI laptop with Intel HD Graphics 530 (Nvidia modules blacklisted so bbswitch can load them as needed)

Added the following in my /etc/default/grub helping with this bug and disabling Nvidia until bbswtich loads it ; note that 'acpi_osi' items may not be useful on your system so search that part up as needed; note the '{your version #}' meaning the package you have installed such as nvidia-384 or nvidia-387:
GRUB_CMDLINE_LINUX="nogpumanager modprobe.blacklist=nouveau,nvidiafb,nvidia-modeset,nvidia-uvm,nvidia,nvidia-{your version #} acpi_osi=! acpi_osi=\"Windows 2009\" intel_iommu=igfx_off i915.semaphores=1 i915.enable_fbc=0 i915.modeset=1 i915.enable_rc=7 i915.enable_dc=2 i915.enable_ppgtt=3 i915.enable_guc_loading=1 i915.lvds_channel_mode=2 i915.lvds_use_ssc=1"

Added the following to /etc/modules :
i915
bbswitch load_state=0

Finally, ran the following manually to make sure things got updated:
sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo grub-mkconfig -o /boot/efi/EFI/ubuntu/grub.cfg
sudo update-initramfs -u -k all
sudo update-grub2

dino99 (9d9) wrote :

This is an unsupported release now. Please think to install the next LTS 'Bionic 18.04'

http://cdimage.ubuntu.com/ubuntu-next/daily-live/current/
https://www.omgubuntu.co.uk/2018/02/ubuntu-18-04-minimal-install-option

Changed in xorg (Ubuntu):
status: Confirmed → Invalid
Berat Postalci (beratpostalci) wrote :

I have this error and arbitrary freezes on the system

My System:

Hardware:
Processor: Intel Core i7-8750H @ 4.10GHz (12 Cores), Motherboard: Dell 0M2MWX, Chipset: Intel Device a36f, Memory: 16384MB, Disk: 1000GB Seagate ST1000LM035-1RK1 + 256GB TOSHIBA KSG60ZMV, Graphics: Intel Device 3e9b, Audio: Realtek ALC3246, Monitor: DELL P2016, Network: Qualcomm Atheros Killer E2400 Gigabit + Intel Device a370

Software:
OS: Ubuntu 18.04, Kernel: 4.15.0-39-generic (x86_64), Desktop: Xfce 4.12, Display Driver: modesetting 1.19.6, OpenGL: 4.5 Mesa 18.0.5, File-System: ext4, Screen Resolution: 1920x1980

dmesg output:

[ 2027.018608] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B (start=15726 end=15727) time 1024 us, min 894, max 899, scanline sta
rt 845, end 903
[ 2534.448063] ACPI Error: [LCD_] Namespace lookup failure, AE_NOT_FOUND (20170831/psargs-364)
[ 2534.448071] No Local Variables are initialized for Method [BRT6]
[ 2534.448072] Initialized Arguments for Method [BRT6]: (2 arguments defined for method invocation)
[ 2534.448073] Arg0: 00000000a83faa08 <Obj> Integer 0000000000000001
[ 2534.448076] Arg1: 0000000035246c42 <Obj> Integer 0000000000000000
[ 2534.448079] ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.PEGP.BRT6, AE_NOT_FOUND (20170831/psparse-550)
[ 2534.448145] ACPI Error: Method parse/execution failed \EV5, AE_NOT_FOUND (20170831/psparse-550)
[ 2534.448206] ACPI Error: Method parse/execution failed \SMEE, AE_NOT_FOUND (20170831/psparse-550)
[ 2534.448268] ACPI Error: Method parse/execution failed \SMIE, AE_NOT_FOUND (20170831/psparse-550)
[ 2534.448332] ACPI Error: Method parse/execution failed \NEVT, AE_NOT_FOUND (20170831/psparse-550)
[ 2534.448394] ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.ECDV._Q66, AE_NOT_FOUND (20170831/psparse-550)

Llord Llama (llamalord) wrote :

I'm getting this error message and arbitary freezes on my system *with Kubuntu 18.10 (the current version) installed*.

Given that this bug is still happening across the three latest versions of (K)Ubuntu, can this bug be marked valid again, so people with this problem on the current versino of Ubuntu aren't discouraged from adding their info here?

Llord Llama (llamalord) wrote :

Just tried the grub commandline fix from #14... My laptop lasted 17 minutes before hanging with the same error. :/

Llord Llama (llamalord) wrote :

Xorg: 1:7.7+19ubuntu8
Kernel: 4.18.0.13.14
Video card: 00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

Llord Llama (llamalord) wrote :

For anyone else still experiencing this, I've opened up a new bug for the current version of Ubuntu at:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1813423

If this bug still affects you, please go and click "This bug affects me", too over at the bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers