Ubuntu

X doesn't start on Samsung Q1 Ultra

Reported by Loïc Minier on 2007-11-19
2
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Unknown
xorg (Ubuntu)
High
Unassigned

Bug Description

Hi,

I'm started generating USB images for UME against hardy, and the X server doesn't start on boot anymore. xinit stuff doesn't start manually either.
"Xorg" starts when launched as root (but of course not as "ume"), "X" doesn't change the video mode and returns silently with exit code 0, startx and xinit will fail with:
xinit: Server error.

I have no clue on which change introduces this breakage; I plan stracing two "startx" on gutsy and hardy and comparing, but I'm taking any hint.

Bye,

Loïc Minier (lool) wrote :

/etc/X11/X is a symlink to /bin/true for some reason...

Loïc Minier (lool) wrote :

Reassigning to xserver-xorg-core: on a fresh install, xserver-xorg will create /etc/X11/X as a dummy symlink to /bin/true; when installing xserver-xorg-core, this symlink should be updated to point to Xorg.

Loïc Minier (lool) wrote :

Could be http://bugs.debian.org/451439 as this might have prevented the setup to complete appropriately, but it seems package installation completed without error. (The installation happens from within moblin-image-creator which presumably has no tty and sets the debconf frontend to non-interactive, so I'm not sure.)

Timo Aaltonen (tjaalton) wrote :

This is hopefully fixed already in Debian, so I'll merge the package to be sure. The bug is in xorg, not the server.

Changed in xorg-server:
status: New → In Progress
Timo Aaltonen (tjaalton) wrote :

I've sent a proposed fix to debian-x mailing list. The logic regarding the server symlink is currently broken.

Changed in xorg:
milestone: none → hardy-alpha-1
importance: Undecided → High
Loïc Minier (lool) wrote :

Timo, can you merge your fix with the one from Debian as uploaded in xorg 1:7.3+7?

Timo Aaltonen (tjaalton) wrote :

Loïc, what a coincidence, I already uploaded a new version :)

marking as fixed!

Changed in xorg:
status: In Progress → Fix Released
Changed in xorg-server:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.