Libre Office Writer Icons unreadability on YY and ZZ with Intel Drivers

Bug #1625595 reported by Marco Parillo on 2016-09-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Low
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

glxinfo | grep -i vendor
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: Intel Open Source Technology Center (0x8086)
OpenGL vendor string: Intel Open Source Technology Center

Marco Parillo (marco-parillo) wrote :
Marco Parillo (marco-parillo) wrote :

Note that this was not a problem on XX on the same HW, nor is it a problem on YY in a VMware VM on similar HW.

Marco Parillo (marco-parillo) wrote :

Note that the VMware drivers that seem to work are:
glxinfo | grep -i vendor
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: VMware, Inc. (0xffffffff)
OpenGL vendor string: VMware, Inc.

Marco Parillo, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:
apport-collect 1625595

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Marco Parillo (marco-parillo) wrote :

After installing, I get:
mparillo@mparillo-HP-EliteBook-8440p:~$ apport-collect 1625595
ERROR: Could not import module, is a package upgrade in progress? Error: No module named PyQt5.QtCore

Marco Parillo (marco-parillo) wrote :

I tried re-booting, and I still get the same message.

Marco Parillo (marco-parillo) wrote :

In case inxi helps:

mparillo@mparillo-HP-EliteBook-8440p:~$ inxi -F
System: Host: mparillo-HP-EliteBook-8440p Kernel: 4.8.0-11-generic x86_64 (64 bit)
           Desktop: KDE Plasma 5.7.5 Distro: Ubuntu 16.10
Machine: System: Hewlett-Packard (portable) product: HP EliteBook 8440p
           Mobo: Hewlett-Packard model: 172A v: KBC Version 30.30
           BIOS: Hewlett-Packard v: 68CCU Ver. F.0E date: 08/23/2010
Battery BAT0: charge: 37.4 Wh 99.1% condition: 37.8/51.0 Wh (74%)
CPU: Dual core Intel Core i7 M 620 (-HT-MCP-) cache: 4096 KB
           clock speeds: max: 2667 MHz 1: 1866 MHz 2: 1199 MHz 3: 1466 MHz 4: 1333 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.00hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 12.0.3
Audio: Card Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-11-generic
Network: Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: down mac: 68:b5:99:ec:1b:62
           Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
           IF: wlo1 state: up mac: 00:24:d7:64:f9:10
Drives: HDD Total Size: 250.1GB (5.0% used)
           ID-1: /dev/sda model: WDC_WD2500BEKT size: 250.1GB
Partition: ID-1: / size: 109G used: 8.2G (8%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 4.07GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 46.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 194 Uptime: 2 min Memory: 614.9/3747.8MB
           Client: Shell (bash) inxi: 2.3.1

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1625595

tags: added: iso-testing

Marco Parillo, please boot into http://cdimage.ubuntu.com/daily-live/current/ and then run the command.

Marco Parillo (marco-parillo) wrote :
Download full text (9.0 KiB)

Same response from the Live ISO (Beta2 Release Candidate):

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

kubuntu@kubuntu:~$ apport-collect 1625595
You need to run 'sudo apt-get install python-apport' for apport-collect to work.
kubuntu@kubuntu:~$ sudo apt install python-apport -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  python-apt python-cffi-backend python-cryptography python-enum34 python-httplib2
  python-idna python-ipaddress python-keyring python-keyrings.alt python-launchpadlib
  python-lazr.restfulclient python-lazr.uri python-oauth python-pkg-resources
  python-problem-report python-pyasn1 python-secretstorage python-setuptools
  python-simplejson python-six python-wadllib python-zope.interface
Suggested packages:
  python-apt-dbg python-apt-doc python-cryptography-doc python-cryptography-vectors
  python-enum34-doc gnome-keyring gir1.2-gnomekeyring-1.0 python-fs python-gdata
  python-kde4 python-keyczar python-testresources doc-base python-secretstorage-doc
  python-setuptools-doc
The following NEW packages will be installed:
  python-apport python-apt python-cffi-backend python-cryptography python-enum34
  python-httplib2 python-idna python-ipaddress python-keyring python-keyrings.alt
  python-launchpadlib python-lazr.restfulclient python-lazr.uri python-oauth
  python-pkg-resources python-problem-report python-pyasn1 python-secretstorage
  python-setuptools python-simplejson python-six python-wadllib python-zope.interface
0 upgraded, 23 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,302 kB of archives.
After this operation, 7,095 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-apt amd64 1.1.0~beta5 [142 kB]
Get:2 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-problem-report all 2.20.3-0ubuntu7 [9,638 B]
Get:3 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-httplib2 all 0.9.1+dfsg-1 [34.2 kB]
Get:4 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-keyring all 9.1-1 [28.9 kB]
Get:5 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-pkg-resources all 25.2.0-1ubuntu1 [109 kB]
Get:6 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-lazr.uri all 1.0.3-2build1 [13.6 kB]
Get:7 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-simplejson amd64 3.8.2-2 [60.1 kB]
Get:8 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-wadllib all 1.3.2-3 [28.2 kB]
Get:9 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-zope.interface amd64 4.2.0-2 [80.6 kB]
Get:10 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-oauth all 1.0.1-5 [12.9 kB]
Get:11 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-lazr.restfulclient all 0.13.4-6 [50.8 kB]
Get:12 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-launchpadlib all 1.10.4-1 [45.7 kB]
Get:13 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-apport all 2.20.3-0ubuntu7 [79.2 kB]
Get:14 http://archive.ubuntu.com/ubuntu yakkety/main amd64 python-cffi-backend amd64 ...

Read more...

Marco Parillo, regarding apport not working as expected, please file a new report via https://launchpad.net/apport/+filebug , and feel free to subscribe me to it.

Changed in libreoffice (Ubuntu):
status: Incomplete → New
Marco Parillo (marco-parillo) wrote :

Thank you very much. I was not able to subscribe you to https://bugs.launchpad.net/apport/+bug/1627790

Perhaps because you are not on my team?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
buzzmandt (buzzmandt) wrote :

same problem here, actually on 2 of my computers
but can only file once i'd reckon so here's one of them

buzzmandt (buzzmandt) wrote :

found a work around. I removed libreoffice-kde and install libreoffice-gtk (which will also install libreoffice-gtk2). Launch libreoffice as normal and the icons and menus are working properly. I then uninstalled libreoffice-gtk and libreoffice-gtk2 and reinstalled libreoffice-kde which reproduced the problem in this bug report. Seems only libreoffice-kde is at fault.

hope this helps and let me know if i can try anything else.

Marco Parillo, getting back to https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1625595/comments/10 I had asked you to run apport-collect with http://cdimage.ubuntu.com/daily-live/current/ not Kubuntu daily. Could you please advise?

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
Marco Parillo (marco-parillo) wrote :

ubuntu@ubuntu:~$ apport-collect 1625595
/usr/share/apport/apport-gtk:16: PyGIWarning: Wnck was imported without specifying a version first. Use gi.require_version('Wnck', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GLib, Wnck, GdkX11, Gdk
The authorization page:
 (https://launchpad.net/+authorize-token?oauth_token=KLpv7KHp0gXs4jHdHbJ7&allow_permission=DESKTOP_INTEGRATION)
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.
Waiting to hear from Launchpad about your decision...
Package libreoffice not installed and no hook available, ignoring
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
ubuntu@ubuntu:~$

Marco Parillo (marco-parillo) wrote :

Then a dialog box pops up saying "No additional information collected".

Marco Parillo, thanks for that. Looks like yet another distinct issue with apport?!

It wouldn't hurt to try a earlier supported version of Ubuntu (not Kubuntu) via http://releases.ubuntu.com/ to see if we can get something out of it. Just make sure you have the xdiagnose package installed, and click yes for additional information.

affects: libreoffice (Ubuntu) → xorg (Ubuntu)
tags: added: kubuntu
Marco Parillo (marco-parillo) wrote :

Changing the title of the bug report as Libre Office Calc icons are readable, and tested on ZZ also.

summary: - Libre Office Icons unreadability on YY with Intel Drivers
+ Libre Office Writer Icons unreadability on YY with Intel Drivers
summary: - Libre Office Writer Icons unreadability on YY with Intel Drivers
+ Libre Office Writer Icons unreadability on YY and ZZ with Intel Drivers
Marco Parillo (marco-parillo) wrote :

This may be resolved with Kubuntu ZZ Beta 1.

buzzmandt (buzzmandt) wrote :

I have tested this with my ZZ it now works properly, Fixed i think

Marco Parillo (marco-parillo) wrote :

Tested and resolved on both 32-bit and 64-bit Kubuntu ZZ Beta 1 Images

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Fix Released
Changed in xorg (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers