[PowerMac7,3] GPU compositors do not work

Bug #1575391 reported by ernsteiswuerfel on 2016-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Low
Unassigned

Bug Description

On Ubuntu MATE 16.04 one can select 4 compositing modes via MATE Tweak (german translation):
1. Marco (kein Komposit)
2. Marco (Programmkomposit)
3. Marco (Compton GPU-Komposit)
4. Compiz (anspruchsvolle Schreibtischeffekte mit GPU-Beschleunigung)

On my PowerMac7,3 G5 with a Radeon 9650 Pro only the 1st one works properly. The 2nd one works, but more sluggish and a jerkier mouse pointer. 3 and 4 trash the desktop showing wrong colours. Only VERY jerky mouse movement is possible then. The desktop is no longer in a usable state any longer, you can't click on anything. Restarting the desktop with "systemctl restart lightdm" from console returns the desktop usable (defaulting to 1st compositor.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-21.37-powerpc64-smp 4.4.6
Uname: Linux 4.4.0-21-powerpc64-smp ppc64
ApportVersion: 2.20.1-0ubuntu2
Architecture: powerpc
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Tue Apr 26 23:40:25 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] RV350 [Radeon 9550/9600/X1050 Series] [1002:4150] (prog-if 00 [VGA controller])
   Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] RV350 [Radeon 9550/9600/X1050 Series] [1002:4150]
InstallationDate: Installed on 2016-03-26 (31 days ago)
InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Beta powerpc (20160326)
ProcEnviron:
 LANGUAGE=de_AT:de
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=UUID=d6fab932-3e79-4f5c-a392-c86c01b5a8f9 ro rootflags=subvol=@ radeon.agpmode=-1
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Tue Apr 26 22:55:40 2016
xserver.configfile: /etc/X11/xorg.conf
xserver.devices:
 input Logitech G100s Optical Gaming Mouse MOUSE, id 6
 input HID 046a:010d KEYBOARD, id 7
 input HID 046a:010d KEYBOARD, id 8
 input PMU KEYBOARD, id 9
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.3-1ubuntu2
xserver.video_driver: radeon

ernsteiswuerfel (erhard-f) wrote :

ernsteiswuerfel, thank you for reporting this and helping make Ubuntu better.

1) To clarify, you have which mac precisely from the list in https://support.apple.com/en-us/HT201518 ?

2) Is there something missing when you choose 1 that you don't get from the other three?

Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
ernsteiswuerfel (erhard-f) wrote :

1) It is not on the list you linked. It is a http://identimac.com/modelDetails/PowerBook%20G4/4.html
Same problem on my PowerMac G5 (http://identimac.com/modelDetails/Power%20Mac%20G5/5.html) with a Radeon 9650 (http://www.welovemacs.com/atig59650.html).

2) I am missing a flicker and tearingfree desktop experience (e.g. browsing, watching videos, moving windows around). Well, of course it's a nice to have and no must. "Compton GPU composit" provides the best desktop experience, at least it does on my amd64 box with newer AMD graphics hardware.

ernsteiswuerfel, to advise, this report is focused on one model only (PowerMac G5). For additional machines, please file one report per machine, per issue.

To clarify my previous question, is there a positive feature from 2.-4. that isn't available in 1.?

summary: - GPU compositors do not work on r300-class Radeon cards on PPC hardware
+ [PowerMac7,3] GPU compositors do not work
description: updated
ernsteiswuerfel (erhard-f) wrote :

Yes, composting.

Means a more usable task switcher. And desktop/icon animations.

ernsteiswuerfel (erhard-f) wrote :

This is related to https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1432949

With the upstream patch applied on mesa GPU compositors started working on my PowerMac 7,3.

Changed in xorg (Ubuntu):
status: Incomplete → New
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1575391

tags: added: iso-testing
ernsteiswuerfel (erhard-f) wrote :

As of Yakkety's todays daily iso (24.07.2016) this bug is gone due to an update mesa-11.2.1 -> mesa-12.0.1.

Changed in xorg (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers