Ubuntu

ATI display update causes lines to form on screen in Firefox

Reported by UKThom on 2007-10-08
4
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Upon applying updates for ATI display drivers, my screen now produces vertical lines while browsing on Firefox. I have an older laptop, with the ATI Radeon Mobility M6 LY video display card (??). Not sure if it's Xgl that might be causing the issue, and I've also had a problem with Advanced Desktop, as well (crashing - already reported).

If you, pleasant bug fixer-person, need more information, please kindly tell me how to obtain it on my machine, and I will post it here ASAP.

OS: Xubuntu 7.10 Beta
Machine: Gateway 2000 SD4 Laptop (P4 processor)

Many Thanks!

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add your '/etc/X11/xorg.conf' file and your '/var/log/Xorg.0.log' file as attachments to your bug report? Thanks in advance.

Changed in xorg:
status: New → Incomplete
UKThom (ukthom) wrote :
Download full text (62.6 KiB)

Xorg.0.log file:

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu8)
Current Operating System: Linux worker-ant 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT 2007 i686
Build Date: 29 September 2007
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct 8 19:27:08 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "ATI Technologies Inc Radeon Mobility M6 LY"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "stylus"
(**) |-->Input Device "cursor"
(**) |-->Input Device "eraser"
(**) |-->Input Device "Synaptics Touchpad"
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
 Entry deleted from font path.
(WW) Including the default font path /usr/share/fonts/X11/misc,/usr/share/fonts/X11/cyrillic,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType.
(**) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/cyrillic,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81ea440
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.3
 X.Org Video Driver: 1.2
 X.Org XInput driver : 0.7
 X.Org Server Extension : 0.3
 X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
 compiled for 1.3.0, module version = 1.0.0
 ABI class: X.Org Video Driver, version 1.2
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,1a30 card 107b,0401 rev 05 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,1a31 card 0000,0000 rev 05 class 06,04,00 hdr 01
(II) PCI: 00:1d:0: chip 8086,2482 card 107b,0401 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1e:0: chip 8086,2448 card 0000,0000 rev 42 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,248c card 0000,0000 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,248a card 107b,0401 rev 02 class 01,01,8a hdr 00
(II) PCI...

Brian Murray (brian-murray) wrote :

Have you tried taking a screenshot of the issue at all? That may be helpful too, sorry about not thinking about it before.

Changed in xorg:
importance: Undecided → Medium
Timo Aaltonen (tjaalton) wrote :

I think this is a dupe of bug 150361. UKThom, there is a new version available, could you try that:

http://archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-video-ati/

UKThom (ukthom) wrote :

I have done the update, and am not noticing vertical lines anymore. However, I am now not able to use my scroll button on my scratchpad - I posted a question (#14769) and am thinking the two are related - but only because of the information I saw when I posted all that stuff above. I could be completely wrong, which wouldn't be out of the ordinary at all.

Thanks again for all your help!

Timo Aaltonen (tjaalton) wrote :

I don't think they are related..

thanks for testing!

l0b0 (victor-engmark) wrote :

Re-opening, I've got a similar problem, and I can't see the similarity with bug 150361.

I installed the driver using the instructions at http://wiki.cchtml.com/index.php/Ubuntu_Gutsy_Installation_Guide#Method_2:_Install_the_8.42.3_Driver_Manually. Now, whenever I start Firefox (v2.0.0.8), I get visual artifacts in the bottom right corner of the primary screen (I've got a dual screen setup with horizontal,reverse). It's kinda hard to explain how it looks, so here's an attempt at ASCII graphics:

|#|#|#|#|#|#|#|#
|#|#|#|#|#|#|#|#

|#|#|#|#|#|#|#|#

|#|#|#|#|#|#|#|#

|#|#|#|#|#|#|#|#
|#|#|#|#|#|#|#|#

Legend:
Pipes (|) are green or something similar lines which are all 1 px wide, and which are sometimes broken in some places by black.
Hashes (#) are black and all about 10-15 px wide. The height of the top and bottom horizontal bars are about 20 px, while the middle ones are about half that. The middle gap is about the same height as the middle bars, while the top and bottom gaps are slightly thinner (maybe 6 px). The desktop contents are visible in the gaps.

The artifacts stay in the same place even if I move the Firefox window.

The artifacts do /not/ show up in a screenshot of the entire desktop.

More interesting, the artifacts /disappear/ if I open the ATI Catalyst Control Center and press "OK" there. They reappear the next time I start Firefox.

I did /not/ have this problem with the previous version of the driver (8.40.something).

Hardware:
$ lspci | grep 01:00
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]

l0b0 (victor-engmark) wrote :

Could this be related to the "(WW) AIGLX: 3D driver claims to not support visual ..." lines in the X.org log? Attached file.

l0b0 (victor-engmark) wrote :

Now it turns out the artifacts return when I do certain actions within Firefox - Clicking on any email in Gmail is one such action.

Ken Collins (ken-confirmative) wrote :

I had the same problem as l0b0 when I upgraded from 8.40 driver to 8.42.3. My screen also flashes periodically.

I had the composite option disabled in my xorg.conf, so I tried enabling it, and the box seems to have gone away. My screen still flashes, though.

I'm running a dual screen horizontal setup on Ubuntu 7.10:

01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]
01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300 Pro] (Secondary)

Ken Collins (ken-confirmative) wrote :

I upgraded to version 7.11 of the driver, and the problem is actually worse.

Steven Clark (steven-p-clark) wrote :

I have the same problem as l0b0. Glitches in the bottom right corner of the screen, as well occasional glitching centered about the mouse cursor.

Timo Aaltonen (tjaalton) wrote :

Steven, Ken, l0b0:

you are all using the proprietary fglrx driver, this bug was about the free ati driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers