Add xserver-xorg-video-ati as a dependency for ubuntu-desktop/ubuntu-gnome-desktop

Bug #1484249 reported by bugproxy on 2015-08-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Add xserver-xorg-video-ati as a dependency for ubuntu-desktop/ubuntu-gnome-desktop packages, to avoid X failure to start on machines that use this x driver.

Please backport this feature to Ubuntu 14.04.

bugproxy (bugproxy) on 2015-08-12
tags: added: architecture-ppc64le bugnameltc-128494 severity-high targetmilestone-inin1510

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1484249/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Brian Murray (brian-murray) wrote :

It seems to already be a dependency in Trusty:

bdmurray@bizarro:/mnt/storage/archive-mirror$ apt-cache show xserver-xorg-video-ati
Package: xserver-xorg-video-ati
Priority: optional
Section: x11
Installed-Size: 92
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian X Strike Force <email address hidden>
Architecture: amd64
Version: 1:7.3.0-1ubuntu3.1
Provides: xorg-driver-video
Depends: libc6 (>= 2.2.5), libpciaccess0, xorg-video-abi-15, xserver-xorg-core (>= 2:1.14.99.902), xserver-xorg-video-glamoregl, xserver-xorg-
video-r128, xserver-xorg-video-mach64, xserver-xorg-video-radeon
Filename: pool/main/x/xserver-xorg-video-ati/xserver-xorg-video-ati_7.3.0-1ubuntu3.1_amd64.deb
Size: 6754
MD5sum: 19c9a679289781b67e1d282849297612
SHA1: b288e0fc84eb1a9c8db96ac2234bb43a96e5116c
SHA256: 789dd3ad5e1b800053f8d7d1df3e57d61fad8e6c6dc5e36e2a7258d0ce1bda94
Description-en: X.Org X server -- AMD/ATI display driver wrapper
 This package provides the 'ati' driver for the AMD/ATI Mach64, Rage128,
 Radeon, FireGL, FireMV, FirePro and FireStream series. This driver is
 actually a wrapper that loads one of the 'mach64', 'r128' or 'radeon'
 sub-drivers depending on the hardware.
 These sub-drivers are brought through package dependencies.
 .
 Users of Rage, Mach, or Radeon boards may remove this package only if
 they use Driver "r128", "mach64", or "radeon" in /etc/X11/xorg.conf
 instead of relying on autodetection.
 .
 More information about X.Org can be found at:
 <URL:http://www.X.org>
 .
 This package is built from the X.org xf86-video-ati driver module.
Description-md5: e44c47ee90083ed5cf59825a85aa1878
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 5y
Task: ubuntu-desktop, ubuntu-usb, kubuntu-desktop, kubuntu-active, kubuntu-active-desktop, kubuntu-active, edubuntu-desktop, edubuntu-usb, xubuntu-desktop, mythbuntu-frontend, mythbuntu-desktop, mythbuntu-backend-slave, mythbuntu-backend-master, lubuntu-core, ubuntustudio-desktop, ubuntu-gnome-desktop

Additionally, trying to install ubuntu-desktop or ubuntu-gnome-desktop in a trusty chroot pulls in xserver-xorg-video-ati. How did you determine that this is an issue?

tags: added: trusty
Changed in ubuntu:
status: New → Incomplete

------- Comment From <email address hidden> 2015-08-19 19:47 EDT-------
Hi Brian,

When this package isn't automatically installed with the desktop environment packages, X will fail to load and crash the system when a AMD graphics card is plugged in it, The following is the lspci output for the card:
0006:00:00.0 PCI bridge: IBM Device 03dc
0006:01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar GL [FirePro 2270]
0006:01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series]

I am attaching a file with the output for the following commands that were executed in a ppc64 system after a fresh install of the ubuntu-14.04.3-server-ppc64el.iso [1]:
cat /etc/lsb-release (to show ubuntu version)
apt-get install ubuntu-desktop (xserver-xorg-video-ati isn't listed in the packages that will be installed)
a[t-get install xserver-xorg-video-ati (just to show that the package is available for installation)
apt-cache show xserver-xorg-video-ati (the "Task" line with the desktop environment packages that were shown in your output aren't showing up)

Let me know if you need any additional logs.

[1] Found in http://cdimage.ubuntu.com/releases/trusty/release/

------- Comment (attachment only) From <email address hidden> 2015-08-19 19:48 EDT-------

------- Comment on attachment From <email address hidden> 2015-08-31 17:00 EDT-------

Proposed patch to add xserver-xorg-video-ati as a dependency for graphical packages by changing vars.ppc64el in the xorg source package.

Steve Langasek (vorlon) wrote :

The xserver-xorg-video-all metapackage in trusty for ppc64el does not depend on the per-hardware video driver packages, only on xserver-xorg-video-dummy. This would need adjusted in xorg.

affects: ubuntu → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: Incomplete → Triaged
Changed in xorg (Ubuntu):
assignee: nobody → Taco Screen team (taco-screen-team)
Manoj Iyer (manjo) on 2017-02-06
Changed in xorg (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers