Runlevel 2 starting GUI

Bug #14644 reported by James E. LaBarre on 2005-03-28
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Critical
Unassigned

Bug Description

The system is attempting to start the GUI for runlevels 2 & 3, when the standard
specification is that runlevel 5 is reserved for GUI startup.
This is a serious hinderance to systems where the X-server has to be manually
configured from a console *outside* the GUI, or other maintainence has to be
done before the X-server starts.

In my particular example: I am trying to set up a test configuration of Ubuntu
Hoary Hedgehog (5.04, 2005/03/10 build) in a VMware session. As Ubuntu cannot
recognize/configure the X-server in this environment, I would need to manually
configure the X-server. However, manual configuration requires me to start the
system at boot to a console-only boot (RL 3), and only RL 1 will come up in text
mode (and this severly restricts my ability to get patches).

Additionally, the error dialog that eventually comes up afer a number of GUI
startup failures will lock up the VM, and you still cannot get past that.

Running the system to default to Runlevel 5 should be sufficient to boot a
system into the preferred GUI condole.

Matt Zimmerman (mdz) wrote :

The LSB does not require specific runlevel definitions for distributions, and
the current configuration reflects Ubuntu policy.

single-user mode is provided for maintenance (an entry is added to the default
GRUB menu labeled "recovery mode")

Perhaps, but if I cannot make a test configuration work, then I cannot evaluate
the distribution, and if I cannot evaluate it, then I cannot recommend it for
anyone else.

Don't make life difficult for system administrators. If you want to ignore this,
then fine, but I think it's a big mistake which will marginalize this distribution.

Matt Zimmerman (mdz) wrote :

This default configuration reflects our policy, which is that runlevels are the
domain of the system administrator to customize. Nothing about this choice
prevents you from customizing it according to your needs: indeed, that is
precisely the rationale for the policy.

Daniel Stone (daniels) wrote :

You can stop gdm from starting in runlevels 2 and 3 if you want to; the standard
tools we ship allow for this.

In this respect, we have not moved away from Debian, which has a couple of
people using it. It is not an Ubuntu creation; indeed, runlevel 3 for console
logins and runlevel 5 for X logins is almost exclusively a Red Hatism, and is in
no way a standard across the Linux world.

Matthew Carpenter (matt-eisgr) wrote :

There is no requirement for this in the LSB, but it is strongly recommended.
Here is a package which should set up your system to run without a GUI for runlevels 1, 2, and 3. Removing the package should set you back to standard Ubuntu. This should work for all ubuntu's including Edgy and Dapper.

Christian Kujau (christiank) wrote :

The attached patch will prevent lxdm from starting in runlevel 2 (and 1, don't know why lxdm is supposed to start in RL 1). One has to edit their /etc/init/*dm.conf for the desktop manager they're using.

But I agree with James here: there's no reason to start X11 in runlevel 2. Just because some-other-distribution does it, did not seem to be a valid excuse before. And when some-other-distribution starts X11 in RL 5 and users find it practical, I'd say: go for it. But not because of a policy but because of user's "demand".

To be more specific: disable X11 in RL 2 and set the default RL to 5. Nobody would notice and power-users can just alter the default runlevel or pass "2" to the bootloader and still have a functional multi-user system but w/o X11.

Changed in xorg (Ubuntu):
status: Invalid → Confirmed

The attachment "Don't start lxdm in runlevel 1,2" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Adam Conrad (adconrad) wrote :

As stated many years ago, this is a question of local policy. "Some users want the same runlevel definitions as RedHat" isn't a critical bug in Debian or Ubuntu, it's a local decision for the admin to make, should they want to. The argument that you need a text-only runlevel for maintenance is readily solved by single-user.

Changed in xorg (Ubuntu):
assignee: Daniel Stone (daniels) → nobody
status: Confirmed → Invalid

Not quite. Single-user mode is useless if you need network connectivuty. That's the purpose of it, disabling all devices and getting to a bare running command prompt. If you instead want to work on the system *WITH* the network enabled, then a text-only runlevel is needed. Also, if you want to leave the system headless and only run GUI applications remotely, it's foolish to have a GUI running at the console.

But as I had pointed out YEARS ago when first describing this bug; if you have hardware that will need some custom tweaking, you will need network connectivity **AND** no GUI running. I know, with the headlong lemming-rush towards Wayland, the idea that someone may need to work on a text-only system is completely alien.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.