swrast.so is broken in Ubuntu 14.04

Bug #1403336 reported by Nikos Balkanas on 2014-12-17
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

I have Ubuntu 14.04 64x. I need to use libGL for a project. LibGL uses (dlopen) swrast_dri.so. Both of these are maintained by Ubuntu as specified in the package repository. When i try to run glxinfo I get:

name of display: :0
libGL: screen 0 does not appear to be DRI3 capable
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/fglrx/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/fglrx/dri/swrast_dri.so
libGL: driver does not expose __driDriverGetExtensions_swrast(): /usr/lib/fglrx/dri/swrast_dri.so: undefined symbol: __driDriverGetExtensions_swrast
libGL: Can't open configuration file /home/nikos/.drirc: No such file or directory.
libGL: Can't open configuration file /home/nikos/.drirc: No such file or directory.
libGL error: failed to load driver: swrast

This is with mesa 10.1.3. Unresolved symbols in swrast seem to go back to mesa 10.1.1. Are there any updates/patches for 14.04? Failing that, where can i dind a version that doesn't have these problems and where can I download its sources?

TIA,
Nikos

I have the same error.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-lts-transitional (Ubuntu):
status: New → Confirmed
shaomeng (shaomenglee) wrote :

I confirm this bug as 2/18/2016. Hope it get fixed soon.

Matt Stillerman (s4bhemw02) wrote :

I am experiencing this same error. I am running a straightforward Trusty instance on OpenStack. Here is what happens if I run glxgears:

ubuntu@seventh:~/trunk/bin/bin$ glxgears
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL: driver does not expose __driDriverGetExtensions_swrast(): /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so: undefined symbol: __driDriverGetExtensions_swrast
libGL: Can't open configuration file /home/ubuntu/.drirc: No such file or directory.
libGL: Can't open configuration file /home/ubuntu/.drirc: No such file or directory.
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 149 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Value in failed request: 0x0
  Serial number of failed request: 24
  Current serial number in output stream: 26

Matt Stillerman (s4bhemw02) wrote :

I have just tested Ubuntu version 16.04 LTS xenial.

glxgears now gives a different error message, but somewhat similar. We are still failing to load the swrast driver. Here is the output:

glxgears
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL: Can't open configuration file /home/ubuntu/.drirc: No such file or directory.
libGL: Can't open configuration file /home/ubuntu/.drirc: No such file or directory.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 149 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Value in failed request: 0x0
  Serial number of failed request: 28
  Current serial number in output stream: 30

John Strupp (strupp) wrote :

I get the error when I run glxinfo in an Xvnc4 session but no error when on the console.

affects: xorg-lts-transitional (Ubuntu) → xorg (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions