Please backport xtrans, libdrm, x11proto-{fonts,core} packages for 14.04.2

Bug #1400626 reported by Maarten Lankhorst on 2014-12-09
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libdrm (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned
llvm-toolchain-snapshot (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
x11proto-core (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
x11proto-fonts (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned
xtrans (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned

Bug Description

In order to upload the new xorg-server we need to backport the following packages from utopic:
libdrm
x11proto-core
x11proto-fonts
xtrans

libdrm 2.4.52-1->2.4.56-1 seems to have the following changes:
- Hides private symbols from all libdrm libraries
- fixes MSAA on Hawaii (radeon).
- Adds cherryview pci-ids (intel).
- Makes libdrm-nouveau threadsafe with concurrent access to the drm fd.
- Fixes to exynos and freedreno.
- Enables building libdrm-freedreno1 and libdrm-exynos1

x11proto-core's main change appears to be changing from the 'pointer' type to 'void *':
https://launchpadlibrarian.net/173873109/x11proto-core_7.0.24-1_7.0.26-1.diff.gz

x11proto-fonts' main change is the same as x11proto-core, but the documentation is reformatted too:
https://launchpadlibrarian.net/173873038/x11proto-fonts_2.1.2-1_2.1.3-1.diff.gz

xtrans seems to have 2 minor changes, increase default unix pipe size and add support for systemd socket activation:
https://launchpadlibrarian.net/173873112/xtrans_1.3.2-1_1.3.4-1.diff.gz

xorg needs to be slightly updated, to allow xserver-xorg to provide the unrenamed lts-utopic, and to allow xorg to be installed with the renamed xorg-server.

Related branches

summary: - Please backport some xorg packages for 14.04.2
+ Please backport xtrans, libdrm, x11proto-{fonts,core} packages for
+ 14.04.2
Changed in libdrm (Ubuntu):
status: New → In Progress
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
Changed in xtrans (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
status: New → In Progress
tags: added: lts-utopic trusty
description: updated

Hello Maarten, or anyone else affected,

Accepted libdrm into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libdrm/2.4.56-1~ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libdrm (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in x11proto-core (Ubuntu Trusty):
status: New → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Maarten, or anyone else affected,

Accepted x11proto-core into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/x11proto-core/7.0.26-1~ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in x11proto-fonts (Ubuntu Trusty):
status: New → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Maarten, or anyone else affected,

Accepted x11proto-fonts into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/x11proto-fonts/2.1.3-1~ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xtrans (Ubuntu Trusty):
status: New → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Maarten, or anyone else affected,

Accepted xtrans into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xtrans/1.3.4-1~ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Mathew Hodson (mhodson) wrote :

Hello Maarten, or anyone else affected,

Accepted xorg into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg/1:7.7+1ubuntu8.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg (Ubuntu Trusty):
status: New → Fix Committed
Timo Aaltonen (tjaalton) on 2014-12-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11proto-core - 7.0.26-1~ubuntu1

---------------
x11proto-core (7.0.26-1~ubuntu1) trusty-proposed; urgency=medium

  * Copy package back to trusty. (LP: #1400626)

x11proto-core (7.0.26-1) unstable; urgency=medium

  * New upstream release.
 -- Maarten Lankhorst <email address hidden> Tue, 09 Dec 2014 10:26:01 +0100

Changed in x11proto-core (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for x11proto-core has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11proto-fonts - 2.1.3-1~ubuntu1

---------------
x11proto-fonts (2.1.3-1~ubuntu1) trusty-proposed; urgency=medium

  * Copy package back to trusty. (LP: #1400626)

x11proto-fonts (2.1.3-1) unstable; urgency=medium

  * New upstream release.
  * Get rid of debian/xsfbs, unused.
 -- Maarten Lankhorst <email address hidden> Tue, 09 Dec 2014 10:27:24 +0100

Changed in x11proto-fonts (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xtrans - 1.3.4-1~ubuntu1

---------------
xtrans (1.3.4-1~ubuntu1) trusty-proposed; urgency=medium

  * Copy package back to trusty. (LP: #1400626)

xtrans (1.3.4-1) unstable; urgency=medium

  * New upstream release.
 -- Maarten Lankhorst <email address hidden> Tue, 09 Dec 2014 10:29:17 +0100

Changed in xtrans (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdrm - 2.4.56-1~ubuntu1

---------------
libdrm (2.4.56-1~ubuntu1) trusty-proposed; urgency=medium

  * Copy package back to trusty. (LP: #1400626)

libdrm (2.4.56-1) unstable; urgency=medium

  * New upstream release.
  * Enable building freedreno and exynos on arm. (Closes: #741509)
  * Add a squashed patch from upstream to hide all private symbols.
    - 03_hide_symbols.diff

libdrm (2.4.54-1) unstable; urgency=medium

  [ Andreas Boll ]
  * New upstream release.
  * Add 02_fix_qxl_drm_h.diff (Closes: #746807).

libdrm (2.4.53-1) unstable; urgency=medium

  [ Timo Aaltonen ]
  * New upstream release.
    - 02_kbsd_modeset.diff dropped, upstream
 -- Maarten Lankhorst <email address hidden> Tue, 09 Dec 2014 10:21:05 +0100

Changed in libdrm (Ubuntu Trusty):
status: Fix Committed → Fix Released
Mathew Hodson (mhodson) wrote :

The packge xorg still needs to be moved to trusty-updates.

tags: added: upgrade-software-version
Steve Langasek (vorlon) wrote :

Instead of uploading a new llvm-toolchain-3.5 package to trusty-proposed, let's reuse the llvm-toolchain-snapshot source package which already builds all of the relevant binaries in trusty.

Steve Langasek (vorlon) on 2015-01-26
Changed in llvm-toolchain-snapshot (Ubuntu Trusty):
status: New → Fix Committed
Changed in llvm-toolchain-snapshot (Ubuntu):
status: New → Invalid
Mathew Hodson (mhodson) on 2015-01-27
tags: removed: lts-utopic
John Gilbertson (blackcap93) wrote :

The new xorg/mesa packages should, but don't, have a "Provides: <name-of-package-being-replaced>" field in the Debian control file, to avoid breaking other installed packages which depend on the older xorg/mesa packages by name; for example, the lib-gl1-mesa-glx-lts-utopic package's control file should contain "Provides: lib-gl1-mesa-glx".

John Gilbertson (blackcap93) wrote :

Addendum: my comment above is relevant if someone chooses to install the "lts-utopic" packages from proposed on a current 14.04 system.

Harm van Bakel (hvbakel) wrote :

Installation of xserver-xorg-lts-utopic seems to pull in a bunch of unity8 packages. Is this expected behavior?

Timo Jyrinki (timo-jyrinki) wrote :

I could not reproduce what comment #15 said, only the correct packages were pulled when I upgraded with:

sudo apt install libgles2-mesa-lts-utopic libglapi-mesa-lts-utopic linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-dri-lts-utopic libegl1-mesa-drivers-lts-utopic libgl1-mesa-glx-lts-utopic:i386

However, I can confirm comment #13 in that the Mesa packages miss the Provides: so I lost my qtbase5-dev and can't reinstall it.

Other than that, all seems functioning well.

GrzesiekC (grzesiekc) wrote :

@16
Hi Timo,

Try:
sudo apt-get install libgl1-mesa-glx-lts-utopic xserver-xorg-lts-utopic xserver-xorg-core-lts-utopic

Reagards

Timo Jyrinki (timo-jyrinki) wrote :

@17: I think that's understandable that not giving enough necessary packages may make apt do wrong decisions. The upgrade is very complex package dependency wise so apt needs to be given as much information as possible so that it's able to do the correct upgrade.

I experienced the same with 12.04 LTS point releases, for example I needed to add that "libglapi-mesa-lts-xxx" at some point or otherwise I also experienced apt doing misupgrades I think during 12.04.2 -> 12.04.3 HWE stack or so.

As upgrading HWE stack from command line is an advanced operation, I think the current situation seems good (and documentable, ie just use the command I gave for example) aside from the "Provides:" problem making some packages uninstallable after the upgrade.

Harm van Bakel (hvbakel) wrote :

@18 : I now tried the upgrade again with the more complete command provided by Timo (@16) and apt now selected the correct packages. The updated stack appears to be working well.

Maarten Lankhorst (mlankhorst) wrote :

I needed to do something like apt-get install xserver-xorg-lts-utopic libegl1-mesa-drivers-lts-utopic libgl1-mesa-glx-lts-utopic:i386

John Gilbertson (blackcap93) wrote on 2015-01-29: #13
The new xorg/mesa packages should, but don't, have a "Provides: <name-of-package-being-replaced>" field in the Debian control file, to avoid breaking other installed packages which depend on the older xorg/mesa packages by name; for example, the lib-gl1-mesa-glx-lts-utopic package's control file should contain "Provides: lib-gl1-mesa-glx"

$ apt-cache show libgl1-mesa-glx-lts-utopic | grep Provides
Provides: libgl1, libgl1-mesa-glx, xorg-renamed-package, xorg-renamed-package-lts-utopic

Although the provides: libgl1 should be enough in this case, no need for an explicit libgl1-mesa-glx but it's there anyway. ;-)

I upgraded my system to the utopic stack. Unfortunately, after cleaning old config files I rebooted to find that X couldn't be started. Essentially the symlink "/etc/X11/X" got deleted. I recreated it manually (reconfiguring xserver-xorg-lts-utopic also works).

I guess this is a known issue (bug #1132736). Any way to avoid this when upgrading HWE?

Timo, I saw you were affected by this on Precise. Same thing on Trusty for you?

Timo Jyrinki (timo-jyrinki) wrote :

franglais.125: Yes, I tested it on purpose that bug #1132736 still happens on 14.04.X HWE updates for the pedantic of us that clean up removed packages' configuration bits and pieces.

Adam Conrad (adconrad) on 2015-02-09
Changed in x11proto-core (Ubuntu):
status: New → Invalid
Changed in x11proto-fonts (Ubuntu):
status: New → Invalid
Changed in xorg (Ubuntu):
status: In Progress → Invalid
Changed in xtrans (Ubuntu):
status: In Progress → Invalid
Changed in libdrm (Ubuntu):
status: In Progress → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package llvm-toolchain-snapshot - 1:3.5-4ubuntu2~trusty1

---------------
llvm-toolchain-snapshot (1:3.5-4ubuntu2~trusty1) trusty; urgency=medium

  [ Maarten Lankhorst ]
  * Copy package back to trusty. (LP: #1400626)

  [ Steve Langasek ]
  * Use the existing llvm-toolchain-snapshot source package name, which owns
    all of these binary packages in trusty.
 -- Steve Langasek <email address hidden> Mon, 26 Jan 2015 10:57:53 -0800

Changed in llvm-toolchain-snapshot (Ubuntu Trusty):
status: Fix Committed → Fix Released
Mathew Hodson (mhodson) wrote :
Florian W. (florian-will) wrote :

Is there any way to preserve wine, libsdl-*-dev and qt5 when installing the hardware enablement bits on 14.04 (with -proposed disabled)?

I tried the suggested apt command lines, but none of them seemed to install the new mesa/xorg stack and preserve wine/qt5/libsdl at the same time. See the attached apt output.

Maarten Lankhorst (mlankhorst) wrote :

Add libgl1-mesa-glx-lts-utopic:i386 to your line..

Florian W. (florian-will) wrote :

Thanks, Maarten. I just noticed my comment was missing the apt command that I used.

I now use

> LANG=C sudo apt install --install-recommends libgles2-mesa-lts-utopic libglapi-mesa-lts-utopic linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-dri-lts-utopic libegl1-mesa-drivers-lts-utopic libgl1-mesa-glx-lts-utopic:i386

and now wine is preserved. However, I still lose qt5-default, qtbase5-dev and some other qt5 libs, and also libsdl2-2.0-0 and related sdl libs, and some random other libs where I'm not sure I really need them (I guess not). Adding qt5-default and qtbase5-dev to the command leads to http://paste.ubuntu.com/10141032/ (I already have the utopic kernel, so that note there by apt is correct).

I'm not sure if this is a bug in one of the backported packages, or another package, or even my system setup or apt skills. Since #16 and #13 apparently had the same issue, it might be related. Let me know if this is not the right place to post this. :-)

Florian W. (florian-will) wrote :

I tried this again now, and after installing libgl1-mesa-dev-lts-utopic I was able to re-install qt5-default and qtbase5-dev, and then ubuntu-sdk.

Mathew Hodson (mhodson) wrote :

This bug was fixed in the package xorg 1:7.7+1ubuntu8.1

---------------
xorg (1:7.7+1ubuntu8.1) trusty-proposed; urgency=medium

  * Fixup the xorg packages to work correctly with the renamed lts stack.
 -- Maarten Lankhorst <email address hidden> Thu, 09 Oct 2014 11:55:01 +0200

Changed in xorg (Ubuntu Trusty):
status: Fix Committed → Fix Released
job (jeppekdahl) on 2015-03-15
Changed in xorg (Ubuntu Trusty):
assignee: nobody → job (jeppekdahl)
Changed in libdrm (Ubuntu Trusty):
assignee: nobody → job (jeppekdahl)
Changed in x11proto-fonts (Ubuntu Trusty):
assignee: nobody → job (jeppekdahl)
Po-Hsu Lin (cypressyew) wrote :

Reverting job (jeppekdahl)'s changes

Changed in libdrm (Ubuntu Trusty):
assignee: job (jeppekdahl) → nobody
Changed in x11proto-fonts (Ubuntu Trusty):
assignee: job (jeppekdahl) → nobody
Po-Hsu Lin (cypressyew) on 2015-04-01
Changed in xorg (Ubuntu Trusty):
assignee: job (jeppekdahl) → nobody
Mathew Hodson (mhodson) on 2015-08-21
Changed in libdrm (Ubuntu Trusty):
importance: Undecided → High
Changed in libdrm (Ubuntu):
assignee: Maarten Lankhorst (mlankhorst) → nobody
importance: High → Undecided
Changed in xorg (Ubuntu Trusty):
importance: Undecided → High
Changed in xtrans (Ubuntu Trusty):
importance: Undecided → High
Changed in xorg (Ubuntu):
importance: High → Undecided
milestone: ubuntu-14.04.2 → none
assignee: Maarten Lankhorst (mlankhorst) → nobody
Changed in xtrans (Ubuntu):
assignee: Maarten Lankhorst (mlankhorst) → nobody
importance: High → Undecided
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments